Safari 9.1.3 ne prend plus les clics souris

pecos

Membre junior
19 Janvier 2003
24
0
www.potemplier.net
Salut à tous.
Sur une des mes partitions système avec Mavericks 10.9.5 (j'en ai besoin pour faire tourner certains softs...) avec un iMac 27" 2010, j'ai eu le malheur de mettre à jour Safari vers la dernière version compatible, la 9.1.3.

Résultat : plusieurs fois par jour, safari n'accepte plus aucun clic de souris.
Ça arrive en sortie de veille (pas systématiquement) ou quand Safari a été laissé longtemps en arrière plan.
Aléatoirement.

Aucun lien, bouton, onglet, etc. ne peut plus être cliqué.
Mais uniquement sur safari, pas sur le système et les autres applications !

Par contre les menus de Safari fonctionnent tous (à la souris) et les raccourcis clavier aussi.
On peut ainsi avec ctrl+tab changer d'onglet, ou le fermer avec cmd+W.
On peut recharger la page avec cmd+R, etc.

Le seul moyen de récupérer un safari fonctionnel est de
- quitter safari
- relancer Safari
- menu Historique : "rouvrir toutes les fenêtres de la dernière session".
C'est très chiant.

Est ce que quelqu'un sait d'où ça vient ?
Est ce que ce souci est connu ?

Que faire ?
Merci d'avance.
 

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
4 106
988
Dole 39
Peut-être réinitialiser Safari via le terminal, mais je ne connais pas cette ligne de commande !

Fouille un peu ici, tu devrais trouver.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 625
3 641
Là-haut
C'est un problème d'affichage, voire de contrôle souris pas de Safari. Réinitialiser ne servira à rien à part perdre des réglages et données.

Je suis resté longtemps avec Mavericks et je n'ai jamais eu quelques chose de ce genre.

C'est quoi comme souris ?
 

pecos

Membre junior
19 Janvier 2003
24
0
www.potemplier.net
C'est une tablette wacom qu j'utilise depuis 10 ans et qui fonctionne parfaitement, pas une souris.
Mais le problème ne touche vraiment QUE safari.
Je suis en train de faire des tests : j'ai désactivé addblock et installé ublock à la place, et pour l'instant le problème a disparu (mais ça ne fait que 24 heures).
Il me faut plus de temps pour voir si ça vient de cette extension.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 625
3 641
Là-haut
Perso, j'ai banni tous ces Adblock & Co : ils bouffent trop de Ram. Le jour où j'ai commencé à naviguer sans, j'ai diminué la consommation de Ram de près de moitié.

Je n'ai conservé que Ghostery. Les grosses saletés (outbrain, taboola, ligatus, criteo, etc) je les bloque en plus directement dans Little Snitch.