Safari problème avec raccourcis clavier onglet suivant

2be3

Membre enregistré
18 Août 2002
9
0
Bonjour

je constate à force d'utiliser différents Macs que safari n'a pas toujours le même raccourcis clavier pour passer aux onglets suivant.

Chez moi, chez un ami et sur quelques autres postes, c'est pomme+shift+ <- ou ->
Sur plein d'autres machines, c'est le plus pratique pomme+alt+ <- ou ->

Et j'aimerai bien pouvoir moi aussi avoir ce raccourci plus pratique, mais j'arrive pas à trouver où on peut changer ce paramètre et surtout pourquoi cette différence d'une machine à l'autre ?

Merci par avance
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 161
1 029
Toulouse.cong
faq.office.macintosh.free.fr
Chez moi (Safari 3.1.2, clavier français) c'est Commande-Option-( et Commande-Option-) (indiqué Commande-{ et Commande)-} dans le menu "Fenêtres").

La cause de ces variantes je ne la connais pas (mais la langue et le type de clavier ont peut-être un rôle dans l'histoire). Pour modifier les raccourcis, normalement, c'est dans le panneau de préférences "Clavier et souris" que ça se passe, onglet "Raccourcis clavier", tout en bas de la liste.
 

2be3

Membre enregistré
18 Août 2002
9
0
Chez moi (Safari 3.1.2, clavier français) c'est Commande-Option-( et Commande-Option-) (indiqué Commande-{ et Commande)-} dans le menu "Fenêtres").

La cause de ces variantes je ne la connais pas (mais la langue et le type de clavier ont peut-être un rôle dans l'histoire). Pour modifier les raccourcis, normalement, c'est dans le panneau de préférences "Clavier et souris" que ça se passe, onglet "Raccourcis clavier", tout en bas de la liste.

J'avais oublié de le préciser, donc je suis sur Safari 3.1.2 sur 10.5.5 régler en français avec un clavier français de mon macbook pro.

Dans les préférences Clavier, je vois rien pour safari, et quand je veux le rajouter à la main avec le +, cela change rien.
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 161
1 029
Toulouse.cong
faq.office.macintosh.free.fr
quand je veux le rajouter à la main avec le +, cela change rien.
Qu'est-ce à dire ?
- Lorsque tu cliques sur le +, tu n'as pas une fenêtre qui s'ouvre, te demandant l'application concernée (par un menu déroulant), la saisie du texte exact du menu concerné(en fait de l'option de menu, et il faut taper exactement le texte voulu) ainsi que le raccourci souhaité ?
- Ou une fois que tu as fait ça et validé, ça ne donne toujours pas le résultat attendu ?
 

2be3

Membre enregistré
18 Août 2002
9
0
Qu'est-ce à dire ?
- Lorsque tu cliques sur le +, tu n'as pas une fenêtre qui s'ouvre, te demandant l'application concernée (par un menu déroulant), la saisie du texte exact du menu concerné(en fait de l'option de menu, et il faut taper exactement le texte voulu) ainsi que le raccourci souhaité ?
- Ou une fois que tu as fait ça et validé, ça ne donne toujours pas le résultat attendu ?

oui oui, j'ai bien fais comme ça, j'ai tapé comme dans le menu et cela ne marche pas.
 

anic297

Membre enregistré
5 Janvier 2009
5
0
J'ai une solution payante (avec un produit qui, de toutes façons, vaut le coup).
À l'aide de l'application "MenuMaster", on peut changer les raccourcis des menus. On laisse la souris sur un menu, on presse quelques touches (ou une seule, mais c'est pas pratique à utiliser ;)) et le menu acquiert l'entrée en tant que raccourcis.
Je viens de le tester, pour être sûr que ça marche aussi quand il y a déjà un raccourcis prédéfini. Donc, oui, ça marche.

Pour les différences évoquées dans le message de base (certains ont un raccourcis et d'autres en ont un autre), ne serait-ce pas une différence de version? (du genre Safari 3 et Safari 2, ou de l'OS?)
 

Crevettegirl

Membre enregistré
22 Mai 2011
2
1
bonjour,

je ne sais pas si tu as réussi à résoudre ton problème mais as-tu tapé le bon apostrophe quand tu as écrit "Sélectionner l’onglet suivant" ? Il faut faire attention car avec le clavier Mac la touche apostrophe, fais un apostrophe tout droit ' et non pas le bel apostrophe ’ (touches 4 + alt + shift).
J'espère que ça pourras t'aider!
 

2be3

Membre enregistré
18 Août 2002
9
0
bonjour,

je ne sais pas si tu as réussi à résoudre ton problème mais as-tu tapé le bon apostrophe quand tu as écrit "Sélectionner l’onglet suivant" ? Il faut faire attention car avec le clavier Mac la touche apostrophe, fais un apostrophe tout droit ' et non pas le bel apostrophe ’ (touches 4 + alt + shift).
J'espère que ça pourras t'aider!

J'avais réussis à résoudre le problème lors d'une mise à jour système et/ou de safari il y a longtemps. Mais là le problème était revenu, et ta solution m'a sauvé. Merci :)