Serveur réseau apparaît dans "appareils" sur une session

ccciolll

Membre expert
Club MacG
Bonjour,

J'ai un comportement curieux sur un poste que je n'ai pas l'habitude d'utiliser.

Habituellement, de chez moi, je me connecte au serveur de l'usine en pomme-k afp://… après avoir lancé une connexion sécurisé Junos Pulse.

En ce moment, je dois me rendre à cette usine pour travailler (remplacement de collègue en congés), donc le serveur est en local.

J'ai récupéré un poste inoccupé (la personne que je remplace) et m'y suis fait une session user perso avec mes réglages et mes extensions (default folder, copypaste, etc…)

Mais la connexion au serveur est très lente. Vraiment très lente. Pourtant il est en local, à priori.

J'ai donc comparé avec la session du collègue absent.

Chez lui, les disque du serveur s'affichent dans la barre latérale dans "appareils", et dans "Imac de untel".
Pas sur ma session.
(évidemment, j'ai mis les mêmes prefs de finder…)

J'ai essayé d'ouvrir les infos des serveurs affichés.
des deux côtés, ils sont identiques :
Type : volume
Serveur : afp://adresseIP/NomDuVolume
Format AppleShare

sauf une fois (allez savoir pourquoi une seule fois) où il m'a affiché, sur la session du collègue
Type : volume
Serveur : afp://nomduserveur._afpovertcp._tcp.local/NomDuVolume
Format AppleShare

Il y a peut-être un truc à creuser par là ?

Pour info : inutile d'espérer trouver qui que ce soit capable de m'indiquer la procédure pour se connecter au serveur dans l'usine, le plaisir d'un grand groupe international…

---------- Nouveau message ajouté à 11h33 ---------- Le message précédent a été envoyé à 09h42 ----------

Je me demande si je ne pourrais pas tenter d'analyser la "façon" dont ma session se connecte et la comparer à la session existante.

peut-être avec le Terminal, avec une action genre ifconfig ou netstat (allez pas croire que je connais le terminal, je copie juste des actions que j'avais utilisées antérieurement pour déterminer la connexion par VPN)

En fait, je soupçonne ma session de se connecter au serveur local en passant par le réseau extérieur (internet, quoi).

Ce qui est royalement con.

Et vu que la connexion ici, c'est de la boue (et je reste poli), forcément, ça marche pas bien.

EDIT : pour info, j'ai récemment installé WireShark sur ce poste, peut-être y-a-t'il dedans des outils qui pourraient me servir à faire cette comparaison ?

---------- Nouveau message ajouté à 11h42 ---------- Le message précédent a été envoyé à 11h33 ----------

Encore pour info, voilà le résultat d'un test de ping depuis le terminal.
Je ne sais pas si c'est révélateur du débit catastrophique que j'ai ici.

ping -c 5 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: icmp_seq=0 ttl=36 time=203.510 ms
Request timeout for icmp_seq 1
64 bytes from 8.8.8.8: icmp_seq=2 ttl=36 time=83.525 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=36 time=182.058 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=36 time=97.562 ms

--- 8.8.8.8 ping statistics ---
5 packets transmitted, 4 packets received, 20.0% packet loss
round-trip min/avg/max/stddev = 83.525/141.664/203.510/51.918 ms
 

ccciolll

Membre expert
Club MacG
J'ai tapé traceroute dans Terminal
il me donne ça
Bloc de code:
Version 1.4a12+Darwin
Usage: traceroute [-adDeFInrSvx] [-A as_server] [-f first_ttl] [-g gateway] [-i iface]
	[-M first_ttl] [-m max_ttl] [-p port] [-P proto] [-q nqueries] [-s src_addr]
	[-t tos] [-w waittime] [-z pausemsecs] host [packetlen]

Mais comme j'ai en même temps le serveur "local" et internet de connectés, il mélange peut-être les deux, comment savoir qui va où ?
 

drs

Oh ouiiiiiiiii !
Club MacG
J'ai tapé traceroute dans Terminal
il me donne ça
Bloc de code:
Version 1.4a12+Darwin
Usage: traceroute [-adDeFInrSvx] [-A as_server] [-f first_ttl] [-g gateway] [-i iface]
	[-M first_ttl] [-m max_ttl] [-p port] [-P proto] [-q nqueries] [-s src_addr]
	[-t tos] [-w waittime] [-z pausemsecs] host [packetlen]

Mais comme j'ai en même temps le serveur "local" et internet de connectés, il mélange peut-être les deux, comment savoir qui va où ?

Avec la table de routage. Le réseau local a une métrique inférieure au réseaux distants, donc il sait qu'il doit aller le chercher en local.

Pour le traceroute il faut taper ensuite l'adresse IP (ou le nom DNS) de destination, par exemple:
traceroute 192.168.10.10
traceroute google.com
 

edd72

Membre expert
Club MacG
14 Avril 2010
9 850
283
Si l'adresse IP (celle dans ton afp://) n'est pas un IP locale (10.x.x.x, 172.x.x.x, 192.x.x.x selon la classe du réseau) mais une adresse web alors il est tout à fait possible qu'il passe par le web (si le cache ARP est mal géré).

Maintenant, c'est vrai qu'utiliser le nom du serveur (nommachine.local souvent pour une machine OSX) dans ton AFP serait une bonne idée.
 

ccciolll

Membre expert
Club MacG
Je viens de tester :

traceroute MonServeur.local
traceroute to MonServer.local (10.24.xxx.xxx), 64 hops max, 52 byte packets
1 10.24.xxx.xx (10.24.xxx.xxx) 4.194 ms 3.837 ms 4.056 ms

Donc vu comme ça par un newbie, ça me donne qd-même l'impression qu'il ne fait pas de détours inutiles. Il serati donc bien connecté en local, par le ethernet.
Mais comment expliquer cette lenteur atroce quand je me connecte à ce serveur (la lenteur est telle que ça fait souvent figer le finder complet pendant plusieurs secondes, même quand je cherche à ouvrir des fichiers présents sur mon DD, sans toucher aux fenêtres du serveur.
 

ccciolll

Membre expert
Club MacG
Donc ce serveur est un gros veau…