SL - Problème depuis la dernière mise à jour.

Pierro19

Membre enregistré
3 Janvier 2011
7
0
Chers tous,

Avant de poster j'ai parcouru le forum pour voir si ce problème à déjà été posté, mais je n'ai rien trouvé.

Depuis la dernière mise à jour de Snow Leopard paru le 19/09/2012, j'ai quelques petits problèmes avec Mails, le Mac AppStore et QuickTime.
J'ai essayé de les lancer suite à la mise à jour est impossible. Mails et Quicktime ne se lance pas, et le Mac AppStore m'affiche un message d'erreur me disant qu'il ne peut pas s'ouvrir car l'application est "peut être endommagée ou incomplète".
Me basant sur ce dernier message, je me suis dis que l'installation avait du mal se passer. J'ai donc désinstaller ces applications et re-téléchargé et installé la mise à jour depuis le site d'Apple. Malheureusement le problème persiste... :(

Quelqu'un a-t-il le même problème ou trouvé une solution?

Pour information, si cela peut rentrer en ligne de compte, j'ai un iMac 27' de 2011.

Merci d'avance pour votre aide. :)
 

olekhnov

Membre confirmé
9 Octobre 2004
62
6
48
Clermont Fd enfin à coté
jd.olek.fr
J'ai exactement le même souci...

J'ai tenté de rectifier le tir en réinstallant une Combo 10.6.8, et c'est pire : maintenant, Safari ne se lance pas non plus :(

Si tu as pu trouver des éléments de réponse, je suis preneur (je continue à chercher...)
 

Pierro19

Membre enregistré
3 Janvier 2011
7
0
Hello,

J'ai toujours pas trouvé de réponse. Pas de MacAppStore... Tant pis je pensais peut être faire la mise à jour vers Mountain Lion...

Merci pour la mise en garde sur l'installation d'une Combo.

Je vais peut être contacter le support technique d'Apple. Je sais pas ce qu'ils valent mais on verra bien.
 

olekhnov

Membre confirmé
9 Octobre 2004
62
6
48
Clermont Fd enfin à coté
jd.olek.fr
Pour l'appli Mail, j'ai eu un début de réponse : le patch de sécurité inclus un nouvelle version de Mail qui semble poser problème dans certains cas...

D'après ce que j'ai lu, ça arrive lorsqu'on avait déplacé la précédente appli mail dans un autre répertoire que "Applications", ou qu'on l'a renommé. Il n'y retrouve plus ses petits, et fait sa mise à jour n'importe comment.

Dans mon cas, la réinstallation du combo + réinstallation de Mail via l'outil Pacifist + repassage du patch de sécurité a permis de retrouver l'appli Mail... mais elle ne marche toujours pas, apparemment la migration des données s'est mal passée...
 

olekhnov

Membre confirmé
9 Octobre 2004
62
6
48
Clermont Fd enfin à coté
jd.olek.fr
Je me répond à moi même, car j'ai trouvé une issue de sortie, des fois que ça serve à d'autres !

Bon, déjà, passer le combo 10.6.8 est une fausse bonne idée : ça n'a fait que donner un OS assez bizarre, mix d'éléments 10.6.8 et d'autres restant patchés.

Effacer les .app est également une mauvaise idée

Le seul truc que j'ai pu réussir à faire "proprement" est de laisser les anciennes .app, éventuellement en les renommant avec leur nom d'origine et les replaçant dans /Applications pour que tout retombe sur ses pattes, puis ensuite j'ai extrait les mises à jour depuis le patch de sécurité, avec l'outil Pacifist, en précisant bien à chaque fois "Mettre à jour" : en effet, si l'on prend ces patchs pour écraser l'ancienne appli, il va manquer des fichiers

Une fois ces règles suivies, ça devrait revenir dans l'ordre... Enfin, ça marche pour moi !
 

baduroux

Membre enregistré
24 Septembre 2012
1
0
Je me répond à moi même, car j'ai trouvé une issue de sortie, des fois que ça serve à d'autres !

Bon, déjà, passer le combo 10.6.8 est une fausse bonne idée : ça n'a fait que donner un OS assez bizarre, mix d'éléments 10.6.8 et d'autres restant patchés.

Effacer les .app est également une mauvaise idée

Le seul truc que j'ai pu réussir à faire "proprement" est de laisser les anciennes .app, éventuellement en les renommant avec leur nom d'origine et les replaçant dans /Applications pour que tout retombe sur ses pattes, puis ensuite j'ai extrait les mises à jour depuis le patch de sécurité, avec l'outil Pacifist, en précisant bien à chaque fois "Mettre à jour" : en effet, si l'on prend ces patchs pour écraser l'ancienne appli, il va manquer des fichiers

Une fois ces règles suivies, ça devrait revenir dans l'ordre... Enfin, ça marche pour moi !

BRAVO BRAVO BRAVO olekhnov !!!! :p
Tu es le meilleur !!! Franchement je n'y croyais plus et j'ai essayé un bon nombre de solutions mais là, celle là il fallait aller la chercher ! :rateau:
Ca marche à la perfection et ça m'a évité de faire le combo 10.6.8 !!!

Pour info pour les autres, j'amène ma ptite précision => je ne connaissais pas "PACIFIST", c'est excellent mais il faut connaitre les étapes (olekhnov ne le précisait pas car il connait) donc les voici :

- Ouvrir PACIFIST
- Choisir "ouvrir un paquet"
- indiquer le chemin vers la MAJ pourrie d'Apple sur votre disque
- Cliquer sur les flèches devant les noms d'applis jusqu'à trouver "MAIL.app"
- Faire un clic droit dessus et choisir "installer a l'endroit par défaut"
- C'est à ce moment là qu'il vous proposera plusieurs choix dont le fameux "METTRE A JOUR ?" dont a parlé olekhnov !
- Voilà ça marche :)

Merci encore 1000 fois olekhnov :up: