Solution aux caractères illisibles dans Mail : envoi de mail lisible (encodage)

cheb

Membre confirmé
18 Janvier 2005
309
5
Un peu de partout !
:zen:Bonjour à tous,:zen:

Je crois que j'ai trouvé une solution pour éviter le pbms de courriels illisibles du style "j'ai @t% enchant% (au lieu de "j'ai été enchanté ..)", cela me les brisait depuis un petit moment, donc j'ai décidé de faire une recherche sur le forum et via l'app Mail et ma boite yahoo (ouverte via mon navigateur firefox), j'ai pu comparer mes mails envoyés et leurs réceptions dans Yahoo... afin devoir quel encodage choisir.

Voici ma prospection, qui je pense va aider beaucoup de monde (merci, merci ... via la boule disco !.. oh l'autre il fait du racket !:love:)

Voici mon test :
Avant toute chose j'ai fais cette modification (voir ici pour mettre UTF8 comme mode "Automatique"), mais si vous ne l'avez pas faite... ne le faite pas :D! Fermez "Mail", allez dans le "Terminal" tapez cette ligne de code (copiez/collez) : (pour revenir à la configuration par défaut) :

defaults delete com.apple.Mail NSPreferredMailCharset


TEST : envoi d'un courrier en français puis un autre en vietnamien (car les caractères en quốc ngũ (vietnamien) ne passe pas non plus...)

Courrier Français, avant de l'envoyer "Message > Encodage> et choix du mode encodage :
- Iso windows latin 1 (WL1)+ rtf : réussi
- automatique (donc mode UTF8) + RTF : ECHEC

Donc le format Iso windows choisi permet de transmettre le mail sans soucis, même en RTF... très intéressant ! Donc pourquoi ne pas le mettre directement en mode "automatique" ?

Si tôt dis .... si tôt fait ! Donc en utilisant la manip vu sur ce post : http://forums.macg.co/vbul...43&postcount=8

on ouvre le Terminal, et on indique cette formule (magique où on remplace "UFT-8" par "windows latin 1") :
defaults write com.apple.mail NSPreferredMailCharset “windows latin 1"

Et là rebatterie de test, et cela marche !
auto (modification dans le terminal de UFT-8 à wl1) + Rtf : réussi
essai UTF8 + RTF : ECHEC
auto + RTF : Réussi
:up::up::up::up::up::up:

Donc le mode windows latin 1 permet l'envoi des accents (du moins pour moi), et autre caractères, et avec cette manip, tout cela est automatique !:up:

Courrier vietnamien, par contre pas de solutions via "apple mail" :eek: ... incroyable ... car voici les essais (infractueux) :

UFT8 + RTF = echec
Automatique (UTF-8) : echec
UFT8 : echec
automatique (WL1) : ECHEC
auto (WL1) + police Arial : ECHEC

Seule solution pour les envois en vietnamien ... passer directement via Yahoo mail ! A défaut de trouver une solution un jour .... et oh, steve tu fais quoi ? Pas la peine de te la ramener avec la "facilité des macs ..."
 

Jacques L

Membre d’élite
Club MacG
4 Septembre 2004
1 508
61
Saint Maur des Fossés
j'ai essayé de mettre en pratique ce qui est indiqué ci-dessus, mais quand je rentre la commande de retour au réglage d'origine j'ai ça

Last login: Mon Apr 21 23:31:58 on ttyp1
Welcome to Darwin!
Ibook-Jacques:~ jacques$ defaults delete com.apple.Mail NSPreferredMailCharset
2008-04-21 23:56:36.075 defaults[2567]
There is no (NSPreferredMailCharset) default for the (com.apple.Mail) domain.
Defaults have not been changed.
Ibook-Jacques:~ jacques$

quand je fais le changement vers WL1 ça donne ça (après avoir corrigé le guillemet " courbe)

Last login: Mon Apr 21 23:50:07 on ttyp1
Welcome to Darwin!
Ibook-Jacques:~ jacques$ defaults write com.apple.mail NSPreferredMailCharset "windows latin 1"
Ibook-Jacques:~ jacques$

je n'ai plus que automatique de disponible dans encodage texte, je dis bien que parce aucune autre option n'est disponible, ni apparente, ni grisée, est-ce normal?

OSX 10.4.11 - ibook 1,42GHz - 1,5 Go DDR SDRAM
 

lepetitpiero

Vétéran
Club MacG
20 Août 2005
8 085
376
48
www.pierrecourtial.com
Bonsoir,

C'est une astuce connue de tous les lecteurs de l'excellente revue Avosmac :D

Détail c'est utile pour Mail version 1 et 2 la version n°3 gère correctement l'encodage si je ne dis pas de bêtises

Pierre