MacBook Pro SSD: boot impossible si interne mais boot en externe

Emelyss

Membre enregistré
25 Décembre 2019
6
0
41
Bonjour!

J'ai été missionné par ma copine pour donner un coup de jeune à son mac (mi 2012, Yosemite 10.10.5). Ni une, ni deux, j'envisage de remplacer le HDD par un SSD. J'ai utilisé CCC pour cloner le DD sur le SSD en suivant les instructions que je détaillerai plus bas.

Or impossible de booter quand le SSD est en place (comprendre relié par la nappe, à l'intérieur du mac). En revanche il boot très bien dans son petit boitier USB externe.

J'ai parcouru plein de topics, merci au passage à ceux qui ont pris le temps de répondre, c'est génial.
Je n'ai cependant pas réussi à régler le problème.

Serait-ce un problème de nappe comme parfois évoqué? Ou est-ce un problème avec le TRIM (je ne sais pas ce que c'est; toujours est-il que j'ai essayé par la suite de le désactiver sur le SSD en envoyant une commande dans le terminal),...

Je reprends: tout a commencé par le clonage grâce à CCC. Je reprends les propos de macomaniac sur un autre topic car c'est exactement la procédure que j'ai suivi:
"Laissant mon HDD en place, j'ai placé le SSD vierge dans un boîtier USB. Par l'«Utilitaire de Disque», j'ai initialisé logiquement le SSD en Table de partition GUID et le volume destiné à accueillir l'OS au format Mac OS étendu (journalisé) comme requis. Puis, grâce au logiciel de clonage Carbon Copy Cloner, j'ai cloné la version d'OSX alors existante sur mon HDD interne sur mon SSD externe - opération que «CCC» effectue avec clonage parallèle de la partition de récupération invisible «Recovery HD». Cette opération effectuée, j'ai vérifié par un démarrage avec 'alt' que je pouvais démarrer sur le SSD placé en externe et apparaissant désormais à l'écran des disques démarrables car supportant un Système bootable, et j'ai alors ouvert mon Mac pour remplacer le HDD par le SSD".

Lorsque je mets le SSD en place (à l'intérieur du mac), un point d'interrogation dans un dossier gris apparaît et clignote.

J'ai assez peu de connaissance en mac et suis vite perdu...

Un peu d'aide ne serait pas de refus.

Bonnes fêtes à tous :)
 

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
4 182
1 061
Dole 39
Salut,

Tu peux assurément commander une Nappe Sata ...

Chez Macway ou IfiXit, pas chez Am...

Personnellement je change les Nappe d'office ! ( 50€ )
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
54 986
10 512
Nancy___
J'ai été missionné par ma copine pour donner un coup de jeune à son mac (mi 2012, Yosemite 10.10.5).
Pas mieux que les propos de Fullcrum :up:

Les MBP 2012 sont connus pour avoir la nappe qui flanche, surtout quand on met un SSD pour remplacer le dd.
 
Dernière édition:

Invité

Pommé
Club MacG
19 Février 2005
8 760
642
21000 ou 22740
Si c'est un MBP 2012 (voir 2011 déjà expérimenté) le coupable est presque toujours cette nappe.

En revanche, j'ai déjà vu que le seul fait que le SSD soit branché en interne empêchait le boot même sur un disque externe.
Mais c'est pas un bug c'est un(e) feature…
 

Emelyss

Membre enregistré
25 Décembre 2019
6
0
41
Bonjour à tous, merci pour vos conseils éclairés, le remplacement de la nappe (arrivée drôlement vite!) a réglé le problème! C'est super, ca va nettement plus vite. Pour information, la nappe m'a couté 14€.

Encore merci :)

Bonnes fêtes
 

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
4 182
1 061
Dole 39
Salut,

C’est bien pour toi, ça ne pouvait être que ça .

la nappe m’a couté 14€.
Tu ne m’as pas écouté ... attends-toi, un jour, un mois, une année ( sûrement avant ) de devoir acheter une vraie Nappe comme dit plus haut. Ce n’est pas pour rien que je te donnais Macway ou IfiXit pour l’achat de cette Nappe.
J’espère me tromper ...
 
  • J’aime
Réactions: peyret

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
4 182
1 061
Dole 39

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
4 182
1 061
Dole 39
Je note quand même que je suis resté à 50€, alors que maintenant c’est 36€ chez IfiXit.
(Dernier MacBook Pro optimisé date de cet été)

PS: j’avoue être un poil exigent ... j’ai mes habitudes, les Nappe c’est IfiXit, SSD et RAM c’est Crucial, y’a moins cher, mais c’est moins bien aussi, je n’ai jamais eu de retour des Mac je suis intervenu avec ces composants. Note que pour un SSD d’autres marques existent et ne sont pas mal aussi, mais j’aime Crucial. Idem pour la RAM, tu peux trouver de la DDR moins cher que les Crucial.
 

Corwiiin

Membre enregistré
1 Mars 2020
3
0
29
Bonjour à tous,

Après avoir suivi scrupuleusement le même protocole, nje suis exactement dans la même situation que Emelyss sauf que j'ai remplacé la nappe SATA et que cela n'a rien changé au problème.
Le SSD marche sans problème sur un boitier externe mais en interne : dossier avec le point d'interrogation au démarrage.
Le disque HD marche sans problème en interne.

Je commence à perdre espoir.
D'autres idées vous viendraient elles en tête ?

Merci d'avance
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
54 986
10 512
Nancy___
Bonjour,

Bonjour à tous,

Après avoir suivi scrupuleusement le même protocole, nje suis exactement dans la même situation que Emelyss sauf que j'ai remplacé la nappe SATA et que cela n'a rien changé au problème.
Le SSD marche sans problème sur un boitier externe mais en interne : dossier avec le point d'interrogation au démarrage.
Le disque HD marche sans problème en interne.
Nappe achetée où ? Payée combien ?
 

Invité

Pommé
Club MacG
19 Février 2005
8 760
642
21000 ou 22740
Des fois, je ne regrette pas mes achats chez Macway ou OWC
C'est plus cher, mais je n'ai jamais eu ce soucis après changements (que 4 mais quand même)
 

Corwiiin

Membre enregistré
1 Mars 2020
3
0
29
Je ne suis pas contre racheter une nappe en revanche j'ai un peu de mal à comprendre pourquoi la nappe marche parfaitement avec l'ancien disque HD et pas du tout avec le SSD...
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
54 986
10 512
Nancy___
Je ne suis pas contre racheter une nappe en revanche j'ai un peu de mal à comprendre pourquoi la nappe marche parfaitement avec l'ancien disque HD et pas du tout avec le SSD...
Parce que les débits (lecture-écriture) d'un disque dur sont faibles par rapport aux débits d'un SSD. Donc une nappe de "mauvaise" qualité peut suffire pour les débits d'un dd, mais pas pour un SSD.