MacBook Pro SSD Crucial M550 512 Go ...lent

bulrog

Membre junior
29 Juillet 2007
96
2
Bonjour,

J'ai un MacBook Pro 13" mid-2012

J'ai installé un SSD M550 de Crucial (512 Go) il y a 2-3 ans. Jusqu'ici, tout allait bien mais je viens de constater que la vitesse en écriture est vraiment faible. Avec Blackmagic, j'arrive à peine à 40 MB/s en écriture contre 450 MB/s en lecture. De mémoire, les 2 tests étaient, au début, les mêmes.

Avez-vous une idée de ce qui peut brider le disque à ce point ? Il est loin d'être saturé... je n'utilise que 180 Go
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 894
3 141
C'est sans doute que tu n'as pas bidouillé le système pour qu'il applique la commande TRIM à ton SSD.

Lorsqu'on écrit sur une cellule de SSD, si elle est libre, c'est rapide ; si elle ne l'est pas, c'est plus lent. D'où l'intérêt de la commande TRIM à passer lorsqu'on a supprimé des fichiers.
Par défaut, macOS n'effectue cette commande que lorsqu'on utilise un SSD officiel de ses ordinateurs. Dans le cas contraire, pas de TRIM...
On peut forcer la main du système pour le faire :
  • jusqu'à Yosemite, il faut modifier un module du système, de manière non officielle ;
  • depuis El Capitan, on peut passer la commande :
    Bloc de code:
    sudo trimforce enable
    pour dire au système de prendre en compte tout SSD (voir ce fil et cette description).
 
Dernière édition:

bulrog

Membre junior
29 Juillet 2007
96
2
Oui, c'est cela. Merci. Je viens de comprendre en cherchant sur internet...

Je l'avais activé sur El Capitan mais lors de la mise à jour vers Sierra, ce truc a du sauter. J'ai refais le test et cela me donne +- 400/450 MB/s en écriture comme en lecture.

Avis à tous ceux qui ont un SSD tiers dans un Mac : n'oubliez pas de vérifier si le trim est resté activé lors de mises à jours.

Merci.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
33 007
3 689
Dans /A propos de ce Mac/Rapport système/SATA SATA Express le Trim est bien activé ?

Capture d’écran 2017-04-17 à 17.01.13.jpg

Ou  un appui sur la touche alt puis Informations système/SATA SATA Express
 

melaure

Chasseur de Bobos
Club MacG
24 Octobre 2001
24 768
1 701
49
Le Grand Lyon
Impec. Et justement en lisant ce sujet, je me suis aperçu que le trim avait sauté chez moi. Pourtant je n'ai pas changé d'OS, toujours Mavericks, mais je ne sais pas, peut-être une mise à jour de sécurité. J'ai réactivé le trim et rebooté du coup.