• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

Supprimer la fenêtre d'info jaune dans Safari ?

chupastar

Membre d’élite
Club MacG
10 Décembre 2003
2 268
231
Bonjour à tous.

Ça fait un petit moment déjà que la petite fenêtre jaune, qui apparait automatiquement dans Safari à chaque fois que je met mon pointeur sur un lien, m'agace... Même si des fois, je l'admet, elle peut être utile, mais quand elle est trop grande et qu'elle cache les info qu'il y a dessous c'est embêtant je trouve. :siffle:

Donc ma question serait de savoir s'il y avait un moyen de la supprimer ?

Merci à tous !
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
12 890
637
Toulouse.cong
faq.office.macintosh.free.fr
Tu veux probablement parler des bulles d'aide qui, dans Safari affichent les URL, etc. Je ne crois pas qu'on puisse en supprimer l'affichage.


-----------------------------------------------------
Note du modérateur (Aliboron aussi) :
En tout état de cause, il est ici question d'internet et plus exactement de navigateur. Comme on a bien entendu lu au préalable le message de Pascal77 en tête de ce forum et/ou la table d'orientation, on déménage vers "Internet et réseau". Et hop !!!
 

-anonyme-

Légende
26 Février 2001
66 286
2 667
Bonjour,

Ces infobulles peuvent être utiles, même si elles entravent parfois un peu la lecture... Avec Safari 5 sur Leopard, je n'ai pas ce problème (elles doivent être désactivées probablement par défaut). Si on veut les désactiver, tenter d'entrer ceci dans le Terminal, cela ne devrait pas faire exploser l'ordinateur (normalement...) :

defaults write com.apple.Safari WebKitShowsURLsInToolTips 0

Touche "Enter" puis Redémarrer ensuite Safari. Cela fonctionnait bien avec Safari 2.

Pour réactiver ces "tooltips", remplacer 0 par 1.
Il existe aussi une commande pour paramétrer le délai d'apparition. Mais ce n'était pas la question posée.

PS : confirmation que cela ne fait pas bobo à l'ordi et fonctionne avec SL ICI.
 
  • J’aime
Réactions: Mac Flo et Aliboron

chupastar

Membre d’élite
Club MacG
10 Décembre 2003
2 268
231
J'ai bien fait la commande dans le terminal mais j'ai toujours ces petites bulles jaunes...

Et pour retarder leur arrivée ? Ça pourrait être une bonne alternative.
 

-anonyme-

Légende
26 Février 2001
66 286
2 667
Bizarre...

On trouve cette combine un peu partout sur Internet, y compris pour Safari 4 sur des systèmes récents, et cela semble marcher sans problème.

Mais j'ai trouvé pourquoi je n'avais pas ces tooltips : il y a un paramétrage possible de leur affichage dans Onyx et je les avais désactivés. Il suffit d'aller dans "Paramètres", puis l'onglet "Safari" et décocher "Afficher l'adresse des liens dans les bulles d'aide".

Pour allonger le délai d'apparition, rentrer dans le Terminal la ligne suivante (le délai est en millièmes de secondes ; ici, paramétré sur 10s) :

defaults write com.apple.safari NSInitialToolTipDelay -int 10000

Saisir ensuite Enter et redémarrer Safari.
 

chupastar

Membre d’élite
Club MacG
10 Décembre 2003
2 268
231
Merci !

En fait je crois que ça a marché, mais uniquement pour les adresses des liens dans les bulles d'aide. Et ça laisse donc les petites infos comme par exemple le "insérer une image" pour l'icône qui se situe juste au dessus de mon champ de frappe à cette réponse (et c'est pour cela que je pensais que ça n'avait pas marché la première fois). Et dans Onyx la case est décochée.

C'était juste ces adresses un longues qui m'embêtaient jusqu'à présent donc tout va bien maintenant.

Merci ! :up: