Supprimer le remplissage auto des URL dans SAFARI ?

MortyBlake

Membre expert
Club MacG
29 Novembre 2004
1 183
114
65
la maison près de la fontaine
endavent a dit:
J'ai bien supprimé history.plist dans mon compte puisque j'ai fait une recherche de tout ce qui portait Safari comme nom avec direction --> poubelle ! Mais ça n'a absolument rien changé.

J'en suis à mon enieme vidage de cache, réinitialisation de Safari, suppression de formulaire, etc....

Mais tout ça ne fait rien : les URL continuent de me proposer des URL déjà saisies .....:(

Et vous, ça ne vous arrive pas ?

Non, Non, Non :confused: :confused: :confused:

Attention, le fichier ne porte pas le non de safari mais history.plist tout court. Ferme Safari, essaie de le retrouver dans ta bibliothèque, supprime le et redémarre Safari.

Par le Property List Editor, on voit bien que c'est dans ce fichier que sont archivés tous les sites visités.

En faisant des modifications partielles de ce fichiers, j'ai pu faire apparaitre ou disparaitre des sites ...

Sinon, c'est magique, ton truc :) :) :)
 

endavent

Membre actif
16 Janvier 2005
554
16
Nantes
Hé bien oui, ce doit être magique :eek:

Car j'ai fait une recherche de tous les history.plist sur mon disque dur (avec Pomme-F) et il ne m'en a trouvé qu'un, dans le répertoire Safari.

Je l'ai mis à la corbeille et j'ai redémarré Safari : comme d'hab, lorsqu je commence à taper une URL, elle me propose des auto-remplissages :(

Un sorcier dans le forum ???:rose:
 

Dos Jones

Va modo va molo...
Club MacG
17 Juin 2004
19 591
1 937
67
A pas de loups...
Moi pas sorcier mais moi donner médecine à toi. Toi devoir suivre chemin initiatique suivant.

Toi quitter le Safari :D

Toi supprimer de /Ta case/bibliothèque/Safari, history.plist

Toi éteindre machine à bits quelques minutes

Toi réveiller machine

Toi vérifier l'absence d'history.plist dans /Ta case/bibliothèque/Safari

Toi reprendre le Safari et tester

Si problème à nouveau, toi noter l'heure au soleil et toi quitter le Safari.

Toi rechercher avec la baguette de Sherlock les fichiers modifiés aujourd'hui (visibles et invisibles en +)

Toi regarder ceux modifiés à l'heure de soleil plus haut.

Toi devoir trouver history.plist + d'autres (les noter et nous les TamTamiser*).

Toi éditer history.plist qui ne devrait pas contenir grand-chose.

Si remède pas efficace toi éliminer les revendeurs PC de ton village, ils t'ont envouté...

:up:

* Du verbe TamTamiser il me semble, signifiant : transmettre message en tapant sur tambours :D :D :D
 

Amaël

Membre actif
24 Juin 2004
350
26
33
Montpellier
Il n'y as pas de solution !!!!! ...

Nos collègues américais s'arrachent les cheveux comme nous : ici.

:D
 

MortyBlake

Membre expert
Club MacG
29 Novembre 2004
1 183
114
65
la maison près de la fontaine
Amaël a dit:
Il n'y as pas de solution !!!!! ...

Nos collègues américais s'arrachent les cheveux comme nous : ici.

:D

Ne despérer jamais. Faites infuser d'avantage (Henri Michaux).

Encore une fois, c'est pas magique. Tu tapes une URL, elle est mémorisée qu'elle part, tu retrouves le fichier, tu l'effaces et hop...

Ce fichier c'est soit un cache, soit un fichier temporaire soit un plist.

Je suis d'accord avec DJ. La solution est peut-être d'éteindre et de débrancher après avoir éliminer la plist.

Question subsidiaire. dans le Safari Debug, si vous regarder le cache Window, il y a un Webfountain et un Webcore cache. Quelqu'un sait-il à quoi ça corresopond ? :hein: :hein: :hein:
 
  • J’aime
Réactions: endavent

endavent

Membre actif
16 Janvier 2005
554
16
Nantes
Ben pour ma part j'ai laissé tomber, j'utilise Firefox :sleep:

Je n'utilise plus Safari que pour les adresses courantes que je visite souvent, comme ça au moins le déroulement des adresses auto me sert à quelque chose .... :rolleyes:

Si quelqu'un trouve une méthode qui fonctionne (car j'ai testé toutes vos idées et rien de rien) qu'il m'envoie un message privé !

Merci à toutes et à tous.
 

Sophia

Membre enregistré
23 Octobre 2004
4
0
Moi j'ai le même problème avec IE :(
Je sais que la fonction peut être désactivée, mais moi je voudrais juste réinitialiser la mémoire des URL sans désactiver définitivement la fonction...
Quelqu'un pourrait m'aider ?
Merci.
 

Burzum

Membre actif
5 Mai 2005
681
146
44
Caen
endavent a dit:
J'en suis à mon enieme vidage de cache, réinitialisation de Safari, suppression de formulaire, etc....

Mais tout ça ne fait rien : les URL continuent de me proposer des URL déjà saisies .....:(

Et vous, ça ne vous arrive pas ?

Même problème...
Pas de solution alors ?
 

ccyyrriill

Membre enregistré
20 Mai 2006
1
0
Salut, en fait il me semble que quelqu'un a deja trouver la reponse a ton probleme..

Il faut effacer la liste des bookmarks.plist, et non la history.plist car.....

history comme son nom l'indique efface l'historique de tes visites..

bookmarks contient la liste de tous tes sites favoris, et ceux ci se retrouve obligatoirement dans le zone URL, si tu verifie dans la zone d'adresse, tes url qui s'ecrive tout seul sont les memes, que tu as dans tes sognet, si tu supprime un signet, l'adresse n'apparaitra plus dans ta liste d'url..

si tu efface bookmarks, tu verra qu'il n'apparait plus aucune adresse url dans la zone d'adresse...

donc si tu veux qu'une adresse n'apparaisse plu dans la zone d'adresse il faut la virer dans les signets.. c la seule solution..... preqsue logique, car vu que c un de tes sites favoris, safari te propose de ne pas taper l'adresse....

bye
 

endavent

Membre actif
16 Janvier 2005
554
16
Nantes
STOOP ! N'utilisez pas cette solution ! :afraid:

Effectivement elle fonctionne mais...elle efface tous les signets !

Tu m'étonnes qu'il n'y ait plus d'historique relatif aux signets quand on tape un début d'adresse !:D

C'est une solution aussi radicale que de virer Safari de son disque dur :bebe:
 

Foyan

Membre confirmé
--
Une sévère toilette sélective de la liste qui s'affiche dans Safari
Préférences / Rempl. auto. / Autres formulaires ---> Modifier
ne ferait pas l'affaire ?

Quitte à recommencer régulièrement...

Hth
 

pcnum

Membre actif
16 Avril 2010
612
20
Bonjour. Je rechauffe ce vieux post de 2005. Depuis le temps n'y a t'il pas une fonction pour supprimer les propositions de site dans la barre URL ? Merci
 

Anthony

Administrateur
MacGeneration
Administrateur
Club iGen
28 Octobre 2005
3 777
1 497
metrozendodo.fr
Bonjour. Je rechauffe ce vieux post de 2005. Depuis le temps n'y a t'il pas une fonction pour supprimer les propositions de site dans la barre URL ? Merci

Toujours dans les préférences de Safari (Safari > Préférences), mais cette fois dans l'onglet Recherche, parce que les choses sont bien faites parfois. Il suffit de décocher les options Inclure les suggestions du moteur de recherche et Inclure les suggestions Safari, et puis Activer la recherche rapide de site web quitte à y être. Pour couper aussi le remplissage basé sur l'historique, la solution la plus simple consiste probablement à réduire l'historique à peau de chagrin, cette fois dans l'onglet Général des préférences. Il restera toujours l'historique quotidien — on doit pouvoir bloquer son enregistrement, mais probablement pas sans causer des problèmes de stabilité. (Et quatorze ans entre deux posts, je me demande si ce n'est pas un record, bien joué !)