macOS Ventura TextEdit pété ? o0

tabasko

Membre actif
1 Décembre 2003
750
17
47
Paris
www.123boost.com
Salut à tous,

Je sèche et je tourne en rond alors je viens pour raconter ma mésaventure ...

J'ai un fichier texte que TextEdit n'ouvre pas. L'application se lance mais le fichier n'est pas ouvert.
Dans le Finder, l'aperçu de mon fichier texte est OK
Si j'ouvre le fichier texte avec un autre éditeur comme BBedit, le fichier s'ouvre sans problème.

On peut affirmer que le fichier n'est pas corrompu, sinon BBedit ne pourrait pas l'ouvrir.
Niveau permission tout est standard (j'ai comparé avec d'autres applications et fichiers)

Si j'ouvre TextEdit, que je crée un fichier test, et que je l'enregistre, le ficher s'enregistre sans problème (l'aperçu me montre même mon texte). Par contre même chose, si je double clic sur mon fichier test.txt il ne s'ouvre pas.

(si je change de session utilisateur, ça fonctionne).

Merci pour vos avis et conseil pour en arriver à bout.
PS : je pense que c'est depuis ma dernière maj ventura 13.3.
 
Dernière édition par un modérateur:

moderno31

Membre expert
Club iGen
21 Avril 2011
1 087
83
Salzbourg
Hello
Faisons le tri. :cool:
Tu peux lire directement avec bbedit ? Il te faut confirmer vouloir ouvrir tout le temps ce typz de fichier avec bbedit ou textedit. Et a priori le tour est joué

Partage une copie d’écran de ton clic droit / « ouvrir avec » depuis un fichier txt.

Tu dois avoir un conflit
A+
 

tabasko

Membre actif
1 Décembre 2003
750
17
47
Paris
www.123boost.com
(et pire, dans certain cas, si depuis l'application ouverte je fais ouvrir ça va fonctionner mais pas systématiquement)

Voici ce que tu m'as demandé. J'ai tenté cet aprèm le changement de l'app par défaut, puis retour à TextEdit (les droits de BBedit sont strictement identique à ceux de TextEdit). Je voudrai conserver TextEdit (pas drôle sinon...)

Merci pour ton aide.

1680208932512.png
 
Dernière édition par un modérateur:

moderno31

Membre expert
Club iGen
21 Avril 2011
1 087
83
Salzbourg
Je continue de penser que tu as un conflit. Et de belles perspectives de nettoyage. Un ordinateur qui propose skype pour lire un fichier texte. Humm ça déraille sérieux

Je vais fouiller mes archives. Il me semble avoir déjà vu ça.
 

tabasko

Membre actif
1 Décembre 2003
750
17
47
Paris
www.123boost.com
Je suis d'accord pour ton commentaire Skype. Je sais pas comment il est arrivé là (bien que ç soit forcément moi).
Je reste un utilisateur plutôt averti, et sous macos depuis quasi 20 ans, je suis pas totalement novice (dans les grande ligne hein)

Ce qui m'embête c'est que j'avais pas le souci avant la dernière maj de ventura, et que je viens de refaire un re-install de ventura.

Si ça peut aider, même souci en mode sans échec.
Pas de souci depuis une autre session utilisateur.
 

tabasko

Membre actif
1 Décembre 2003
750
17
47
Paris
www.123boost.com
Histoire de compliqué le contexte.
J'ai le souci depuis mon répertoire Google Drive.
Si je copie le fichier sur mon bureau, je n'ai à priori plus le problème (je dis à priori car je suis quasi certain d'avoir fait le test hier et ça marchait pas).

Et côté Google Drive, les permissions sont celles attendues.
+ j'ai désinstaller Google Drive, j'ai effacé après backup mon répertoire local Google Drive, j'ai rescynchronisé "from scratch", et ça change rien.

çà me rend dingue :-/
 

Sly54

Acrobate de l'espace
Modérateur
Club iGen
31 Janvier 2005
57 278
10 987
Nancy___
Si j'ouvre TextEdit, que je crée un fichier test, et que je l'enregistre, le ficher s'enregistre sans problème (l'aperçu me montre même mon texte). Par contre même chose, si je double clic sur mon fichier test.txt il ne s'ouvre pas.
J'ai un souci similaire, avec Word et Excel : de temps en temps, mes fichiers ne s'ouvrent pas par double clic dessus. Je dois passer par le Menu Fichier/ouvrir de Word ou d'Excel.

Ce "bug" est rare et quand il arrive, ça n'est jamais avec le même fichier. Je me demande donc si MacOS ne traine pas un bug depuis Monterey (mon OS actuel).
 

Aliboron

Chercheur de son
Club iGen
1 Janvier 2008
14 732
1 195
Toulouse.cong
faq.office.macintosh.free.fr
Je me demande donc si MacOS ne traine pas un bug depuis Monterey (mon OS actuel).
Jamais observé, pour ma part (Monterey 12.6.3).

Concernant le problème avec TextEdit, vu que c'est manifestement limité au compte utilisateur courant, je tenterais (après avoir quitté TextEdit) une suppression du dossier "TextEdit" qui se trouve dans ~/Bibliothèque/Containers

Mais, dans la mesure où Google Drive entre en ligne de compte, ça peut être plus compliqué que ça...
 

tabasko

Membre actif
1 Décembre 2003
750
17
47
Paris
www.123boost.com
C'est une application système, je pense pas être autorisé à bouler un tel dossier. C'est juste des préférences de l'app ? (edit : à priori : oui :))

Et après l'avoir fait, qu'est-il supposé ce passer ?

Edit :
Je l'ai zippé, puis supprimé (ok).
plist et dossier data se sont reconstruits.
Situation inchangée :(
 

Aliboron

Chercheur de son
Club iGen
1 Janvier 2008
14 732
1 195
Toulouse.cong
faq.office.macintosh.free.fr
Oui, c'est une manip de routine de suppression des fichiers de paramétrages de l'application. Rien de dangereux (je ne me serais pas permis de le suggérer sans avertissements conséquents, sinon), au contraire. Comme tu l'as constaté, il s'en recrée un tout neuf tout propre au lancement suivant de l'application. On en est éventuellement quitte pour refaire quelques réglages.

Mais bon, dans ton cas, c'est effectivement plus compliqué, probablement du fait de l'implication de Google Drive. Désolé !
 

tabasko

Membre actif
1 Décembre 2003
750
17
47
Paris
www.123boost.com
On est d'accord. Et comme j'ai désintallé Google Drive (tous les fichiers détectés par AppCleaner) et refait la synchronisation depuis zéro, je vois pas ce que je pourrai faire de plus.

Je rappelle que c'est Ventura 13.3 qui a réveillé cette situation. Reste plus qu'à croiser les doigts pour que ça soit corrigé avec une autre version (vue que j'ai déjà tenté une ré-install Ventura, et que je ne suis pas disposé à repartir d'une installation totale de mon macOS)
 

Sly54

Acrobate de l'espace
Modérateur
Club iGen
31 Janvier 2005
57 278
10 987
Nancy___
Jamais observé, pour ma part (Monterey 12.6.3).
Ici problème identique, cette fois avec Aperçu :


Lorsque je double-clique sur un .pdf dans le finder, le Finder réagit et semble envoyer la commande à Aperçu (mini-icône qui s'affiche rapidement) mais au final rien ne s'ouvre.

Alors que si je lance Aperçu et que je fais un bon vieux Fichier>Ouvrir puis que je vais chercher ce même .pdf avec l'explorateur : ça s'ouvre !
(extrait de ce fil)
 

tabasko

Membre actif
1 Décembre 2003
750
17
47
Paris
www.123boost.com
Si je fais fichier > ouvrir > un doc word de mon Google Drive j'ai ceci.
C'est inattendu, et il y a certainement une explication (mais ça me dépasse)
J'ai créé le fichier avec mon autre macos, mais niveau utilisateur c'est le même et ça n'a jamais posé de souci avant Ventura 13.3

C'est vraiment la m.... je peux pas enregistrer mes changements sur le poste qui me pose problème. Je suis bon à tout faire à partir de mon MBP

1680283498187.png
 
Dernière édition par un modérateur:

sinbad21

Membre expert
Club iGen
2 Décembre 2004
1 350
152
Pour le ouvrir avec Skype, ce n'est pas si absurde. Bien que le système ne me propose pas Skype dans ouvrir avec, si je glisse un fichier .txt sur l'icône de Skype dans le dock ça lance Skype et ça met le fichier en pièce jointe.
 

daffyb

-Duck Warrior-
Modérateur
Club iGen
18 Octobre 2001
14 319
1 882
Angoulême
Si je fais fichier > ouvrir > un doc word de mon Google Drive j'ai ceci.
C'est inattendu, et il y a certainement une explication (mais ça me dépasse)
J'ai créé le fichier avec mon autre macos, mais niveau utilisateur c'est le même et ça n'a jamais posé de souci avant Ventura 13.3

C'est vraiment la m.... je peux pas enregistrer mes changements sur le poste qui me pose problème. Je suis bon à tout faire à partir de mon MBP

Voir la pièce jointe 278179
Ça ça se règle dans les préférences système/Sécurité et confidentialité/confidentialité/Fichiers et dossiers
 

tabasko

Membre actif
1 Décembre 2003
750
17
47
Paris
www.123boost.com
J'ai du le faire une fois j'imagine ...
Ca règle pas mon affaire :( :( je sens que je suis bon pour une réinstall complète.... car j'ai aussi ma commande universelle qui ne fonctionne plus (post ici), ça me casse les pieds, ça me fait perdre un temps de dingue !
 

Locke

What am I doing here?
Modérateur
Club iGen
20 Juillet 2011
43 602
6 961
(si je change de session utilisateur, ça fonctionne).
Tu te crées une nouvelle session Administrateur et si tout fonctionne, ce qui devrait être le cas, tu devras refaire tes réglages, car ta session précédente est corrompue et pour une réparation, autant chercher une aiguille dans une meule de foin !
 

tabasko

Membre actif
1 Décembre 2003
750
17
47
Paris
www.123boost.com
C'est une bonne idée merci, je vais faire ça et tester voir si ce qui ne fonctionne pas sur ma session fonctionne sur la nouvelle sessions.
Je reste contrarié avec Ventura 13.3, ça m'a aussi retirer la possibilité de copier/coller entre mes appareils (dont mon iPhone aussi (et le MBP présente pas les défauts constatés sur mon iMacs dont on parle ici)