Très gros problème avec des fichiers MOV

iNico

Membre confirmé
Club MacG
Bonjour à tous,

Je vous écris car j'ai un très gros problème concernant l'ouverture de fichiers MOV...
J'avais stocké sur disques durs externes des fichiers MOV donc, filmés avec mes précédents iPhone et mon caméscope HD Sony.
J'ai voulu les revoir il y a peu mais ils ne s'ouvre plus...Enfin plutôt si, Quicktime me les ouvre, mais il se contente uniquement de lire la piste audio du fichier.
J'ai tenté de les copier en local, au cas ou ça fonctionnerait mieux, et de les ouvrir dans iMovie, mais c'est la même chose et iMovie refuse carrément de me les lire.
Ces fichiers sont "bruts", ils sortaient directement des appareils, je ne les ai jamais modifié et la lecture se faisait parfaitement avant.
Pouvez-vous m'aider à résoudre ce problème s'il vous plaît? C'est très important pour moi, ce sont des souvenirs que je ne voudrais absolument pas perdre.
Merci beaucoup par avance pour votre précieuse aide et pour votre temps.

Cordialement,
Nico.
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 216
440
Bonjour,
Mov est un container (propriétaire Apple) et ne permet pas de connaître les codecs vidéo/audio des flux respectifs qu'il contient.

Ceci dit ton histoire est pour le moins curieuse, des fichiers qui se lisaient et qui ne se lisent plus ?

Mais je te rassure, il est peu probable que tes souvenirs soient perdus, on n'a jamais vu de fichier se dégrader ainsi, du moins pour ce qui me concerne…

La première chose à faire serait de connaître les codecs vidéo/audio. Mais en principe, si c'est filmé par un iPhone qui plus est ancien et un camescope Sony, c'est du H.264/AAC.

J'aurais plutôt tendance à soupçonner un problème sur ton compte utilisateur. Et notamment au niveau de QuickTime.

Il faudrait que tu essaies avec un autre lecteur non basé QuickTime. Je te suggère IINA (qui lit tout). Si IINA lit tes vidéos (ce qui est probable), l'hypothèse problème sur compte utilisateur est évidente.

Pourrais-tu alors relancer ton ordi (dont tu ne dis malheureusement rien) à partir d'un compte invité ou d'un compte 'test' que tu auras créé à cet effet afin de voir ce qui se passe en lecture QuickTime depuis ton DDE ?

Si la lecture QT se passe bien, c'est que ton compte utilisateur est corrompu.

Et sinon, il va te falloir envisager la ré-installation complète de ton OS.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
33 110
3 702

iNico

Membre confirmé
Club MacG
Bonjour,
Mov est un container (propriétaire Apple) et ne permet pas de connaître les codecs vidéo/audio des flux respectifs qu'il contient.

Ceci dit ton histoire est pour le moins curieuse, des fichiers qui se lisaient et qui ne se lisent plus ?

Mais je te rassure, il est peu probable que tes souvenirs soient perdus, on n'a jamais vu de fichier se dégrader ainsi, du moins pour ce qui me concerne…

La première chose à faire serait de connaître les codecs vidéo/audio. Mais en principe, si c'est filmé par un iPhone qui plus est ancien et un camescope Sony, c'est du H.264/AAC.

J'aurais plutôt tendance à soupçonner un problème sur ton compte utilisateur. Et notamment au niveau de QuickTime.

Il faudrait que tu essaies avec un autre lecteur non basé QuickTime. Je te suggère IINA (qui lit tout). Si IINA lit tes vidéos (ce qui est probable), l'hypothèse problème sur compte utilisateur est évidente.

Pourrais-tu alors relancer ton ordi (dont tu ne dis malheureusement rien) à partir d'un compte invité ou d'un compte 'test' que tu auras créé à cet effet afin de voir ce qui se passe en lecture QuickTime depuis ton DDE ?

Si la lecture QT se passe bien, c'est que ton compte utilisateur est corrompu.

Et sinon, il va te falloir envisager la ré-installation complète de ton OS.
Merci beaucoup pour ta réponse...La vache, tu vas me faire bosser lol!

C'est ça oui...Avant je pouvais toutes les lires et maintenant plus rien.
Mon Mac est un MacBook Pro 2016 15'' Touch Bar qui tourne sur Catalina.
Non je n'ai aucun autre compte utilisateur dessus, juste le mien et c'est tout.
Je suis vraiment surpris et pas du tout rassuré que cela pourrait venir de ma session et de mon installation de mon OS.

Ecoutez, je vois ça demain et je reviens vous tenir au courant :) Merci beaucoup à tous les deux.
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 216
440
Merci pour cette info ;)

Effectivement, sur leur sit il est spécifié : 'Propulsé par le lecteur multimédia open source mpv, IINA peut lire presque tous les fichiers multimédias que vous possédez. Avec la prise en charge de youtube-dl et de nos extensions de navigateur, vous pouvez également lire une variété de flux en ligne dans IINA en un seul clic'

J'ai adopté IINA car durant une certaine période, au début des enregistrements par certaines caméras en HEVC, VLC a été complètement 'à la ramasse', incapable de lire le moindre fichier fluidement alors qu'IINA se promenait…
 
Dernière édition:
  • J’aime
Réactions: iDanGener

iNico

Membre confirmé
Club MacG
Bonjour à tous,

Comme convenu hier je reviens vous tenir au courant...
IINA et VLC arrivent à lire comme il faut mes vidéos, déjà merci beaucoup pour ça les gars :)
Ensuite...Je fais des tests de conversion en ce moment avec VLC pour que je puisse lire celles-ci directement avec Quicktime et iMovie, mais c'est pas gagné :(
J'ai réussi à en faire une, la vidéo passe impeccable sur Quicktime mais je n'ai aucun son.
Je reste désespérément ouvert à votre expertise pour arriver à bout de cette &é"'(§è!. #FaitSuer

Cordialement,
Nico.
 

iDanGener

Membre émérite
12 Mars 2011
517
57
Bonjour,

Pour les conversions, le plus simple -- à mon avis -- c'est d'utiliser Handbrake.
En supposant bien sûr que votre fichier source soit reconnu par Handbrake.

iDan
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 216
440
Non, je pense qu'avant de ré-encoder avec Handbrake, il faut tenter le ré-encapsulage.

En effet, la vidéo étant lisible sans problème dans IINA, cela signifie que sa qualité intrinsèque n'est pas en cause, c'est plus probablement le container mp4 qui est en cause, il n'est apparemment plus reconnu par QuickTime.

L'avantage du ré-encapsulage s'il résout le problème, est que contrairement à la solution de IdanGener ;) qui est longue, fastidieuse, et touche à la vidéo, c'est sa quasi immédiateté puisque il y a juste ré-écriture du container mp4.

Alors télécharge Avidemux.

Et applique exactement le réglage comme la capture d'écran ci-après :

Capture_d’écran_2020-05-15_à_19_53_25.jpg


Pose une vidéo sur l'interface et clique sur l'icône de disquette pour enregistrer le nouveau container.
Tu pourras alors vérifier si QuickTime le lit.
Le tout en quelques secondes…

Et si cela ne marche pas, il faudra effectivement tout ré-encoder, et Handbrake est excellent pour ce faire…
 

iNico

Membre confirmé
Club MacG
Bonjour à tous,

Je reviens vous voir encore...
Alors, avec Avidemux ça n'a pas fonctionné donc j'ai fait un test d'encodage avec Handbrake et là miracle! Tout est impeccable! L'image est revenue avec Quicktime ET avec le son!
Je vous remercie énormément pour votre aide, sincèrement. Vous avez fait fort de vos enseignements et ça, c'est terrible...Vous êtes au top!
Je vous souhaite à tous une excellente continuation et portez-vous bien.

Nico.
 
  • J’aime
Réactions: Nanardtetard