Triple boot : OS X SL + Win XP 64 + Ubuntu Studio

SveDec

Membre émérite
12 Mai 2004
676
44
31
Paris
Bonjour à tou(te)s :)
Je vous écris ce long message pour vous faire part de mes pérégrinations concernant l'installation de Mac OS X 10.6, avec Windows XP Pro 64 bits et Ubuntu Studio 10.04 "Lucid Lynx", sur mon tout frais MacBook Pro.
J'ai essayé de suivre et d'adapter le tutoriel suivant : http://videonoob.fr/mac/triple-boot-macbook-mac-windows-linux , en essayant de l'adapter à ma sauce.
J'ai donc fait comme suit :
- Booté le MBP sur le CD de SL
- Sélectionné le DD, et créé une partition sur laquelle j'ai installé SL
Jusqu'ici, tout va bien
- Installé rEFIt
- Entré la commande cd /efi/refit; sudo ./enable-always.sh (qui l'active si j'ai à peu près compris ?)
Alors là suivant le tuto, première question : le type n'a pas réussi à créer de partition de "partage" qui serait accessible aux trois OS, car apparemment Vista ne le permet pas. Serait-ce en revanche possible avec mon XP 64 ? J'ai vu sur ce forum il me semble quelqu'un qui avait réussi ... ou alors ce n'était pas des partitions primaires ? Je ne sais pas, je suis un peu paumé là ^^
Bref, continuons :
- Lancé les commande "diskutil list" et "sudo diskutil resizeVolume /dev/disk0s2 61G "MS-DOS FAT32" Linux 20G "MS-DOS FAT32" Windows 30G" (enfin sa version adaptée)
Bon, je crois avoir à peu près compris cette étape, mais j'ai un doute ... que je vais expliquer un peu après. La suite :
- J'ai ensuite installé Ubuntu Studio 10.04, sans soucis
Là, les problèmes ont commencé ^^
Déjà, je n'ai pas bien compris pourquoi dans le tuto il ne fallait pas créer de SWAP, pour en créer un juste après ... de toute façon je n'ai pas pu le faire, car le CD d'installation de Ubuntu Studio ne permet pas de booter dessus et d'utiliser le système en live !
Cela dit, Ubuntu Studio était bien là à la fin du processus, proposé par rEFIt ... à ceci près, que cet abruti (enfin .. ^^) s'est installé sur la partition nommée "Windows" ! Alors que je n'ai pas l'impression de m'être trompé ... de tout façon je vais refaire tout (à part l'installation de SL), je pourrais donc en être sûr.
J'ai ensuite installé Win XP 64, sur la partition restante, qui elle s'appelle maintenant "Untitled" (bon ...), avec succès, puisque comme prévu par le tuto, rEFIt ne m'a plus affiché que OS X et Win ... à la différence près que je ne peut pas réparer GRUB (enfin, je ne sais pas comment faire), puisqu'encore une fois je ne peux booter sur le CD d'Ubuntu.
DONC, j'ai actuellement les trois OS sur ma machine, et les problèmes suivants :
- Ils sont installés sur les mauvaises partitions (solution : refaire tout, à priori ?)
- Ubuntu n'est plus accessible
- Dans SL, ma partition Linux (donc celle nommée 'Windows' :p ) n'apparaît pas (le FS est en ext3) mais celle de Windows (donc 'Untitled', en NTFS) apparaît ... je n'aimerais pas la voir, est-ce possible ?
- rEFIt ne se lance pas toujours, des fois SL boot tout seul (après que j'aie lancé Windows il me l'a fait, et là tout à l'heure à un simple redémarrage de SL). Est-il donc possible de contrôler le lancement de rEFIt ? Pour l'instant pour y avoir accès je retape la commande "cd /efi/refit; sudo ./enable-always.sh", mais ce n'est pas très pratique, et peut-être pas très propre ..
Mon post est assez confus, et va reprendre sûrement pas mal de choses déjà dites ailleurs, mais j'ai l'impression que la particularité de la situation vaut un nouveau sujet.
Voilà, j'attend vos réponses, et en attendant je vais continuer à bousiller le DD de mon MBP :D
Merci d'avance !
 

SveDec

Membre émérite
12 Mai 2004
676
44
31
Paris

SveDec

Membre émérite
12 Mai 2004
676
44
31
Paris
Bon, je bascule sur le sujet indiqué, il me paraît en effet plus simple d'installer Ubuntu dans sa version standard pour ensuite l'upgrader vers la version Studio. Cela contourne le problème de l'absence de live CD (et c'est nettement plus simple avec !).
Merci quand même :)