Un disque USB 3.0 bloque ports usb mac puis crash tout ce qui est branché après !

Gag

Membre actif
8 Février 2009
239
14
Boulogne-Billancourt
Bonjour,
Je me tourne vers vous en désespoir de cause :

Ma tante qui est sur iMac a eu la bonne idée de travailler un projet directement (ne me demandez pas pourquoi…) sur un disque Storeva 2,5 externe alimenté via le câble USB 3.0 / USB 2 connecté au Mac.

Malgré quelques lenteurs à l’allumage, ça fonctionnait depuis un moment, mais il y a quelques semaines le disque n’est pas monté et elle a eu l’alerte "Comme un périphérique USB consommait trop d'énergie de votre ordinateur, un ou plusieurs périphériques USB ont été désactivés. » (de mémoire).

Elle a alors tenté de brancher un autre DD (similaire), qui n’est pas monté non plus.
Différents essais de câbles, de ports etc n’ont rien donnée, et elle se retrouve donc avec 2 DD remplis de données non sauvegardées ailleurs qui ne tournent plus (pas même d’allumage : pas de bruit, pas de vibration).

Appelé à l’aide, je lui ai conseillé de tenter le coup sur d’autres Macs pour voir si le problème était circonscrit au sien, mais idem : pas de réaction.
Elle est allé chez Macway (vendeur des 2 disques), diag confirmé ça ne monte pas, et il lui on donné l’adresse d’une boite qui fait de la récupération de donnée.

Pour ma part (pas sur place pour tester, je pensais plutôt à un problème d’alim des boitiers (grillées par un surtension ou autre ?), car 2 disques externes qui tombent en rade en même temps, je n’y croyais pas trop…
Je lui ai conseillé d’acheter un nouveau boitier pour tester les disques dedans, mais pas bricoleuse (du tout), elle ne l’a pas fait et les a amené à la boite de récupération de données.

Ils lui ont confirmé que ça ne marchait pas (je ne sais pas ce qu’ils on testé ni comment), et proposé une récupération à 800 boules (le disque…) :
du coup elle leur a laissé 1 disque et a conservé l’autre pour me le montrer, au cas où.

J’ai donc fait le test de placer le DD H.S dans un autre boitier, et une fois branché sur mon iMac, même constat :
il ne monte pas (et aucun signe de vie), et j’ai le même message indiquant qu’un périphérique consomme trop.

Je l’ai alors branché sur un Hub USB avec alim externe, mais celui-ci a généré le même message (périphérique en surconso) !
Disque branché dessus idem, j’ai alors branché successivement 2 clefs USB qui ne sont pas monté non plus (elle fonctionnaient juste avant !).
L’une d’entre elle dispose d’une diode qui s’allume quant elle est branchée et qui là est resté éteinte…

Testé sur 2 macs, idem, et les clefs branchées en direct ne fonctionnent plus non plus…
Ça n’est pas un problème de port :
2 autres clefs branchées après (sans passage par le Hub) fonctionnent normalement.

Bref, j’ai du mal à saisir le problème !

Une hypothèse serait que le premier disque a généré un problème générant le message de surconso, qui a ensuite « fait griller » (ou rendu inactif) tous les autres périphs USB branchés après, et quelque soit le mac.

Quelqu’un aurait-il déjà expérimenté ce type de problème et/ou aurait-il une idée du pourquoi du comment ?

Merci d’avance !
 

Gag

Membre actif
8 Février 2009
239
14
Boulogne-Billancourt
Je vois que ça n'inspire pas grand-monde :
@macomaniac tu ne connais personne qui pourrait avoir une idée sur ce coup-là ?
Merci !
 

gwen

iModo
Modérateur
Club MacG
25 Octobre 2001
14 923
2 467
50
Caen et de temps en temps Limoges
www.shito.com
Je suis également circonspect sur deux disque grillés d'un coup. A mon avis, il faut reconstruire la table des partition afin de faire monter le disque. Tu as regardé ce que cela donne avec la fonction SOS d'utilitaire de disque ?
 

Gag

Membre actif
8 Février 2009
239
14
Boulogne-Billancourt
Je suis également circonspect sur deux disque grillés d'un coup. A mon avis, il faut reconstruire la table des partition afin de faire monter le disque. Tu as regardé ce que cela donne avec la fonction SOS d'utilitaire de disque ?
Oui, il ne voit rien et de toutes façon le disque ne bronche pas :
pas de son ni de vibration (et la diode de ma clef USB ne s'allume plus) donc à mon avis pas alimenté, et pas vu nonplus dans la liste des périphériques USB…
Impossible donc de reconstruire la table de partition ou quoi que ce soit d'autre en soft au niveau des disques (ou en tout cas, je ne vois pas).
Merci en tout cas de te pencher sur mon cas :
je commençais à me sentir seul : )
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
40 943
6 411
Ma tante qui est sur iMac a eu la bonne idée de travailler un projet directement (ne me demandez pas pourquoi…) sur un disque Storeva 2,5 externe alimenté via le câble USB 3.0 / USB 2 connecté au Mac.
Non, Storeva c'est la marque du boîtier USB qui contiendra le disque dur.
  • quel est le modèle exact de boîtier USB ?
  • quel est le modèle exact du disque dur à plateaux, SSD, il y en a 2 ?
  • est-ce que le ou les cordons USB sont neufs ?
  • est-ce qu'un clavier ou une souris filaire sont reconnus sur tous les ports USB ?
  • quel est le modèle exact de ce Mac, modèle, taille écran, année ?
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
54 540
10 429
Nancy___
La question a deux balles : qui est responsable de ce grillage de port ? disques ?
Est ce que ça pourrait provenir du câble USB3-2 ?
 

Gag

Membre actif
8 Février 2009
239
14
Boulogne-Billancourt
Salut à tous, et merci de votre intérêt : )
Dans l'ordre :
- non, ça n'est pas le port USB qui fonctionne avec d'autres périphériques, et de toutes façons testés sur plusieurs ports et plusieurs macs avec le même résultat.
  • quel est le modèle exact de boîtier USB ? : boitiers Storeva en USB 3 sans alim dédiée
  • quel est le modèle exact du disque dur à plateaux, SSD, il y en a 2 ? : Plateau, mais je n'ai pas les infos du reste car plus celui que j'ai testé avec moi, et l'autre est en chambre blanche… 2 To pour celui que j'ai testé, et les 2 disques sont des 2,5 pouces.
  • est-ce que le ou les cordons USB sont neufs ? : Non, mais le boitier dans lequel j'ai testé le disque est en micro (ou mini ?) USB (je m'y perd dans leurs specs…) et idem.
    Donc j'éliminerai bien la cause du cordon !
  • est-ce qu'un clavier ou une souris filaire sont reconnus sur tous les ports USB ? : Oui : comme indiqué j'ai branché 2 clefs USB (qui n'ont pas été branchées avant sur le Hub USB : les 2 autres sont "mortes", et elles montent sans problème.
  • quel est le modèle exact de ce Mac, modèle, taille écran, année ? : le mac "d'origine"" (le sien) est un iMac de 2009 il me semble, et 2011 max (boitier "épais"). Testé sur les miens : un iMac 2012 (i7 fin) et sur un 2018 (i7 rétina).

    - Et pour "La question a deux balles" : c'est bien ce que je cherche à comprendre : )
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
54 540
10 429
Nancy___
est-ce que le ou les cordons USB sont neufs ? : Non, mais le boitier dans lequel j'ai testé le disque est en micro (ou mini ?) USB (je m'y perd dans leurs specs…) et idem.
Donc j'éliminerai bien la cause du cordon !
Je ne comprends pas pourquoi tu élimines la possibilité que le cordon soit défaillant ?
 

Gag

Membre actif
8 Février 2009
239
14
Boulogne-Billancourt
Je ne comprends pas pourquoi tu élimines la possibilité que le cordon soit défaillant ?
Ben parce que quand testé avec un autre cordon qui n'a même pas les caractéristiques ça ne marche pas mieux…
Edit parce que pas clair effectivement :
mon boitier n'ayant pas la même connectique, le cordon n'est évidemment pas le même ;-)

Par contre, ça n'élimine pas la possibilité qu'un cordon soit à l'origine du problème initial, mais le fait d'en changer ne résout rien.
 
Dernière édition:

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
54 540
10 429
Nancy___
Par contre, ça n'élimine pas la possibilité qu'un cordon soit à l'origine du problème initial, mais le fait d'en changer ne résout rien
Disons que si le cordon est défectueux, si le cordon est responsable de la mort des 2 disques (alimentation HS, par exemple), alors changer de cordon ne va pas rescisiter les deux disques.

Mais je ne sais pas s'il est possible de tester le cordon (autrement que de brancher un 3e disque pour voir s'il devient HS, ça finirait par couter cher en disques !).
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
40 943
6 411
Par contre, ça n'élimine pas la possibilité qu'un cordon soit à l'origine du problème initial, mais le fait d'en changer ne résout rien.
Et pourtant, bien souvent le coupable est bien le cordon.

Par contre, je persiste et signe...
  1. quel est le modèle exact de boîtier USB ?
  2. quel est le modèle exact du disque dur à plateaux, SSD, il y en a 2 ?
...tu peux dire ce que tu veux, mais ce sont des informations importantes, d'autant plus que l'iMac concerné est de 2009 avec des ports USB 2.0 qui sont extrêmement lents. Un simple port USB ne peut pas griller un disque dur, comme tu mentionnes que tous les ports USB sont opérationnels, on élimine définitivement cette piste.

Il reste quoi, cordon, boîtier USB, disque dur et c'est tout.
Oui : comme indiqué j'ai branché 2 clefs USB (qui n'ont pas été branchées avant sur le Hub USB : les 2 autres sont "mortes", et elles montent sans problème.
Désolé, mais pour moi c'est de l'hébreu ! Est-ce que tous les ports à l'arrière de cet iMac sont fonctionnels ? Est-ce le boîtier USB est connecté en direct à l'arrière de cet iMac ou depuis un boîtier HUB USB ?
 

Gag

Membre actif
8 Février 2009
239
14
Boulogne-Billancourt
Et pourtant, bien souvent le coupable est bien le cordon.

Par contre, je persiste et signe...
  1. quel est le modèle exact de boîtier USB ?
  2. quel est le modèle exact du disque dur à plateaux, SSD, il y en a 2 ?
...tu peux dire ce que tu veux, mais ce sont des informations importantes, d'autant plus que l'iMac concerné est de 2009 avec des ports USB 2.0 qui sont extrêmement lents. Un simple port USB ne peut pas griller un disque dur, comme tu mentionnes que tous les ports USB sont opérationnels, on élimine définitivement cette piste.

Il reste quoi, cordon, boîtier USB, disque dur et c'est tout.

Désolé, mais pour moi c'est de l'hébreu ! Est-ce que tous les ports à l'arrière de cet iMac sont fonctionnels ? Est-ce le boîtier USB est connecté en direct à l'arrière de cet iMac ou depuis un boîtier HUB USB ?
1 & 2 : Ça n'est pas de la mauvaise volonté, mais comme indiqué précédemment, je n'ai pas les disques sous la main et donc pour l'instant je ne peux pas avoir des infos plus précises que celles déjà données…

Je n'ai pas accès à l'iMac de ma tante pour vérifier ses ports USB, mais sur les 2 miens où le phénomène est identique, je confirme qu'ils marchent tous (après avoir débranché le Hub USB ou le DD qui occasionnent tout 2 le message d'alerte "périphérique trop gourmand bla bla" (voir plus haut).

Pour "l'hébreux", désolé j'ai voulu faire court dans ma réponse car tout est détaillé dans mon premier post :
  • à l'origine, DD branché en direct sur Mac de ma tante, puis des miens : whalou, et message "périphérique gourmand…"
  • puis chez moi test de branchement sur un Hub USB avec alimentation électrique autonome (ce qui devrait logiquement au moins supprimer le message "périphérique gourmand", mais pareil ça ne monte pas et le message apparait.
  • Puis Ô surprise, le message "périphérique gourmand" apparait juste en connectant le hub, même si rien n'est branché dessus !
  • Test avec 2 clefs USB branchées sur le Hub pour vérifier si elles montent : elles ne montent pas et ne montent plus après même branchées en direct !
  • Test des ports USB de mes 2 iMacs avec 2 autres clefs "intactes" (c'est à dire jamais branchées sur le Hub qui semble du coup foutre la merde pareil), et elles montent donc ports OK.

Je ne sais pas si c'est plus clair, mais c'est un peu long et tout déjà dit dans mon premier post ;-)
 

Gag

Membre actif
8 Février 2009
239
14
Boulogne-Billancourt
Disons que si le cordon est défectueux, si le cordon est responsable de la mort des 2 disques (alimentation HS, par exemple), alors changer de cordon ne va pas rescisiter les deux disques.

Mais je ne sais pas s'il est possible de tester le cordon (autrement que de brancher un 3e disque pour voir s'il devient HS, ça finirait par couter cher en disques !).
Tu m'étonnes ;-)
Je n'ai de toute façon pas pu essayer car ma tante a oublié de prendre le câble avec elle, ce qui ne m'a pas gêné puisque j'ai changé son disque de boitier et que j'avais le câble idoine (pas le même connecteur, voir plus haut).

Par contre ce qui m'étonne c'est que le câble puisse non seulement faire griller l'alim des boitiers (ça j'y ai pensé dès le début), mais aussi les disques eux-même puisque pas mieux dans un boitier neuf !

Et le truc encore plus bizarre c'est le comportement du Hub USB qui génère aussi maintenant le message "périphérique gourmand" !
Un câble hanté, voire maudit ?
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
40 943
6 411
Par contre ce qui m'étonne c'est que le câble puisse non seulement faire griller l'alim des boitiers (ça j'y ai pensé dès le début), mais aussi les disques eux-même puisque pas mieux dans un boitier neuf !
Stop, il faut arrêter de dire un peu n'importe quoi. Soit le câble est fonctionnel, soit il ne l'est pas et basta. Oui, ça m'agace, on pose des questions précises qui demandent des réponses précises. Je me répète, si les ports USB à l'arrière de l'iMac sont opérationnels et qu'une ou des clés USB, un clavier ou souris filaire sont opérationnels, il reste quoi à vérifier ? Le ou les câbles, le ou les boitiers USB, le HUB USB et le ou les disques durs.
puisque j'ai changé son disque de boitier et que j'avais le câble idoine (pas le même connecteur, voir plus haut).
Quel boîtier, marque, modèle, avec quel câble ? Une photo de tout cela donnerait une idée. Désolé, mais à distance tout le monde est aveugle, toi tu as le matériel sous les yeux, nous nous n'avons que tes écrits !
 

Gag

Membre actif
8 Février 2009
239
14
Boulogne-Billancourt
Stop, il faut arrêter de dire un peu n'importe quoi. Soit le câble est fonctionnel, soit il ne l'est pas et basta. Oui, ça m'agace, on pose des questions précises qui demandent des réponses précises. Je me répète, si les ports USB à l'arrière de l'iMac sont opérationnels et qu'une ou des clés USB, un clavier ou souris filaire sont opérationnels, il reste quoi à vérifier ? Le ou les câbles, le ou les boitiers USB, le HUB USB et le ou les disques durs.

Quel boîtier, marque, modèle, avec quel câble ? Une photo de tout cela donnerait une idée. Désolé, mais à distance tout le monde est aveugle, toi tu as le matériel sous les yeux, nous nous n'avons que tes écrits !
Il faudrait aussi un peu se détendre :
je t'ai répondu juste avant "Ça n'est pas de la mauvaise volonté, mais comme indiqué précédemment, je n'ai pas les disques sous la main et donc pour l'instant je ne peux pas avoir des infos plus précises que celles déjà données…
Je n'ai pas accès à l'iMac de ma tante pour vérifier ses ports USB".

Donc désolé de ne pas pouvoir être plus précis pour le moment, mais si tu lis mes réponses ça t'évitera de t'énerver pour rien :
je donne toutes les infos que j'ai.
Bonne soirée
 

Gag

Membre actif
8 Février 2009
239
14
Boulogne-Billancourt
Moi non plus, c'est pour ça que je viens vous voir : )

Plus sérieusement, entre mon message d'origine et le post 14, je ne sais pas ce que je peux faire de plus pour vous expliquer les symptômes…
Si c'était simple, je ne viendrait pas vous emmerder avec mes problèmes (qui ne sont pas les miens d'ailleurs : je fais ça pour ma tante !) :
ça fait 30 ans que je suis sur Mac et en général c'est moi qui répare ceux des autres (et les miens), en soft ou en hard, mais là je sèche et ne comprend pas la logique de la cascade de panne (1er disque, puis second, puis mes 2 clefs USB avec aucun point commun à part d'avoir branché le disque HS sur 3 macs…
On est d'accord, c'est louche et ça ne ressemble à rien, mais je n'y suis pour rien !

Et le fait de me balancer "Stop, il faut arrêter de dire un peu n'importe quoi. Soit le câble est fonctionnel, soit il ne l'est pas et basta. Oui, ça m'agace, on pose des questions précises qui demandent des réponses précises." alors que les réponses aux questions posées sont dans mon 1er post, puis dans le post 9, puis dans le 14 etc… et que si pas de réponse c'est que je ne peux pas les donner !

Me redemander x fois et en s'énervant les specs exactes des disques que je n'ai plus en ma possession (ce que j'ai dit et redit !) ne fera pas avancer plus vite :
si j'ai les infos, je les donne !

Bref…
J'espérais en postant ici que quelqu'un aurait déjà eu une expérience similaire ou aurait les compétences techniques pour envisager un début d'explication à cette situation très bizarre et que je ne m'explique pas :
si ça n'est pas le cas on ne va pas en faire un fromage !

Et si quelqu'un a de nouvelles questions, je me ferai un plaisir d'y répondre si je peux (je rappelle que je n'ai plus (et n'aurais pas tout de suite) ni les disques, ni le câble ;-)

Bonne fin de soirée !
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
40 943
6 411
J'espérais en postant ici que quelqu'un aurait déjà eu une expérience similaire ou aurait les compétences techniques pour envisager un début d'explication à cette situation très bizarre et que je ne m'explique pas :
si ça n'est pas le cas on ne va pas en faire un fromage !
Je n'en fait pas un fromage, mais à la base il y a un iMac, un câble, un boîtier, un disque dur, des ports USB. Il n'y a pas 36 solutions pour éliminer toutes les pistes pour trouver le coupable. Tu écris, nous lisons à distance.
Et si quelqu'un a de nouvelles questions, je me ferai un plaisir d'y répondre si je peux (je rappelle que je n'ai plus (et n'aurais pas tout de suite) ni les disques, ni le câble ;-)
Il faudra reprendre les investigations lorsque tu auras tout les matériels à portée de main, sinon on va tourner en rond. Eh oui, ce qui m'agace est de lire que les ports USB ont grillé la partie électronique du boîtier USB !

Pour savoir si les ports USB posent un problème, on lance le Terminal et on tape successivement ces 2 commandes...
Bloc de code:
ioreg -p IOUSB
...puis...
Bloc de code:
system_profiler SPUSBDataType
...ce qui donnera ceci...

Capture-000.jpg

...et là on peut voir ce qui est réellement connecté. Je vais me répéter, mais tout ceci est à faire depuis l'iMac qui pose problème et pas depuis un autre Mac, sauf pour tester dans un boîtier et câble USB sain si le disque dur pose en lui-même un problème. Il faut exclure impérativement l'utilisation d'un HUB USB.