10.13 High Sierra Une erreur s'est produite lors de la préparation de l'installation...

RemX

Membre enregistré
19 Novembre 2020
6
1
35
Bonjour à tous,

C'est un sujet récurrent avec High Sierra sur le forum mais malgré l'ensemble des pistes données dans les échanges, je n'ai pas réussi à le résoudre. Donc, voici ma petite histoire :

Je viens d'acheter un MBP mi-2012 core i5 auquel je souhaite ajouter un SSD de 500Go.

Première opération avec un SSD 2,5" de chez Crucial démonté de mon ancien MB blanc unibody de 2009 (qui tournait parfaitement sous High Sierra jusqu'au jour où l'écran a fait des siennes...). Je branche donc le SSD à la nappe SATA du MBP en lieu et place du HDD d'origine. C'est là que commence les galères :
1/ je n'ai jamais pu lancer le MBP ac le SSD qui était pourtant fonctionnel quelques minutes auparavant. Je précise au passage que la nappe SATA semble bien fonctionnelle car le SSD est reconnu lorsque je fais une vérif via le terminal diskutil list
2/ J'ai donc formater le SSD en mode "mac étendu journalisé" et relancé l'initialisation avec une clé bootable High Sierra.
3/ Un premier message d'erreur était lié à la date du MBP que j'ai changé via le terminal en prenant soin de coupé le WIFI avant...
4/ et enfin ce dernier message "Une erreur s'est produite lors de la préparation de l'installation. Essayez d'exécuter à nouveau cette application" est arrivée.
5/ J'ai essayé la même opération avec Sierra et Catalina. Rien à faire, aucun OS ne semble vouloir aller au bout de l'installation..
6/ J'ai refait une énième fois les mêmes manip avec une réinitialisation NVRAM, tjrs rien !

De forum en forum, je me suis retrouvé là : https://www.journaldulapin.com/2018/07/25/mac-ssd-firmware/
J'en ai conclu que le firmware de mon SSD n'était pas à jour. J'ai donc tenté toute la manip rEFInd expliqué dans le post. Là encore, ça n'a pas fonctionné...

Deuxième opération, je retente les mêmes opérations avec un autre SSD (Samsung 860 EVO), rebelote qd je le boote avec une clé High Sierra, je me retrouve avec le message d'erreur suivant : "Une erreur s'est produite lors de la préparation de l'installation. Essayez d'exécuter à nouveau cette application".
Ensuite, j'ai essayé une récupération directe via Internet avec une installation Catalina : après même pas une seconde l'installation se met en mode échec..

Comme vous l'aurez compris, je suis un peu perdu et à bout de mes compétences sur le sujet (qui viennent principalement des forums comme celui-ci), si vous voyez une piste... je suis preneur d'un peu d'aide ! Merci d'avance :)

à toute fin utile, je mets une photo du terminal diskutil list en PJ
 

Fichiers joints

  • IMG_20201119_094230.jpg
    IMG_20201119_094230.jpg
    62,3 KB · Affichages: 153

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
89 085
27 427
Forêt de Fontainebleau
Alors voici ce que je pense de ton cas de figure -->

- le MacBook Pro 13" mi-2012 (bonne machine par ailleurs) a un "talon d'Achille" notoire : c'est la mauvaise qualité de la nappe SATA d'usine qui relie le disque à la carte-mère en assurant alimentation et transfert des données au processeur en 2 filières séparées. On ne compte plus les cas de défaillance de cette nappe pour ce modèle exclusif de Mac. Défaillance précipitée régulièrement par la substitution d'un SSD au lent HDD d'usine (5400 tr/mn) > à cause de l'augmentation des débits en lecture / écriture dans une proportion allant des 50 Mo/s initiaux => à 500 Mo/s (x10).​
- cette défaillance de la nappe SATA du MacBook Pro 13" mi-2012 ne se manifeste pas la plupart du temps sous forme de panne franche (comme un disque carrément non connecté). Mais elle se manifeste sous une forme larvée pénible à déceler. Au sens où le disque se trouve bien connecté au Système du Mac au départ > mais où interviennent des dysfonctionnements du transfert des données du disque au processeur pour traitement et vice-versa de récupération des instructions du processeur. En somme : des I/O errors (Input/Output errors : erreurs d'entrée au processeur des données provenant du disque / erreurs de sortie du processeur des instructions destinées au disque). En gros : ça m.... dans le tuyaux de transmission.​

Je conjecture qu'à tous les coups tu es dans ce cas de figure : la nappe SATA de ton MacBook Pro 13" mi-2012 "paraît fonctionnelle" (parce que le SSD apparaît connecté au repos au Système du Mac ou même parce que l'ancien HDD fonctionnerait avec ses maigres débits de l'ordre de 50 Mo/s en lecture / écriture) ; mais elle est "défaillante à l'épreuve" en ne permettant pas de transferts de données valides à un débit de 500 Mo/s.
  • si tu voulais tester expérimentalement cette conjecture > il te suffirait de brancher le SSD au Mac en externe (via un câble SATA <=> USB) et de procéder à ton installation dans cette position. Tu verrais bien si l'opération s'effectue ou pas. Une réussite en externe vs un échec en interne => valideraient la défaillance de la nappe SATA. À remplacer contre une spécifique à ton modèle à acheter chez MacWay (dans les 20€ à 40€ pour une bonne nappe).
 

RemX

Membre enregistré
19 Novembre 2020
6
1
35
OK ! merci de l'analyse.
J'ai effectivement réalisé cette manip lorsque j'ai fait le démarrage avec rEFInd en laissant le HDD d'origine en interne et avec le SSD Crucial branché via une câble USD/SATA. Ça avait fonctionné jusqu'au moment où je rebascule le SSD en interne et là, échec du démarrage...
Si c'est bien le cas, j'ai acheté un SSD EVO 860 pour rien ;-)
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
89 085
27 427
Forêt de Fontainebleau
Oui : tu aurais dû changer la nappe au lieu de changer de SSD. Et c'est manifestement bien la nappe SATA que tu dois changer.

- mais ne te désole pas : si tu places un des SSD dans un boîtier Storeva SATA <=>USB-3 (protocole UASP) de chez MacWay encore => tu auras un SSD externe avec une connexion rapide => qui pourra te servir de support de sauvegarde (clone) de ton SSD interne. La combinaison SSD x USB-3 (UASP) en externe => permettant des clonages incrémentiels très rapides.​
 

RemX

Membre enregistré
19 Novembre 2020
6
1
35
OK, je vais voir ce que je fais de ce nouveau SSD. Merci pour le conseil de montage.
Je te tiens informé dès que j'ai la nouvelle nappe ;-) En début de semaine prochaine normalement !
Merci !
 

RemX

Membre enregistré
19 Novembre 2020
6
1
35
Hello Macomaniac,
Tout est opérationnel depuis ce matin. C'était donc bien la nappe SATA !
Merci encore pour ton aide ;-)
 

Angel08

Membre enregistré
11 Janvier 2021
1
0
35
Bonjour à tous,

Je viens d’acquérir un Mac book pro d’occasion.
Mon mari l’a réinitialisé et quand je veux installer Mac OS Sierra à la fin de l’installation sur Macintosh HD j’ai le message d’erreur : « Une erreur s est produite lors de la préparation de l’installation »
Je ne sais pas quoi faire et je suis archi novice dans le domaine et sollicite donc votre aide précieuse.
Merci par avance
 

mokuchley

Membre expert
Club MacG
27 Août 2010
4 924
375
pouvez vous faire un scan de l'identité de votre mac ; dans "a propos de ce mac"
 
  • J’aime
Réactions: Angel08

maxboug

Membre enregistré
16 Février 2021
4
0
25
Bonjour à tous,

En voulant réinitialiser mon MacBook Pro 2017 (QWERTY), je tombe désormais sur ce message d'erreur. Je ne suis pas du tout Tech Savvy mais après quelques recherches, j'ai vu que @macomaniac avait souvent pu trouver une solution. Je suis un peu désespéré...

1) J'ai déjà redémarré l'ordinateur
2) J'ai déjà réinitialisé ma mémoire VRAM

Mais rien n'y fait...

Je vais me connecter sur Safari et poster les captures d'écran, si jamais tu pouvais n'aider, j'apprécierai grandement ton aide...

Belle soirée à toi

Bloc de code:
-bash-3.2# diskutil list
/dev/disk0 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         121.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk2         121.0 GB   disk0s2

/dev/disk1 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        +2.1 GB     disk1
   1:                  Apple_HFS OS X Base System        2.0 GB     disk1s1

/dev/disk2 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +121.0 GB   disk2
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            5.0 GB     disk2s1

/dev/disk3 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +5.2 MB     disk3

/dev/disk4 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk4

/dev/disk5 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk5

/dev/disk6 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk6

/dev/disk7 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +2.1 MB     disk7

/dev/disk8 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk8

/dev/disk9 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk9

/dev/disk10 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +6.3 MB     disk10

/dev/disk11 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +2.1 MB     disk11

/dev/disk12 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +1.0 MB     disk12

/dev/disk13 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +2.1 MB     disk13

/dev/disk14 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk14

/dev/disk15 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk15

/dev/disk16 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +1.0 MB     disk16

/dev/disk17 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +6.3 MB     disk17

/dev/disk18 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk18

/dev/disk19 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        +5.9 GB     disk19
   1:                        EFI EFI                     209.7 MB   disk19s1
   2:                  Apple_HFS OS X Install ESD        5.5 GB     disk19s2

/dev/disk20 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        +2.1 GB     disk20
   1:                  Apple_HFS OS X Base System        2.0 GB     disk20s1

-bash-3.2#

--------------------------------
Note du modérateur de service (ici Aliboron) :

Merci de mettre les copies de compte-rendus de Terminal entre des balises de "Bloc de code". On les trouve dans la barre d'outils, en dessous des trois petits points :

Bloc de code.png
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
89 085
27 427
Forêt de Fontainebleau
Bonsoir maxbourg

Le disque interne porte un volume Macintosh HD de format apfs. Si tu tentes de réinstaller l'OS d'usine Sierra => sache que cet OS ne s'installe que dans un volume de format jhfs+ classique.

- les composants de réinstallation de Sierra > dans la plupart des cas de téléchargement > sont corrompus et invalides sur le serveur Apple de récupération. Si c'était le cas => quel a été l'OS le plus récent installé sur ton Mac ?​
 

maxboug

Membre enregistré
16 Février 2021
4
0
25
Bonsoir macomaniac et merci pour ta réponse,

L'OS le plus récent était la dernière MAJ de Big Sur. Je fais toujours toutes les MAJ dès qu'elles sortent.

Ayant acheté un MacBook Air M1, j'ai donc fait une réinitialisation de mon Mac (censé le vendre demain... mais cela semble compliqué désormais) et je ne m'attendais pas à avoir ce problème lors de la réinstallation de l'OS...
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
89 085
27 427
Forêt de Fontainebleau
Si tu redémarres ton Mac (Menu  > Redémarrer) > les 3 touches ⌘⌥R (command option R) pressées = démarrage via internet téléchargeant en RAM un OS de secours Big Sur et démarrant le Mac dessus à la fin -->

- obtiens-tu un écran affichant 4 Utilitaires macOS > donot l'option : "Réinstaller macOS" => propose d'installer Big Sur ?​
 

maxboug

Membre enregistré
16 Février 2021
4
0
25
Magique! Après beaucoup de bruit, de temps et d'électricité, il s'est enfin remis d'aplomb!

J'avais surement du faire le mauvais raccourci lors du démarrage...

Merci beaucoup pour ta réactivité et ton aide, vraiment.

Très belle continuation et encore merci pour toute l'aide que je t'ai vu apporter sur ces forums.