10.13 High Sierra Une erreur s'est produite lors de la préparation de l'installation...

RemX

Nouveau membre
19 Novembre 2020
6
1
33
Bonjour à tous,

C'est un sujet récurrent avec High Sierra sur le forum mais malgré l'ensemble des pistes données dans les échanges, je n'ai pas réussi à le résoudre. Donc, voici ma petite histoire :

Je viens d'acheter un MBP mi-2012 core i5 auquel je souhaite ajouter un SSD de 500Go.

Première opération avec un SSD 2,5" de chez Crucial démonté de mon ancien MB blanc unibody de 2009 (qui tournait parfaitement sous High Sierra jusqu'au jour où l'écran a fait des siennes...). Je branche donc le SSD à la nappe SATA du MBP en lieu et place du HDD d'origine. C'est là que commence les galères :
1/ je n'ai jamais pu lancer le MBP ac le SSD qui était pourtant fonctionnel quelques minutes auparavant. Je précise au passage que la nappe SATA semble bien fonctionnelle car le SSD est reconnu lorsque je fais une vérif via le terminal diskutil list
2/ J'ai donc formater le SSD en mode "mac étendu journalisé" et relancé l'initialisation avec une clé bootable High Sierra.
3/ Un premier message d'erreur était lié à la date du MBP que j'ai changé via le terminal en prenant soin de coupé le WIFI avant...
4/ et enfin ce dernier message "Une erreur s'est produite lors de la préparation de l'installation. Essayez d'exécuter à nouveau cette application" est arrivée.
5/ J'ai essayé la même opération avec Sierra et Catalina. Rien à faire, aucun OS ne semble vouloir aller au bout de l'installation..
6/ J'ai refait une énième fois les mêmes manip avec une réinitialisation NVRAM, tjrs rien !

De forum en forum, je me suis retrouvé là : https://www.journaldulapin.com/2018/07/25/mac-ssd-firmware/
J'en ai conclu que le firmware de mon SSD n'était pas à jour. J'ai donc tenté toute la manip rEFInd expliqué dans le post. Là encore, ça n'a pas fonctionné...

Deuxième opération, je retente les mêmes opérations avec un autre SSD (Samsung 860 EVO), rebelote qd je le boote avec une clé High Sierra, je me retrouve avec le message d'erreur suivant : "Une erreur s'est produite lors de la préparation de l'installation. Essayez d'exécuter à nouveau cette application".
Ensuite, j'ai essayé une récupération directe via Internet avec une installation Catalina : après même pas une seconde l'installation se met en mode échec..

Comme vous l'aurez compris, je suis un peu perdu et à bout de mes compétences sur le sujet (qui viennent principalement des forums comme celui-ci), si vous voyez une piste... je suis preneur d'un peu d'aide ! Merci d'avance :)

à toute fin utile, je mets une photo du terminal diskutil list en PJ
 

Fichiers joints

  • IMG_20201119_094230.jpg
    IMG_20201119_094230.jpg
    62,3 KB · Affichages: 13

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 063
24 176
Forêt de Fontainebleau
Alors voici ce que je pense de ton cas de figure -->

- le MacBook Pro 13" mi-2012 (bonne machine par ailleurs) a un "talon d'Achille" notoire : c'est la mauvaise qualité de la nappe SATA d'usine qui relie le disque à la carte-mère en assurant alimentation et transfert des données au processeur en 2 filières séparées. On ne compte plus les cas de défaillance de cette nappe pour ce modèle exclusif de Mac. Défaillance précipitée régulièrement par la substitution d'un SSD au lent HDD d'usine (5400 tr/mn) > à cause de l'augmentation des débits en lecture / écriture dans une proportion allant des 50 Mo/s initiaux => à 500 Mo/s (x10).​
- cette défaillance de la nappe SATA du MacBook Pro 13" mi-2012 ne se manifeste pas la plupart du temps sous forme de panne franche (comme un disque carrément non connecté). Mais elle se manifeste sous une forme larvée pénible à déceler. Au sens où le disque se trouve bien connecté au Système du Mac au départ > mais où interviennent des dysfonctionnements du transfert des données du disque au processeur pour traitement et vice-versa de récupération des instructions du processeur. En somme : des I/O errors (Input/Output errors : erreurs d'entrée au processeur des données provenant du disque / erreurs de sortie du processeur des instructions destinées au disque). En gros : ça m.... dans le tuyaux de transmission.​

Je conjecture qu'à tous les coups tu es dans ce cas de figure : la nappe SATA de ton MacBook Pro 13" mi-2012 "paraît fonctionnelle" (parce que le SSD apparaît connecté au repos au Système du Mac ou même parce que l'ancien HDD fonctionnerait avec ses maigres débits de l'ordre de 50 Mo/s en lecture / écriture) ; mais elle est "défaillante à l'épreuve" en ne permettant pas de transferts de données valides à un débit de 500 Mo/s.
  • si tu voulais tester expérimentalement cette conjecture > il te suffirait de brancher le SSD au Mac en externe (via un câble SATA <=> USB) et de procéder à ton installation dans cette position. Tu verrais bien si l'opération s'effectue ou pas. Une réussite en externe vs un échec en interne => valideraient la défaillance de la nappe SATA. À remplacer contre une spécifique à ton modèle à acheter chez MacWay (dans les 20€ à 40€ pour une bonne nappe).
 

RemX

Nouveau membre
19 Novembre 2020
6
1
33
OK ! merci de l'analyse.
J'ai effectivement réalisé cette manip lorsque j'ai fait le démarrage avec rEFInd en laissant le HDD d'origine en interne et avec le SSD Crucial branché via une câble USD/SATA. Ça avait fonctionné jusqu'au moment où je rebascule le SSD en interne et là, échec du démarrage...
Si c'est bien le cas, j'ai acheté un SSD EVO 860 pour rien ;-)
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 063
24 176
Forêt de Fontainebleau
Oui : tu aurais dû changer la nappe au lieu de changer de SSD. Et c'est manifestement bien la nappe SATA que tu dois changer.

- mais ne te désole pas : si tu places un des SSD dans un boîtier Storeva SATA <=>USB-3 (protocole UASP) de chez MacWay encore => tu auras un SSD externe avec une connexion rapide => qui pourra te servir de support de sauvegarde (clone) de ton SSD interne. La combinaison SSD x USB-3 (UASP) en externe => permettant des clonages incrémentiels très rapides.​
 

RemX

Nouveau membre
19 Novembre 2020
6
1
33
OK, je vais voir ce que je fais de ce nouveau SSD. Merci pour le conseil de montage.
Je te tiens informé dès que j'ai la nouvelle nappe ;-) En début de semaine prochaine normalement !
Merci !
 

RemX

Nouveau membre
19 Novembre 2020
6
1
33
Hello Macomaniac,
Tout est opérationnel depuis ce matin. C'était donc bien la nappe SATA !
Merci encore pour ton aide ;-)
 

Angel08

Nouveau membre
11 Janvier 2021
1
0
34
Bonjour à tous,

Je viens d’acquérir un Mac book pro d’occasion.
Mon mari l’a réinitialisé et quand je veux installer Mac OS Sierra à la fin de l’installation sur Macintosh HD j’ai le message d’erreur : « Une erreur s est produite lors de la préparation de l’installation »
Je ne sais pas quoi faire et je suis archi novice dans le domaine et sollicite donc votre aide précieuse.
Merci par avance
 

mokuchley

Membre d’élite
Club MacG
27 Août 2010
4 284
285
pouvez vous faire un scan de l'identité de votre mac ; dans "a propos de ce mac"
 
  • J’aime
Réactions: Angel08