10.15 Catalina Utiliser des installeurs anciens sur Catalina

minitoy

Membre junior
6 Juillet 2009
54
2
Lyon
Bonjour,

Ces derniers temps, je me suis lancé dans l'installation d'un certain nombre de plugins d'instruments pour Logic Pro X (je suis sous Catalina). Dans certains cas, il s'agit de plugins assez anciens. Pourtant, la plupart du temps ces plugins s'avèrent bien acceptés et fonctionnels dans Logic.
Mon petit souci est que si les logiciels sont fonctionnels une fois installés, ce qui coince parfois c'est l'installeur lui-même. C'est-à-dire que je ne peux pas utiliser cet installeur, qui est en .app et est barré d'un panneau gris.

Donc j'utilise 2 solutions jusqu'à présent. Je passe par Pacifist pour accéder aux fichiers contenus dans l'installeur pour les installer moi-même. Mais parfois ça ne peut pas fonctionner, les procédures d'installation sont trop complexes ou je n'ai pas accès aux éléments qui m'intéressent. Dans ce cas, j'effectue l'installation de manière classique sur mon vieux MacBook Pro (qui accepte de lancer l'installeur) puis je rapatrie à la main les éléments qui ont été installés sur mon Mac sous Catalina. Ce qui prend pas mal de temps…

Existe-t-il une manip qui me permettrait d'utiliser l'installeur "old school" sous Catalina, sans passer par toutes ces circonvolutions ? J'imagine que s'il s'agit de 32 bits c'est mort. Mais sinon ?… Merci !
 

lepetitpiero

Vétéran
Club MacG
20 Août 2005
8 623
478
49
Tu peux essayer (ca ne marche pas toujours) clic droit afficher le contenu du paquet et aller trifouiller dans les dossiers (souvent ressources) lancer une installation sur un paquet pas va outrepasser le bloquage.
 
Dernière édition par un modérateur:

minitoy

Membre junior
6 Juillet 2009
54
2
Lyon
Merci, oui, je fais ça aussi quand Pacifist n'est pas d'accord pour me laisser regarder à l'intérieur des installeurs.
Bon, je crois bien que je vais devoir m'en tenir à ma technique à l'ancienne :)