Wi-fi qui fonctionne sur iPhone mais pas sur Mac

adriarrighi

Membre enregistré
19 Mai 2018
8
0
33
Bonjour à tous,
Je viens demander de l'aide aujourd'hui car j'ai un problème de connectivité sur mon Mac.

Je ne comprends pas pourquoi, depuis quelques jours, mon réseau wi-fi ne fonctionne plus sur mon Mac. Le routeur wi-fi en question fonctionne très bien car je peux m'y connecter avec mon iPhone sans problème et le réseau fonctionne bien. Mais impossible de m'y connecter avec le Mac. Enfin je peux m'y connecter mais je n'ai pas d'accès à internet..

Ce qui est bizarre est que lorsque je fais un partage de 4G avec mon iPhone en Wifi, je peux me connecter sur ce partage de connexion via mon Mac.

Si vous avez des pistes je vous serai reconnaissant de m'aider.

J'ai essayé de faire le Diagnostic sans fil via le Mac mais cela n'a rien réparer.

Merci par avance.
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 952
3 163
As-tu installé des logiciels, récemment ? Un anti-virus ou un pare-feu ?
Fait une mise à jour système ?
 
  • J’aime
Réactions: adriarrighi

adriarrighi

Membre enregistré
19 Mai 2018
8
0
33
Salut Bompi,

Merci pour ta réponse aussi rapide. J'avais installé 2 logiciels ce mois-ci du coup je les ai supprimé avec CleanMyMac et j'ai redémarré mon Mac ça n'a rien changé.
Ensuite je n'ai pas installé d'antivirus ni de pare feu récemment.
J'ai essayé de faire la mise à jour vers le nouveau système OSX mais au final j'étais en partage de co 4G et vu que la mise à jour était trop lourde j'ai annulé. Mais à ce moment la mon wifi ne fonctionnait déjà plus.

Depuis quelques temps mon Mac fait un bruit chelou mais je pense que c'est le disque dur car j'entends un truc tourner donc quasi sur que c'est le disque dur et que ça n'a rien à voir avec le wifi.

Merci
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 952
3 163
Il faudrait que tu nous dises de quel Mac et de quelle version du système il s'agit.

Au sujet des deux logiciels installés puis désinstallés avec CleaMyMac, si ce n'est pas trop indiscret : quels sont-ils ?
Note que CleanMyMac peut avoir des effets de bord : désinstaller un logiciel est généralement très simple à réaliser mais dans certains cas, il faut le faire suivant une méthode adaptée, ce que ce logiciel ne saura pas faire correctement... D'où ma question.

/*=======================*/​

Si on résume :
  • tu as un routeur Wifi qui fonctionne correctement ;
  • ton Mac parvient à s'y connecter ;
  • cependant il n'a pas accès à Internet.
Dans ce genre de situations, le problème est le plus souvent dû :
  • soit à un problème de routage :
    • la configuration du réseau n'est pas bonne et la passerelle vers Internet est mal renseignée ou pas accessible etc.
  • soit à un problème de résolution de nom :
    • lorsque tu veux aller sur un site Web (par exemple) ou un serveur de messagerie, tu indiques le nom du serveur et le logiciel commence par demander à un DNS (pour Domain Name Server ou serveur de nom) quelle est l'adresse numérique du serveur correspondant ;
    • ensuite on n'utilise que les adresses numériques pour réaliser le trafic réseau proprement dit ;
    • conclusion : si le serveur de nom auquel on se réfère est en panne, mal renseigné ou inaccessible, on ne peut pas faire autre chose que d'utiliser directement des adresses numériques.
    • pour illustrer : le serveur de développement github.com (ça, c'est pour les humains) a pour adresse numérique (adresse IP ou IP address, où IP signifie Internet Protocol) : 192.30.253.112 (ça, c'est pour les machines).
  • soit à un problème de sécurité : les accès sont bloqués par un pare-feu, sur ton ordinateur ou sur le routeur.
Pour essayer d'y voir un peu plus clair, il va falloir effectuer quelques manipulations. Personnellemnt, j'utilise plutôt Terminal, bien pratique, pour qui connaît les commandes ad hoc. Mais on a sur macOS un bon utilitaire, dans /Applications/Utilitaires, qui permet d'effectuer des actions relatives au réseau.
  1. on va commencer par s'intéresser au routage :
    • connecte ton iPhone au routeur Wifi ;
      • va ensuite dans Paramètres ;
      • puis dans Wifi ;
      • là tu verras le réseau local (de ton routeur) auquel le téléphone est connecté ;
      • tu tapes sur le "i" à droite du réseau ;
      • tu vois alors quelques informations dont :
        • l'adresse IP que le routeur a allouée au téléphone ;
        • l'adresse IP du routeur ;
        • ces adresses sont au format IPV4, c'est à dire quatre nombres compris entre 1 et 254 et séparés par un point.
    • connecte ton Mac au routeur Wifi ;
      • ensuite tu ouvres Terminal ;
      • là, tu tapes la commande suivante :
        Bloc de code:
        ping -c 1 www.xxx.yyy.zzz
        en remplaçant www.xxx.yyy.zzz par l'adresse IP du routeur trouvée précédemment, ce qui doit permettre de vérifier que le Mac peut atteindre le routeur ;
      • la commande va te retourner le nombre de paquets envoyés (un, logiquement) et le nombre de paquets reçus (un, si tout va bien...)
      • si tu as une erreur ici, tu peux tout de suite arrêter là.
      • sinon, tente la commande :
        Bloc de code:
        ping -c 5 192.30.253.112
        qui va envoyer cette fois cinq paquets au serveur de GitHub, lequel accepte ce genre de requêtes
      • si tu n'as aucun paquets en retour, alors le routage ne fonctionne pas : ça va se compliquer un peu.
  2. si tu as au moins quelques paquets reçus en retour, alors on peut en déduire que le routage marche plutôt bien et on peut s'intéresser à la résolution de noms
    • puisque tu as pu atteindre le serveur GitHub par son adresse numérique, on va maintenant tenter l'adresse alphanumérique usuelle, avec la commande :
      • Bloc de code:
        ping -c 5 github.com
      • si la commande te retourne un message disant qu'elle n'a pas pu indentifier github.com, alors cela veut dire que la résolution des noms en adresse numérique se passe mal et que, vraisemblablement, ton problème vient de là ;
      • dans ce cas, il faut examiner la configuration, en allant dans les Préférences Systèmes, au rayon Réseau ;
      • là tu cliques sur "Avancé", entre ton mot de passe si nécessaire, puis tu cliques sur l'onglet DNS.
      • tu dois avoir quelque chose comme ceci :
        iu

      • poste-nous une capture de la fenêtre de ton Mac, histoire de voir quels sont les DNS ajoutés au système.
  3. Pour la sécurité, on s'en occupera une fois que le routage et le DNS auront été éclaircis.
 
  • J’aime
Réactions: adriarrighi

adriarrighi

Membre enregistré
19 Mai 2018
8
0
33
Salut! Bon tout d'abord merci pour ta réponse c'est super cool de ta part.

Alors du coup pour les logiciels que j'ai installé c'était Anki (logiciel de mémorisation de mots pour apprendre une langue), et Seed4VPN (un client VPN).



Ensuite ma config j'ai oublié de préciser, je suis sur un MacBook Pro 13" 128GB, sous MacOs High Sierra 10.13.6.

Alors je suis en train de suivre ta procédure.
Je tiens à te préciser je ne sais pas si c'est important ou non, mais sur mon réseau wifi, je capte le SSID normal, ainsi que celui avec "5G" à la fin. Donc la je vais me connecter au SSID normal sans le "5G".

Pour la première étape quand je rentre la commande sur le terminal ça me donne cela :
Capture d’écran 2018-10-26 à 20.43.06.jpg


Suite à la deuxième ligne de commande , j'ai bien reçu 5 paquets :
Capture d’écran 2018-10-26 à 20.43.41.jpg


Bon, je pense que le problème vient de là, quand je rentre la commande 'ping -c 5 github.com' j'ai un message d'erreur :

Capture d’écran 2018-10-26 à 20.43.57.jpg



Quand je vais dans l'onglet DNS des paramètres réseau de mon Mac, j'obtiens ça :

Capture d’écran 2018-10-26 à 20.44.17.jpg


Bon merci encore pour ton aide c'est super sympa !!
 
Dernière édition:

adriarrighi

Membre enregistré
19 Mai 2018
8
0
33
Re mec!

Je suis heureux de t'annoncer que grâce à toi, mon internet remarche!!!!!!!
J'ai essayé par pur hasard de mettre des DNS que j'ai trouvé sur internet, j'ai essayé celles de Google, et de CloudFare, et ça remarche super!!!! je te remercie énormément mec, par contre du coup je ne sais pas trop quelles DNS choisir. Je suis en Australie actuellement, et mon routeur est un Huawei, je sais pas si il y a des DNS particulières qui marcheraient mieux que d'autres?? Bon en tout cas ça remarche
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 952
3 163
Parfait, c'est un peu ce que j'espérais : un problème de DNS, qui reste un des plus simples à résoudre.

Les DNS de Google (8.8.8.8 et 8.8.4.4) sont très corrects. Il y a aussi ceux de OpenDNS (208.67.222.222 et 208.67.220.220). Bien entendu, il doit y avoir quelque part une contrepartie à leur gratuité. Pour Google, on s'en doute un peu : ils doivent utiliser les résolutions opérées pour ton IP pour les corréler avec le compte associé dans le même temps avec cette IP et rajouter ça dans les données liées à ton profil... Pour OpenDNS, je ne me souviens plus de leur mode de financement mais il doit bien y avoir quelque chose aussi.

Cela étant, normalement, tu ne devrais pas avoir à mettre quoi que ce soit. Le principe est que, lorsque ton Mac se connecte à un routeur, ce dernier lui donne une adresse IP, un masque et une passerelle et l'adresse IP d'un serveur DNS à utiliser, généralement le routeur lui-même ou l'un des DNS du fournisseur d'accès. Donc, en laissant libre ces zones, elles devraient se remplir correctement à la prochaine connexion, de manière automatique. Si ce n'est pas le cas, alors tu peux imposer les DNS de Google ou de OpenDNS (ou d'autres).

Pour en revenir à ton problème initial : les DNS configurés l'étaient avec des adresses IPV6 (sur seize octets) et non des adresses IPV4 (sur quatre octets), ce qui est très inhabituel.
Mon analyse est que :
  • tu as installé un logiciel de VPN ;
  • ce dernier a ajouté des éléments de configuration au coeur du système (dans la partie partagée par tout le système et les utilisateurs) ;
  • tu as désinstallé ce logiciel :
    • non pas avec un désinstallateur approprié (en général un outil qui vient avec, ou au moins une méthode donnée par le fournisseur) ;
    • mais avec CleanMyMac, qui n'y comprend pas grand-chose (ça sort complètement de ce qu'il sait traiter).
  • tu t'es retrouvé avec un système d'où le logiciel avait disparu mais une partie de sa configuration était encore là...
Conclusion : avec un logiciel simple, que tu installes par glisser/déposer, tu peux sans doute utiliser CleanMyMac pour le supprimer. Avec un logiciel qui s'installe avec un installateur, qui demande le mot de passe administrateur pour s'installer, il ne vaut mieux pas le désinstaller avec CleanMyMac mais essayer de trouver une bonne méthode, fournie par le créateur du logiciel.

Profite-bien de l'Australie (ah ! l'Australie...)
 
  • J’aime
Réactions: JLB21 et adriarrighi

adriarrighi

Membre enregistré
19 Mai 2018
8
0
33
D'accord, bon je le saurais pour la prochaine fois! Merci pour tes explications en tout cas et pour ton temps, tout était très clair. Du coup oui prochaine fois si c'est un logiciel qui influe sur mes paramètres systèmes comme ce fameux VPN je suivrai un vrai processus de désinstallation. Je savais même pas que le créateur du logiciel devait fournir un processus de désinstallation tu vois!

Bon bah merci encore un vraiment tu m'enlèves une épine du pied t'imagines même pas! parce que la 4G vaut très cher ici du coup je vais pouvoir retrouver netflix haha.

Ouai je vais profiter de l'Australie aussi quand même!! À bientôt !
 

Alizeebriz

Membre enregistré
17 Janvier 2020
1
0
23
Il faudrait que tu nous dises de quel Mac et de quelle version du système il s'agit.

Au sujet des deux logiciels installés puis désinstallés avec CleaMyMac, si ce n'est pas trop indiscret : quels sont-ils ?
Note que CleanMyMac peut avoir des effets de bord : désinstaller un logiciel est généralement très simple à réaliser mais dans certains cas, il faut le faire suivant une méthode adaptée, ce que ce logiciel ne saura pas faire correctement... D'où ma question.

/*=======================*/​

Si on résume :
  • tu as un routeur Wifi qui fonctionne correctement ;
  • ton Mac parvient à s'y connecter ;
  • cependant il n'a pas accès à Internet.
Dans ce genre de situations, le problème est le plus souvent dû :
  • soit à un problème de routage :
    • la configuration du réseau n'est pas bonne et la passerelle vers Internet est mal renseignée ou pas accessible etc.
  • soit à un problème de résolution de nom :
    • lorsque tu veux aller sur un site Web (par exemple) ou un serveur de messagerie, tu indiques le nom du serveur et le logiciel commence par demander à un DNS (pour Domain Name Server ou serveur de nom) quelle est l'adresse numérique du serveur correspondant ;
    • ensuite on n'utilise que les adresses numériques pour réaliser le trafic réseau proprement dit ;
    • conclusion : si le serveur de nom auquel on se réfère est en panne, mal renseigné ou inaccessible, on ne peut pas faire autre chose que d'utiliser directement des adresses numériques.
    • pour illustrer : le serveur de développement github.com (ça, c'est pour les humains) a pour adresse numérique (adresse IP ou IP address, où IP signifie Internet Protocol) : 192.30.253.112 (ça, c'est pour les machines).
  • soit à un problème de sécurité : les accès sont bloqués par un pare-feu, sur ton ordinateur ou sur le routeur.
Pour essayer d'y voir un peu plus clair, il va falloir effectuer quelques manipulations. Personnellemnt, j'utilise plutôt Terminal, bien pratique, pour qui connaît les commandes ad hoc. Mais on a sur macOS un bon utilitaire, dans /Applications/Utilitaires, qui permet d'effectuer des actions relatives au réseau.
  1. on va commencer par s'intéresser au routage :
    • connecte ton iPhone au routeur Wifi ;
      • va ensuite dans Paramètres ;
      • puis dans Wifi ;
      • là tu verras le réseau local (de ton routeur) auquel le téléphone est connecté ;
      • tu tapes sur le "i" à droite du réseau ;
      • tu vois alors quelques informations dont :
        • l'adresse IP que le routeur a allouée au téléphone ;
        • l'adresse IP du routeur ;
        • ces adresses sont au format IPV4, c'est à dire quatre nombres compris entre 1 et 254 et séparés par un point.
    • connecte ton Mac au routeur Wifi ;
      • ensuite tu ouvres Terminal ;
      • là, tu tapes la commande suivante :
        Bloc de code:
        ping -c 1 www.xxx.yyy.zzz
        en remplaçant www.xxx.yyy.zzz par l'adresse IP du routeur trouvée précédemment, ce qui doit permettre de vérifier que le Mac peut atteindre le routeur ;
      • la commande va te retourner le nombre de paquets envoyés (un, logiquement) et le nombre de paquets reçus (un, si tout va bien...)
      • si tu as une erreur ici, tu peux tout de suite arrêter là.
      • sinon, tente la commande :
        Bloc de code:
        ping -c 5 192.30.253.112
        qui va envoyer cette fois cinq paquets au serveur de GitHub, lequel accepte ce genre de requêtes
      • si tu n'as aucun paquets en retour, alors le routage ne fonctionne pas : ça va se compliquer un peu.
  2. si tu as au moins quelques paquets reçus en retour, alors on peut en déduire que le routage marche plutôt bien et on peut s'intéresser à la résolution de noms
    • puisque tu as pu atteindre le serveur GitHub par son adresse numérique, on va maintenant tenter l'adresse alphanumérique usuelle, avec la commande :
      • Bloc de code:
        ping -c 5 github.com
      • si la commande te retourne un message disant qu'elle n'a pas pu indentifier github.com, alors cela veut dire que la résolution des noms en adresse numérique se passe mal et que, vraisemblablement, ton problème vient de là ;
      • dans ce cas, il faut examiner la configuration, en allant dans les Préférences Systèmes, au rayon Réseau ;
      • là tu cliques sur "Avancé", entre ton mot de passe si nécessaire, puis tu cliques sur l'onglet DNS.
      • tu dois avoir quelque chose comme ceci :
        iu

      • poste-nous une capture de la fenêtre de ton Mac, histoire de voir quels sont les DNS ajoutés au système.
  3. Pour la sécurité, on s'en occupera une fois que le routage et le DNS auront été éclaircis.
Salut !! J’ai essayé de suivre le tuto bien expliqué mais je ne comprends pas pour quoi ça ne marche toujours pas sur mon mac ... j’ai ajouté une photo de ce que j’obtiens au niveau des DNS ...
En espérant que vous pourrez m’aider
Merci d’avance !
 

Fichiers joints

  • 57DA125E-12BD-47C5-964E-10B41F072104.jpeg
    57DA125E-12BD-47C5-964E-10B41F072104.jpeg
    1 000,6 KB · Affichages: 99