Wine sur Catalina pour ouvrir un fichier .exe

JChris64

Membre confirmé
12 Octobre 2019
115
8
42
Bonjour,

espérant être au bon endroit pour lancer cette discussion, j'aimerais pouvoir utiliser un logiciel que j'avais sur mon pc auparavant, sur mon nouvel Imac.(je l'ai sur une clé usb et, depuis, installé sur mon Mac.

n'étant pas expert dans ce domaine, j'ai pu trouver une appli qui semblait simple d'utilisation: Winebottler.
lorsque j'ai reçu mon Imac, vendredi, j'avais la version El capitan.Jai donc téléchargé Win et j'ai réussi à ouvrir mon fichier. Seulement, j'ai effectué une mise à jour juste après et donc installé Catalina.
Le problème est que, maintenant, cela ne fonctionne plus car le lien pour télécharger Win s'arrêtait à la version Mojave.
Pensez vous que, dans les semaines à venir, l'application sera dispo pour la version Catalina?
 

JChris64

Membre confirmé
12 Octobre 2019
115
8
42
ou bien , situation intermédiaire: passer sur Mojave où je n'aurais pas de problème pour exécuter ce fichier.
Seul soucis,je n'ai jamais installé Mojave car j'ai reçu l'Imac avec El capitan et je suis passé direct sur Catalina (n'ayant pas trouvé d'autres versions que la plus récente).
 

ysengrin85

Nouveau membre
17 Février 2020
2
0
50
ou bien , situation intermédiaire: passer sur Mojave où je n'aurais pas de problème pour exécuter ce fichier.
Seul soucis,je n'ai jamais installé Mojave car j'ai reçu l'Imac avec El capitan et je suis passé direct sur Catalina (n'ayant pas trouvé d'autres versions que la plus récente).
Bonjour,
Je suis dans la même situation que vous. Avez-vous trouvé une solution ?
 

sinbad21

Membre émérite
2 Décembre 2004
690
80
68
Wine ne fonctionne pas sous Catalina, parce que c'est une application 32 bits. En fait, il y a bien une version 64 bits de Wine, mais elle ne marche pas. Quand on la lance elle est incapable d'exécuter quoi que ce soit. Cela vient je pense de ce que Wine exécute un Windows XP, et que tout est 32 bits là-dedans.

Je pense que le mieux pour toi est de trouver l'installeur de Mojave et de l'installer. Ou alors tu pourrais essayer dans le Terminal la commande suivante, mais je ne suis pas sûr qu'elle soit reconnue sous El Capitan :
Bloc de code:
softwareupdate --ignore "macOS Catalina"
Peut-être à ce moment-là te proposera-t-il Mojave.
 

ericse

Membre émérite
30 Avril 2019
988
131
Bonjour,
Il y a une version commerciale de Wine qui s'appelle CrossOver et qui est compatible Catalina.
Sinon tu peux installer Windows sur ton Mac et faire fonctionner ton Application avec (mais ça prends beaucoup plus de ressources que Wine/CrossOver)
 
  • J’aime
Réactions: sinbad21

pouppinou

Une vie de Chien et de Pommé, et je suis heureux !
17 Juin 2017
2 239
1 997
48
Niche.
  • J’aime
Réactions: ericse

JChris64

Membre confirmé
12 Octobre 2019
115
8
42
Bonjour,
Je suis dans la même situation que vous. Avez-vous trouvé une solution ?
je suis passé sur mojave et cela fonctionne. Comme Mojave me convient, je ne passe pas sur catalina et donc je peux profiter de cs6 encore une bon moment. ;)
 
  • J’aime
Réactions: ericse