wxMaxima

astrojm

Membre junior
9 Janvier 2007
28
2
Normandie
Bonjour,
j'ai installé Maxima sur mon mac à l'aide de macports puis j'ai installé, en le compilant moi-même wxMaxima. Cependant, bien que Maxima et xMaxima marchent très bien, impossible d'utiliser wxMawima qui ne veut pas se connecter à Maxima. Après quelque test, il semblerait que Maxima plante dès que wxMaxima s'y connecte.
Quelqu'un a une idée ?
Merci d'avance pour votre aide et bon dimanche
astrojm
 

Mobyduck

Vétéran
Club MacG
10 Août 2005
7 277
2 050
Le resto' en bas de la rue...
Bonsoir astrojm,

La seule chose que j'ai pu trouvé d'approchant concerne Linux...donc impossible de savoir si ça te sera vraiment utile...

...m'enfin, à toutes fins utiles voici le lien.


A tous les coups je suis à côté de la plaque...
 

astrojm

Membre junior
9 Janvier 2007
28
2
Normandie
En fouillant un peu j'ai trouver ce message d'erreur quand wxMaxima tente de se connecter à Maxima :
Bloc de code:
jfa: starting server on port 4010
Maxima encountered a Lisp error:

 Error during processing of --eval option "(cl-user::run)":

  Socket error in "connect": ECONNREFUSED (Connection refused)

Automatically continuing.
To reenable the Lisp debugger set *debugger-hook* to nil.

debugger invoked on a SB-INT:SIMPLE-CONTROL-ERROR:
  attempt to THROW to a tag that does not exist: RETURN-FROM-DEBUGGER

Type HELP for debugger help, or (SB-EXT:QUIT) to exit from SBCL.

restarts (invokable by number or by possibly-abbreviated name):
  0: [CONTINUE] Ignore and continue with next --eval option.
  1: [ABORT   ] Skip rest of --eval options.
  2:            Skip to toplevel READ/EVAL/PRINT loop.
  3: [QUIT    ] Quit SBCL (calling #'QUIT, killing the process).

("no debug information for frame")
0]
 

Eymerich

Membre junior
5 Avril 2003
61
3
53
Paris
Bonjour,

Je viens de trouver ce billet avec une recherche web sur maxima macosx et wxmaxima pour voir si àa avait progressé. Voici deux ans j'avais passé un nombre déraisonnable d'heures à essayer de faire fonctionner ensemble maxima et cette gui. Sans succès j'avais tout recompilé, varié les options, etc... j'ai continué en mode terminal !

Devant utiliser à nouveau maxima après une période j'espérais après deux ans trouver du progrès, auquel je n'avais pu contribuer. Hélas je vois que ça ne marche toujours pas !

Je viens d'installer imaxima et vais voir ce que ça donne (je suis par ailleurs utilisateur d'emacs) par contre j'ai galéré: seul carbon emacs marche ! Or sous mac j'avais l'habitude d'aquamacs... dommage.

Par ailleurs maxima c'est super !

Bon courage
 

Eymerich

Membre junior
5 Avril 2003
61
3
53
Paris
Bonjour,

J'ai pour la première fois wxmaxima operationnel sous macosx , sur un imac G5 ppc!:up:

Malheureusement dans les nombreux essais je n'ai pas tout noté, mais voici grosso modo la démarche suivie:

1)installation manuelle de maxima:

-d'abord installation de clisp 2.41 installé à partir des sources compilés sur ma machine
-installation manuelle de maxima 5.12.0 à pârtir des sources, et suivant les instruction d'installation

2) pour wxmaxima 0.7.2

-installation de wxMac 2.8.4, téléchargé à partir du site de wxwidgets
attention macosx 10.4 contient déjà les librairies wxwidgets mais dans une version insuffisante pour wxmaxima. wxMac installe les librairies plus récentes dans un autre répertoire /usr/local/bin mais laisse en place la version originale.

-installation de wxmaxima 0.7.2
bien lire le README qui indique ce qu''il faut faire sur macos
la subtilité... que je n'ai pas lu tout de suite... est d'indiquer le bon chemin vers le binaire de configuration de wx-widgets de version > à 2.6.2
cad:
./configure --with-wx-config=/usr/local/bin/wx-config
make

puis:
make wxMaxima.app

qui va créer une application macosx qui marche !!!:)


Bon courage