Besoin d'aide sur NUMBERS

Cépartimonkiki

Membre junior
22 Mars 2013
19
2
Salut à tous, :cool:

Voilà, je suis débutant (mais qui se débrouille un peu) sur Numbers, et j'aurais besoin de votre aide, pour effectué une opération particulière d'une cellule.


Mon objectif c'est d'appliquer une fonction sur la case "Verte" et une sur la case "Rose", c'est à dire :

La Case "Verte" :
Elle doit faire la somme des cases "jaune" mais ne dois pas dépasser le chiffre 40.
Si elle dépasse le chiffre 40, le surplus dois apparaitre dans la case "Rose".


La Case "Rose" :
Elle doit recevoir le surplus de la case "Verte" mais ne dois pas dépasser le chiffre 5.
Si elle dépasse le chiffre 5, le surplus dois apparaitre dans la case "Bleu".


Une autre question : Est-il possible de verrouillé 1 cellule pour ne pas en modifié le contenu ?
Si Oui, comment faire ?

Un grand MERCI à l'avance pour ceux qui prendrons la peine de m'aider :up:
 
Dernière édition:

zeltron54

Membre d’élite
29 Mars 2008
1 906
283
Lorraine
Bonsoir,

formules à mettre dans les cellules:
En supposant que tes cellules jaunes soient en "B2 à B6".

dans la cellule verte : =SI(SOMME (B2:B6)>40;40;SOMME (B2:B6))

dans la cellule rose : =SI(SOMME (B2:B6)>45;5;SI(SOMME (B2:B6)>40;SOMME(B2:B6)-40;0))

dans la cellule bleue : =SI(SOMME (B2:B6)>45;SOMME (B2:B6)-45;0)

bonne soirée.
 

Cépartimonkiki

Membre junior
22 Mars 2013
19
2
Bonsoir,

formules à mettre dans les cellules:
En supposant que tes cellules jaunes soient en "B2 à B6".

dans la cellule verte : =SI(SOMME (B2:B6)>40;40;SOMME (B2:B6))

dans la cellule rose : =SI(SOMME (B2:B6)>45;5;SI(SOMME (B2:B6)>40;SOMME(B2:B6)-40;0))

dans la cellule bleue : =SI(SOMME (B2:B6)>45;SOMME (B2:B6)-45;0)

bonne soirée.

Un grand Merci pour ta réponse :up:

Pour être plus clair, voici le numéro des cases, car je comprends pas les calculs que tu me donnes !

 
Dernière édition:

zeltron54

Membre d’élite
29 Mars 2008
1 906
283
Lorraine
Alors tu remplace (B2:B6) par (C8:C12)
soit:

dans la cellule verte : =SI(SOMME (C8:C12)>40;40;SOMME (C8:C12))

dans la cellule rose : =SI(SOMME (C8:C12)>45;5;SI(SOMME (C8:C12)>40;SOMME(C8:C12)-40;0))

dans la cellule bleue : =SI(SOMME (C8:C12)>45;SOMME (C8:C12)-45;0)

Pour verrouiller une cellule ce n'est pas possible à ma connaissance !...
 

pepeye66

Jaccédeur
Club MacG
24 Février 2007
5 945
733
Capitale de la Catalogne Nord
Tu ne peux pas verrouiller une cellule mais tu peux y entrer une règle conditionnelle qui peut être par exemple celle ci:
Partons du principe que dans une cellule il y a la valeur "50"
Dans ta fenêtre de règle tu choisis la condition: "Le texte ne contient pas" et tu entres 50
Dans la conséquence tu choisis un remplissage de cellule en rouge.
Tu connaitras ainsi les cellules pour lesquelles des valeurs auront été modifiées.

;)
 

Cépartimonkiki

Membre junior
22 Mars 2013
19
2
Moi mon but c'était que :

En cliquant sur la touche "Enter", cela me fait naviguer QUE dans les cases à modifier :siffle:

PS : ton idée reste en tout cas une possibilité intéressante, MERCI à toi ;)