Bug découvert dans "Mail"

jall94

Membre actif
25 Juillet 2005
367
24
47
Bonjour à tous,

Je pense avoir découvert un bug dans "mail". L'erreur entraine le plantage complet du système, sans autres solutions que l'arrêt par le bouton marche/arrêt. Je peux la reproduire à volonté, et ca fonctionne à chaque fois. Je vais essayer de vous donner un maximum d'info sur le contexte, le matériel et la manip, mais c'est assez difficile.

Le matériel :

iMac G5 2 Ghz Rev. B, 2 Go de mémoire "Apple"
Tiger 10.4.3, mis à jour avec l'update combo (passé deux fois, autorisations réparées)

Le symptôme :

Lors de la manipulation décrite après, l'application "mail" se ferme innopinément, ainsi que toutes les autres applications ouvertes. Des messages de plantage pour l'ensemble des applications apparaissent à leur tour. La fenêtre du finder s'ouvre alors et clignote alternativement, ainsi que la barre de menu et le dock (en fait, tout ce qui est a l'écran disparait, réaparait, disparait etc...) rendant impossible toute autre action que l'arrêt brutal.

Ces symptomes sont reproductibles à l'infini en rejouant la séquence décrite ci-après.

Les causes :

Dans l'ordre :
1. J'ouvre "mail"
2. Je séléctionne un message pour y répondre
3. Je clique sur l'incone "répondre" -> le message s'ouvre en mode édition
4. Je séléctionne l'objet pour le modifier
5. j'appuie sur backspace pour le supprimer
6. Je bascule en saisie japonaise
7. Je tape mon objet (le curseur est donc toujours dans le champ objet)
8. je positionne la souris dans la fenêtre de message pour y placer le curseur
9. Je clique -> PLANTAGE et symptômes décris ci-dessus.

A noter que ce le fait avec quasimment tous les messages. j'ai essayé avec des messages en français pour éviter la saisie japonaise -> Idem. J'ai égalemen éssayé la touche "tab" au lieu d'utiliser la souris pour déplacer le curseur dans la fenêtr de message -> idem. Et mystérieusement, sur certains messages, ca ne le fait pas...

J'ai fait un clean install, supprimer les fichiers préferences de mails, recrée tous les comptes, réimporter les messages, un par un et en masse, j'ai également renvoyé des nouveaux messages tests depuis un PC pour repeupler ma boite de réception Mac afin d'éviter l'importation des messages qui posaient problèmes, craignant une corruption de certains fichiers -> idem. Je précise que je n'ai jamais eu de soucis avant la 10.4.3...... Mais je ne peux pas garantir que c'est lié.

Si c'est pas un bug, je mange mon chapeau. Question : comment je fais pour signaler ca a Apple, vu que je ne peux pas envoyer de rapport ??

Si certains s'intéressent à mon problème mais ne comprennent pas tout, je peux faire une petite vidéo pour illustrer le cas.

Merci par avance pour votre aide, car ce problème est extremement pénalisant pour moi. Si ca ne se règle pas, ca va m'imposer de changer de client de messagerie, ce qui ne m'arrange pas, mais alors, pas du tout... :siffle:
 

rubren

Membre expert
Club MacG
5 Septembre 2005
1 442
86
52
Le Nuage d'Oort
Tu peux aller ICI et reporter ce que tu as expliqué ci-dessus.

J'ai testé chez moi j'ai pas ce problème...mais tu peux quand même faire remonter l'info à Apple.
 

jall94

Membre actif
25 Juillet 2005
367
24
47
Voila, c'est transmis. En attendant, je migre tous mes comptes vers Thunderbird... C'est cool, j'ai l'impression de revenir sur PC ... :(
 

NightWalker

world of muse
Modérateur
Club MacG
15 Septembre 2002
13 811
1 802
Bordeaux
Ça doit vraiment dépendre des messages... par exemple chez moi, les messages d'alertes venant de MacGé me plantent Mail, seulement Mail. En fait j'ai la pizza de la mort dans ce cas. En revanche, contrairement à toi, j'ai toujours la main ce qui me permet de tuer Mail...

Je me demande s'il n'y a pas un problème avec les règles dans Mail.