Bug number formatter Xcode 5 ?

Lio70

Fitzcarraldo de l'IT
Club MacG
16 Janvier 2004
2 394
1 222
51
Cracovie
J'importe un projet Xcode 4 dans Xcode 5. Sur plusieurs XIB, il y a des number formatters sur des text fields, des labels et des cellules de tableaux. Formatters sont regles pour afficher les devises (Currency) donc, dans mon cas, l'euro. Apres avoir ouvert les XIB dans Xcode 5, compile/run et l'euro a disparu.

Je fais le test avec un nouveau projet dans Xcode 5 et c'est pareil. Je modifie les parametres regionaux, par exemple USA pour avoir le dollar en me disant que c'est peut-etre un bug avec l'euro. Non, le dollar a le meme probleme. En revanche, si on regle le formatter sur Percent, le symbole des pourcents s'affiche correctement.

Voila a quoi le probleme ressemble:
lio70-albums-divers-image22226-numform.png


Pouvez-vous tester pour voir si vous avez aussi le probleme chez vous? Si oui, je ferai tourner le radar.
 

Lio70

Fitzcarraldo de l'IT
Club MacG
16 Janvier 2004
2 394
1 222
51
Cracovie
Et en plus, c'est avec la distribution publique d'Xcode 5 via l'app store, sur Mountain Lion.

Je me souviens qu'avec la premiere Developer Preview sous Mavericks, je n'avais pas eu le probleme. :rateau:
Je n'ai pas refait le test avec une DP recente car je n'ai plus de partition Mavericks pour l'instant.

Edit ====
J'ai fait un bug report chez Apple.
 
Dernière édition:

Lio70

Fitzcarraldo de l'IT
Club MacG
16 Janvier 2004
2 394
1 222
51
Cracovie
Bug connu d'Apple.
Duplicate d'un autre rapport, toujours en open.
 

Lio70

Fitzcarraldo de l'IT
Club MacG
16 Janvier 2004
2 394
1 222
51
Cracovie
OK, le problème est réglé dans Xcode 5.1