Bug réseau sous Catalina

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 390
3 509
67
Sous la limite KT
Bon à savoir, il y a un bug touchant le partage de fichiers sous Catalina :
Vous avez des Mac sous Catalina, reliés en réseau, l'un a un ou plusieurs disques externes connectés en USB3, si vous vous connectez dessus depuis un autre, vous ne pourrez accéder qu'à son disque interne, les disques externes ne seront pas accessibles, même si le partage est correctement paramétré. Si vous essayez quand même de vous y connecter, en SMB, il vous répondra que "vous n'avez pas les autorisations requises pour vous connecter à ce serveur", et si vous vous connectez en AFP (via le bouton "Parcourir", par exemple), là, la réponse sera "Impossible d'effectuer l'opération, car l'élément d'origine de "nom du disque" est introuvable".

Ne cherchez pas, c'est un bug de Catalina connu chez Apple, seule solution : attendre la mise à jour qui réglera le problème.

Ce bug touche les versions 10.15, 10.15.1 et 10.15.2, espérons que la 10.15.3 résolve le problème. À noter que je n'ai pas pu tester avec des disques externes connectés en Thunderbolt. Je pense que c'est la même chose, mais ne peux pas l'affirmer.
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 390
3 509
67
Sous la limite KT
Bonne nouvelle : la 10.15.3 résout le problème !

Bon, fausse joie, en fait la 10.15.3 ne résout rien : l'entreprise chez qui j'ai fait le test hier a la déplorable habitude de donner des noms presque semblables à ses disques, de fait, j'ai confondu disque interne et disque externe, le bug est toujours là !
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 390
3 509
67
Sous la limite KT
Toujours pas d'amélioration de ce point de vue avec la 10.15.4, ils font quoi, chez Apple ? Pourtant, d'après ce qu'on m'a dit à l'Apple Store, ils sont au courant du bug !
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 390
3 509
67
Sous la limite KT
Toujours pas d'amélioration de ce point de vue avec la 10.15.4, ils font quoi, chez Apple ? Pourtant, d'après ce qu'on m'a dit à l'Apple Store, ils sont au courant du bug !

Bon, en fait, si, le bug est solutionné, mais je ne sais pas depuis quand, car quelque soient les mises à jour, ça ne règle pas le problème, pour que ça fonctionne, il faut faire une "clean Install", ou, plus compliqué, trouver le fichier qui met le souk, étant entendu qu'il fait partie des composants de Mac OS qui ne sont pas modifiés par les mises à jour successives.

En résumé : 10.15 et 10.15.1 le bug est présent (mon client avait installé la 10.15, et moi, sur ma machine de test, la 10.15.1), 10.15.4, il n'y est plus si clean Install, 10.15.2 et 10.15.3 ??? (pas fait de clean Install de ces deux versions).

Je vais essayer (quand ce put1 de COVID19 nous lâchera la grappe), chez mon client, de télécharger la mise à jour "combo" de la 10.15.4, pour voir … Avec un peu de chance … :siffle:
 

Jimurbis

Membre junior
26 Octobre 2005
26
0
Bonjour à tous,

Même problème chez moi depuis le passage à Catalina, jusqu'à aujourd'hui !
J'utilise Onyx depuis très longtemps et l'idée m'a pris de voir comment changer l'écran de démarrage. Onyx me dit qu'il faut désactiver le SIP. Et là, je me demande si, par hasard, le SIP ne serait pas la source de notre problème. J'ai donc désactivé le SIP sur mes deux machines (iMac et MacBook pro) et après redémarrage, je vois tous mes disques externes depuis les deux machines !!!!
L'essayer, c'est l'adopter !
Bonne journée à tous.
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 390
3 509
67
Sous la limite KT
Problème : tu as rendu tes Mac vulnérables, la question est donc : que se passe-t-il si tu le réactives ?

Bon, pour le problème de mon client, ça s'est réglé par une Clean-install (la mise à jour "combo" n'avait rien réglé) sur l'iMac qui fait office de "serveur". Sur l'autre iMac, le seul disque externe installé est la sauvegarde Time Machine, donc il a toujours le problème, je pourrais y tester la désactivation du SIP (et sa réactivation) lors de ma prochaine visite.
 

Jimurbis

Membre junior
26 Octobre 2005
26
0
Problème : tu as rendu tes Mac vulnérables, la question est donc : que se passe-t-il si tu le réactives ?

Bon, pour le problème de mon client, ça s'est réglé par une Clean-install (la mise à jour "combo" n'avait rien réglé) sur l'iMac qui fait office de "serveur". Sur l'autre iMac, le seul disque externe installé est la sauvegarde Time Machine, donc il a toujours le problème, je pourrais y tester la désactivation du SIP (et sa réactivation) lors de ma prochaine visite.

J'ai rendu mes Macs aussi vulnérables qu'ils pouvaient l'être avec MOJAVE, donc....est-ce vraiment grave ? J'ai tendance à penser que non. A suivre....
 

Jimurbis

Membre junior
26 Octobre 2005
26
0
... et bien évidemment, si je réactive le SIP, je n'ai de nouveau plus accès au contenu des disques externes des autres machines...
 

Jimurbis

Membre junior
26 Octobre 2005
26
0
Ce qui est très étonnant, c'est que ce problème n'est relayé nulle part que dans ce forum.
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 390
3 509
67
Sous la limite KT
Ce qui est très étonnant, c'est que ce problème n'est relayé nulle part que dans ce forum.

Non, mais il est abordé dans les forums Apple.

... et bien évidemment, si je réactive le SIP, je n'ai de nouveau plus accès au contenu des disques externes des autres machines...

À te relire, je pense que ton problème est autre, le bug dont je fais état concerne la machine "serveur", pas les machines "clients". Quel que soit le système de la machine "client", il n'est pas possible de se connecter aux disques externes de la machine "serveur" sous Catalina, sauf à lui refaire une clean install depuis une version de Catalina ayant corrigé le problème, puisque les mises à jour (combo ou ordinaires) ne permettent pas d'en venir à bout.
 

lolipale

Membre émérite
9 Janvier 2011
852
125
59
Thonon-les-Bains
Bonjour,

Il semblerait que ce problème soit lié au deamon smbd situé dans /usr/sbin/smbd/
La méthode serait de supprimer l'accès au disque de ce deamon dans Preferences Système, Sécurité et confidentialité, Onglet Confidentialité, Accès complet au disque et de l'y replacer ensuite.
 

alinf34

Membre confirmé
20 Septembre 2011
259
4
Sète (Hérault)
Bonjour,

Il semblerait que ce problème soit lié au deamon smbd situé dans /usr/sbin/smbd/
La méthode serait de supprimer l'accès au disque de ce deamon dans Preferences Système, Sécurité et confidentialité, Onglet Confidentialité, Accès complet au disque et de l'y replacer ensuite.

Merci pour cette piste, qui m'a permis de résoudre le problème en faisant simplement un double-clic sur ce daemon smbd :

1) rendre les fichiers masqués visibles avec la commande suivante dans le terminal (afin d'accéder au dossier /usr)
defaults write com.apple.finder AppleShowAllFiles -bool true

2) Relancer le Finder pour rendre effective la visualisation des fichiers masqués

3) faire un double-clic sur /usr/sbin/smbd/
Cela ne l'ouvre pas, il ne se passe rien, mais cela a suffi chez moi à débloquer la situation.

4) retour dans le terminal pour masquer les dossiers invisibles avec la même commande que la première, mais en remplaçant "true" par "false" :
defaults write com.apple.finder AppleShowAllFiles -bool false

5) Relancer le Finder par rendre effectif le masquage des fichiers cachés.

Chez moi, ça a suffi pour pouvoir me connecter à un disque dur externe en réseau.

NB : j'ai tenté d'utiliser Onyx pour masquer/démasquer les fichiers invisibles, mais je n'ai pas trouvé l'option dans la version 3.8.2.
 
Dernière édition:

alinf34

Membre confirmé
20 Septembre 2011
259
4
Sète (Hérault)
Merci pour cette piste, qui m'a permis de résoudre le problème en faisant simplement un double-clic sur ce daemon smbd :

1) rendre les fichiers masqués visibles avec la commande suivante dans le terminal (afin d'accéder au dossier /usr)
defaults write com.apple.finder AppleShowAllFiles -bool true

2) Relancer le Finder pour rendre effective la visualisation des fichiers masqués

3) faire un double-clic sur /usr/sbin/smbd/
Cela ne l'ouvre pas, il ne se passe rien, mais cela a suffi chez moi à débloquer la situation.

4) retour dans le terminal pour masquer les dossiers invisibles avec la même commande que la première, mais en remplaçant "true" par "false" :
defaults write com.apple.finder AppleShowAllFiles -bool false

5) Relancer le Finder par rendre effectif le masquage des fichiers cachés.

Chez moi, ça a suffi pour pouvoir me connecter à un disque dur externe en réseau.

NB : j'ai tenté d'utiliser Onyx pour masquer/démasquer les fichiers invisibles, mais je n'ai pas trouvé l'option dans la version 3.8.2.

EDIT
Mauvaise nouvelle : cette manœuvre ne fonctionne que pour la session en cours. Il faut recommencer toute la procédure après un redémarrage
 

maxou56

Membre d’élite
14 Avril 2020
1 699
357
Lorient
"Impossible d'effectuer l'opération, car l'élément d'origine de "nom du disque" est introuvable".
Capture d’écran 2020-07-09 à 21.54.47.png

La version 10.15.6 corrige ce Bug qui était présent en SMB uniquement sous Catalina. (La Bêta de cette version le réglait aussi).
Testé sur plusieurs machines.
 
Dernière édition:

alinf34

Membre confirmé
20 Septembre 2011
259
4
Sète (Hérault)
La version 10.15.6 corrige ce Bug qui était présent en SMB uniquement sous Catalina. (La Bêta de cette version le réglait aussi).
Testé sur plusieurs machines.
Merci Maxou pour cette information.
Sous 10.15.6, pour ma part, j'ai dans la barre latérale des fenêtres du Finder les icones suivants :

  • Archivage (DDE en Wi-Fi, branché par câble Ethernet sur sur ma borne Airport express) ;
  • Freebox Serveur ;
  • Réseau.

  • si je clique sur "Freebox Serveur", ça s'ouvre ;
  • si je clique sur "Archivage" : ce fameux message d'erreur ;
  • si je clique sur "Réseau", je peux ouvrir l'un ou l'autre.
Pas grave, il suffit de prendre l'habitude de cliquer sur "Réseau", je ne vais pas faire une clean install pour ça.
Donc en apparence, ce n'est pas uniquement un bug de MacOS, mais ça dépend aussi du périphérique que l'on désire joindre sur le réseau.
 
Dernière édition:

maxou56

Membre d’élite
14 Avril 2020
1 699
357
Lorient
il suffit de prendre l'habitude de cliquer sur "Réseau", je ne vais pas faire une clean install pour ça
Bonjour,
Les serveur joignable uniquement via le "réseau" ou "Aller > ce connecter au serveurs > SMB://...."
Je ne l'ai eu qu'une ou deux fois, mais j'ai désactiver/réactiver "Bonjour sur le NAS" et rebooter le mac.

Par contre c'était le bug en SMB (je n'ai pas d'AFP) "Impossible d'effectuer l'opération, car l'élément d'origine de "nom du disque" est introuvable" qui m'obligeait à relancer plusieurs fois par jour le Finder,et lui est corrigé pour ma part.
C'était tellement énervant que j'hésitais à downgrader sous Mojave, mais j'ai testé la Bêta public de 10.15.6 et là plus ce BUG :up: .


J'ai fait une Clean Install (sans importation des réglages et des données)et le bug était toujours présent.
A noter que pour moi il était présent que sur une partie de mes machines sous Catalina (avec le même environment réseaux :banghead:)
 
Dernière édition: