Clavier sur Garageband

deepsense

Membre junior
15 Novembre 2008
23
0
29
Toulouse
Bonjour,

Peut-on brancher un clavier midi sur un port usb pour jouer le clavier sur Garageband?
Si oui comment Garageband peut il le reconnaître? (Car j'ai essayé mais rien n'y fait)
Merci beaucoup.
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 492
4 300
58
St Germain en Laye - FRANCE
sans pb...

S'il n'est pas reconnu instantanément dans GarageBand, lances l'utilitaire Audio/Midi dans le dossier Utilitaires de ton Mac pour configurer la reconnaissance du clavier
 

deepsense

Membre junior
15 Novembre 2008
23
0
29
Toulouse
Merci, je ne savais pas que c'était là qu'il fallait configurer.
Dans Périphériques midi, j'ai donc "ajouté un périphérique". Il me propose plusieurs claviers ainsi que le choix entre "network" et "iac driver", en tout cas ça ne marche pas.
Que dois-je faire?
 

deepsense

Membre junior
15 Novembre 2008
23
0
29
Toulouse
Bon, dans "Configuration audio et midi" j'ai fait "afficher les infos" de l'IAC driver et j'ai coché "le périphérique est connecté". Garageband a alors signalé qu'un nouveau périphérique étais disponible, mais quand je tape mon clavier, toujours aucun son ne sors.

Quelqu'un pourrais m'aider?

Merci.
 

herculo

Membre junior
15 Mars 2004
80
4
Ben, normalement, une fois dans les Préférences de Garageband, dans Entrée Audio, tu dois retrouver ton clavier. Enfin, chez moi, ça marche comme ça.
 

meskh

Membre d’élite
Club MacG
5 Janvier 2005
4 430
546
45
Bien :up:

Tu as bien branché le OUT de ton clavier dans le IN de l'interface ?

Débranche l'USB de ton mac, lance GB, une fois qu'il est complètement lancé, allume ton KB et branche l'USB, GB doit te dire que le nombre d'entrées a changé
 

deepsense

Membre junior
15 Novembre 2008
23
0
29
Toulouse
C'est bien le problème, ça ne fait rien.

En revanche, je ne sais pas si c'est un pas en avant, mais je suis allée voir dans "utilitaires" la configuration audio/midi, et j'ai coché la case "le périphérique est connecté" dans les infos de l'IAC driver, et là ça m'a dit dans GB que le nombre d'entrées midi avait changé, qu'une entrée étais dispo. Mais ça ne fait rien à l'affaire, quand je tape sur le clavier (il est allumé, branché, tout normal) ça ne fait rien.
 

meskh

Membre d’élite
Club MacG
5 Janvier 2005
4 430
546
45
et dans les préférences GB -> Audio/MIDI, il te dit quoi dans Etat MIDI ?
 

deepsense

Membre junior
15 Novembre 2008
23
0
29
Toulouse
Il me dit "Etat midi: détection de 1 entrée midi"
C'est en effet le message qui s'est affiché une fois que j'ai coché la case "le périphérique est connecté" de l'IAC driver, mais ça ne change rien, le clavier ne marche toujours pas.
Ou alors il faut que je le connecte sur un port usb précis?
 

meskh

Membre d’élite
Club MacG
5 Janvier 2005
4 430
546
45
non pas de port usb précis, surtout si GB te le détecte, mais tu peux essayer sur un autre port si tu veux ;)

et dans la conf audio/midi de OSX, mets la par défaut pour voir ...
 

deepsense

Membre junior
15 Novembre 2008
23
0
29
Toulouse
Bah en fait il la détecte même quand le clavier usb est pas branché, donc c'est l'IAC driver qu'il détecte, je sais pas si ça sert à grand chose...
Et quand j'enlève la connexion de l'IAC driver (je précise que je ne sais pas ce que c'est que ce truc) et que je branche le clavier, non seulement ça le détecte pas, mais il ne signale plus d'entrée midi détectées...
 

meskh

Membre d’élite
Club MacG
5 Janvier 2005
4 430
546
45
Et bien je ne sais plus quoi te dire .... :rose:

Essayer le clavier sur une autre machine
Recommencer tout depuis le début, vire tout ce que tu as pu installer

Chez moi, j'ai une petite interface comme toi, je l'ai branché sans rien installer et zou c'était parti
Reprends tout depuis le début, met la conf midi de osx par défaut

Quelle est la référence précise de ton KB car je ne le trouve pas
 

deepsense

Membre junior
15 Novembre 2008
23
0
29
Toulouse
C'est un Roland ED PC-160 A (Midi keyboard controller)

En tout cas merci de ton aide, je vais essayer de voir ce que je peux faire :/

Quelqu'un d'autre a des suggestions?
 

deepsense

Membre junior
15 Novembre 2008
23
0
29
Toulouse
Problème résolu.


Il fallait que j'installe le pilote de l'interface midi et surtout, que je le mette sur off au lieu de on (paradoxal ^^ )

Merci pour votre aide.
 

deepsense

Membre junior
15 Novembre 2008
23
0
29
Toulouse
Heu c'est l'interface lui même. Y a u bouton On/off, et off permet une utilisation standard d'après ce que j'ai lu sur la notice d'Edirol.
 

meskh

Membre d’élite
Club MacG
5 Janvier 2005
4 430
546
45
C'est quand même balaud de ne pas avoir lu la doc ni vu que ton interface pouvait être active ou passive :D