Compatibilité PC-Mac Director Mx2004 - 11

ssion

Membre enregistré
25 Mai 2010
2
0
Bonjour à tous et d'avance merci à ceux qui tenteront de comprendre le dysfonctionnement que l'on rencontre.

Un de mes collègues de travail bosse sur Macintosh et sur Director depuis le tout début.

Au fil des années et des différentes versions de director il a chaque fois continué de développer sa propre application de gestion de photo scénarisées.

Cependant, vint le moment où il a fallut passer sur un Mac avec processeur Intel et MacOS 10.5. En effet Director MX2004 n'est plus compatible, et la version 11 est devenu indispensable.

Le problème est que son application ne fonctionne plus sous director 11. Les champs textes sont toujours présents techniquement mais ne s'affichent plus, et sont visuellement inexistant ; la police a été modifiée (avec des erreur d'encodage) et le programme n'est plus exploitable.

Nous avons récupéré son application et l'avons fait passer sous Windows avec director 11. Et là miracle (une fois n'est pas coutume) la conversion est parfaite, l'application fonctionne très bien, aucun bug d'affichage, tout est ok. On a porté le nouveau fichier convertis sur Macintosh sans que cela ne résolve le problème. Le programme développé fonctionne sous PC mais pas sous Macintosh avec les deux même version logiciel de director et exactement les même fichiers :confused:.

En utilisant la version d'essai 11.5, rien n'y fait, le problème reste le même, impossible d'exploiter le programme dans sa nouvelle version sous macintosh alors que sous pc ça fonctionne bien. De là à devoir passer sous windows.... Vous comprendrez qu'on préfèrerai éviter :rolleyes:

Est-ce que parmi vous quelqu'un aurait l'expertise d'un tel problème ou d'une fonctionnalité gérée différemment sous Macintosh dans la version 11 et qui ferait tout planter ?

D'avance merci pour toutes infos qui pourrait nous aider à avancer !
 

tatouille

Membre expert
1 Juin 2004
5 174
493
Stanford CA
Bonjour à tous et d'avance merci à ceux qui tenteront de comprendre le dysfonctionnement que l'on rencontre.

Un de mes collègues de travail bosse sur Macintosh et sur Director depuis le tout début.

Au fil des années et des différentes versions de director il a chaque fois continué de développer sa propre application de gestion de photo scénarisées.

Cependant, vint le moment où il a fallut passer sur un Mac avec processeur Intel et MacOS 10.5. En effet Director MX2004 n'est plus compatible, et la version 11 est devenu indispensable.

Le problème est que son application ne fonctionne plus sous director 11. Les champs textes sont toujours présents techniquement mais ne s'affichent plus, et sont visuellement inexistant ; la police a été modifiée (avec des erreur d'encodage) et le programme n'est plus exploitable.

Nous avons récupéré son application et l'avons fait passer sous Windows avec director 11. Et là miracle (une fois n'est pas coutume) la conversion est parfaite, l'application fonctionne très bien, aucun bug d'affichage, tout est ok. On a porté le nouveau fichier convertis sur Macintosh sans que cela ne résolve le problème. Le programme développé fonctionne sous PC mais pas sous Macintosh avec les deux même version logiciel de director et exactement les même fichiers :confused:.

En utilisant la version d'essai 11.5, rien n'y fait, le problème reste le même, impossible d'exploiter le programme dans sa nouvelle version sous macintosh alors que sous pc ça fonctionne bien. De là à devoir passer sous windows.... Vous comprendrez qu'on préfèrerai éviter :rolleyes:

Est-ce que parmi vous quelqu'un aurait l'expertise d'un tel problème ou d'une fonctionnalité gérée différemment sous Macintosh dans la version 11 et qui ferait tout planter ?

D'avance merci pour toutes infos qui pourrait nous aider à avancer !

as tu recompile l'appli depuis windows? ce bug est la depuis matusalem.
 

ssion

Membre enregistré
25 Mai 2010
2
0
Bonjour Tatouille,

Non l'application n'a pas été compilée. Le bug est déjà présent en mode édition. Le test de l'application en live ainsi que que la compilation de celle-ci ne change rien au dysfonctionnement rencontré :(

Quand tu parle de ce bug, de quel bug s'agit-il ? à savoir quel sont les mécanisme en jeu qui ont été identifié, je n'en ai pas entendu parlé.

Tout le problème que nous rencontrons actuellement c'est d'avoir des objets qui sont "invisible", qui à la sélection en mode édition, ont bien un contenu mais comme si il était inactif. Sur une fenêtre qu'on a créé par exemple, on distingue simplement le contour. Les lien ou le texte ne s'affichent pas.
 

tatouille

Membre expert
1 Juin 2004
5 174
493
Stanford CA
Bonjour Tatouille,

Non l'application n'a pas été compilée. Le bug est déjà présent en mode édition. Le test de l'application en live ainsi que que la compilation de celle-ci ne change rien au dysfonctionnement rencontré :(

Quand tu parle de ce bug, de quel bug s'agit-il ? à savoir quel sont les mécanisme en jeu qui ont été identifié, je n'en ai pas entendu parlé.

Tout le problème que nous rencontrons actuellement c'est d'avoir des objets qui sont "invisible", qui à la sélection en mode édition, ont bien un contenu mais comme si il était inactif. Sur une fenêtre qu'on a créé par exemple, on distingue simplement le contour. Les lien ou le texte ne s'affichent pas.

compile et place tes labels sur windows et tu verras ca marchera sur le mac