compiler libjpeg

pèrejc

Membre confirmé
6 Septembre 2002
225
13
52
au bout du monde normand
bonsoir,

Je cherche à compiler les libjpeg (afin de compiler les mpegtools).
Lors du "sudo make install" voici mon message :

/usr/bin/install -c cjpeg /usr/local/bin/cjpeg
/usr/bin/install -c djpeg /usr/local/bin/djpeg
/usr/bin/install -c jpegtran /usr/local/bin/jpegtran
/usr/bin/install -c rdjpgcom /usr/local/bin/rdjpgcom
/usr/bin/install -c wrjpgcom /usr/local/bin/wrjpgcom
/usr/bin/install -c -m 644 ./cjpeg.1 /usr/local/man/man1/cjpeg.1
install: /usr/local/man/man1/cjpeg.1: No such file or directory
make: *** [install] Error 71

bizarre alors que le make était passé. :)siffle:
J'ai essayé plusieurs manips (./configure --enable-shared --enable-static ou par fink)
mais rien de rien.
J'ajoute que je suis proche du degré zéro en matière de terminal (cette compilation étant ma première)

si une ame charitable veut m'aider..
:zen:
 

ntx

Vénérable sage
Club MacG
15 Octobre 2004
12 072
376
92
Bonjour,
il n'arrive pas à installer le fichier cjpeg.1, est-il bien présent dans ton répertoire courant, là où le makefile le cherche ? D'un autre côté, ce n'est que le manuel, pas la librairie, donc tu peux toujours modifier le makefile pour virer l'instruction d'installation de ce fichier.
 

pèrejc

Membre confirmé
6 Septembre 2002
225
13
52
au bout du monde normand
merci ntx,

bon j'ai viré les instructions d'installations des manuels (cjpeg.1, djpeg.1, jpegtran.1..) .
le "sudo make install" passe (je ne voie pas trop ce qu'il a installé..).

Par contre lorsque que je veux compiler les mpegtools, au "./configure" j'ai :

checking for pthread_attr_getstacksize... yes
checking for jpeg_start_compress in -ljpeg-mmx... no
checking jpeglib.h usability... no
checking jpeglib.h presence... no
checking for jpeglib.h... no
configure: error: jpeglib.h not found - please install the libjpeg headers

alors que le jpeglib.h existe (créé par la compile précédente). De plus fink m'a créé des répertoires libjpeg que j'ai copié dans ma library.

j'espère avoir été clair...:siffle:
 

ntx

Vénérable sage
Club MacG
15 Octobre 2004
12 072
376
92
Mais où est installé le fichier jpeglib.h ? Il devrait se trouver dans /usr/local/include.
Vérifie de même de libjpeg.a est dans /usr/local/lib.
Et vérifie aussi que ta variable d'environnement LD_LIBRARY_PATH contient /usr/local/lib.
 

pèrejc

Membre confirmé
6 Septembre 2002
225
13
52
au bout du monde normand
ntx a dit:
Mais où est installé le fichier jpeglib.h ? Il devrait se trouver dans /usr/local/include.
Vérifie de même de libjpeg.a est dans /usr/local/lib.

les deux fichiers se trouvent dans /sw/include et /sw/lib

ntx a dit:
Et vérifie aussi que ta variable d'environnement LD_LIBRARY_PATH contient /usr/local/lib.

Vu que je suis pas terrible :rose: , on fait comment pour modifier cette variable? (je ne la trouve pas..)
 

ntx

Vénérable sage
Club MacG
15 Octobre 2004
12 072
376
92
pèrejc a dit:
les deux fichiers se trouvent dans /sw/include et /sw/lib
Tiens ! Tu les a compilés ou récupérés avec Fink ?

pèrejc a dit:
Vu que je suis pas terrible :rose: , on fait comment pour modifier cette variable? (je ne la trouve pas..)
Dans le terminal, tu fais "echo $LD_LIBRARY_PATH" pour voir si ":sw/lib" se trouve dedans.
S'il n'y est pas, cela dépend du shell utilisé :
- en csh ou tcsh, tu ajoute dans le fichier .cshrc ou .tcshrc qui se trouve dans ton home :
"setenv LD_LIBRARY_PATH ${LD_LIBRARY_PATH}:/sw/lib"
- en bash, tu ajoute dans le fichier .bashrc qui se trouve dans ton home :
"$LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/sw/lib"
 

pèrejc

Membre confirmé
6 Septembre 2002
225
13
52
au bout du monde normand
ntx a dit:
Tiens ! Tu les a compilés avec Fink ?

exact, comme cité plus haut j'ai un peu tout essayé (lorsque l'on débute...)

J'ai copié en root les fichiers libjpeg.h et libjpeg.a dans usr/local/include et usr/local/lib. Mais j'ai toujours
configure: error: jpeglib.h not found - please install the libjpeg headers
lors de la compile des mpegtools :confused:
J'ai du loupé un épisode...

ntx a dit:
- en bash, tu ajoute dans le fichier .bashrc qui se trouve dans ton home :
"$LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/sw/lib"

pas trouvé ce fichier .bashrc
@+
 

ntx

Vénérable sage
Club MacG
15 Octobre 2004
12 072
376
92
pèrejc a dit:
J'ai copié en root les fichiers libjpeg.h et libjpeg.a dans usr/local/include et usr/local/lib. Mais j'ai toujours
configure: error: jpeglib.h not found - please install the libjpeg headers
lors de la compile des mpegtools :confused:
J'ai du loupé un épisode...
Il faudrait avoir la commande pour voir dans quel répertoire il cherche ce header.
pèrejc a dit:
pas trouvé ce fichier .bashrc
Comme son nom commence par un ".", c'est un fichier caché. Tu le verras avec ls -a.
 

pèrejc

Membre confirmé
6 Septembre 2002
225
13
52
au bout du monde normand
ntx a dit:
Il faudrait avoir la commande pour voir dans quel répertoire il cherche ce header.

Comme son nom commence par un ".", c'est un fichier caché. Tu le verras avec ls -a.

Yesss le configure est passé, j'ai refait l'install des jpeg-6b en "sudo make install-lib":)
p.s: j'ai toujours pas trouvé le .bashrc (ls -a, ou en effectuant une recherche avec BBedit)
merci nxt d'avoir pris du temps.;)
 

tatouille

Vétéran
1 Juin 2004
5 174
494
Stanford CA
pèrejc a dit:
bonsoir,

Je cherche à compiler les libjpeg (afin de compiler les mpegtools).
Lors du "sudo make install" voici mon message :

/usr/bin/install -c cjpeg /usr/local/bin/cjpeg
/usr/bin/install -c djpeg /usr/local/bin/djpeg
/usr/bin/install -c jpegtran /usr/local/bin/jpegtran
/usr/bin/install -c rdjpgcom /usr/local/bin/rdjpgcom
/usr/bin/install -c wrjpgcom /usr/local/bin/wrjpgcom
/usr/bin/install -c -m 644 ./cjpeg.1 /usr/local/man/man1/cjpeg.1
install: /usr/local/man/man1/cjpeg.1: No such file or directory
make: *** [install] Error 71

bizarre alors que le make était passé. :)siffle:
J'ai essayé plusieurs manips (./configure --enable-shared --enable-static ou par fink)
mais rien de rien.
J'ajoute que je suis proche du degré zéro en matière de terminal (cette compilation étant ma première)

si une ame charitable veut m'aider..
:zen:

GNU-Darwin /usr/local Setup Dist

sudo mkdir -p /usr/local/{bin,lib,libexec,include,share}
sudo mkdir -p /usr/local/share/{man,info,doc,aclocal}
sudo mkdir -p /usr/local/share/man/man{1,2,3,4,5,6,7,8}
sudo ln -s /usr/local/share/{man,info,doc} /usr/local

the Author :zen:
 

tatouille

Vétéran
1 Juin 2004
5 174
494
Stanford CA
tatouille a dit:
GNU-Darwin /usr/local Setup Dist

sudo mkdir -p /usr/local/{bin,lib,libexec,include,share}
sudo mkdir -p /usr/local/share/{man,info,doc,aclocal}
sudo mkdir -p /usr/local/share/man/man{1,2,3,4,5,6,7,8}
sudo ln -s /usr/local/share/{man,info,doc} /usr/local

the Author :zen:

l'erreur vient du dossier man1 manquant :zen: