connexion à steam impossible

tomahawkcochise

Membre confirmé
14 Juin 2007
326
7
bonjour,

des sujets similaires existent déjà mais datent un peu, et les "solutions" que j'y ai trouvées ne fonctionnent pas pour moi.

lors du premier démarrage de steam, l'application télécharge des fichiers de mise à jour (38,178 KB exactement)... puis l'application présente sa fenêtre d'accueil :

Voir la pièce jointe 71622

jusque là, tout va bien...

puis je clique sur "connexion à un compte" et cette fenêtre s'affiche :

Voir la pièce jointe 71632

pour info, le log dans le terminal lorsque je lance l'application est le suivant :

démarrage de steam :

found breakpad via in process memory: '/Applications/Steam.app/Contents/MacOS/osx32/../Frameworks/Breakpad.framework/Versions/A/Resources'
Installing breakpad crash handler
unlinked 0 orphaned pipes
$$$: Status -10811
SteamID: 0, universe Public
SteamID: 0, universe Public
Failed to load Steam Service
ServiceStart: failed to start
Errors in resource/styles/steam.styles:
Unknown key 'visible' set in style 'html-findbar' in file 'resource/styles/steam.styles'


puis après que j'ai cliqué sur "connexion à un compte" :

SteamID: 0, universe Public
KQ: Error reading KQ:Interrupted system call
Shutting down. . .
unlinked 2 orphaned pipes
CWorkThreadPool::~CWorkThreadPool:: work complete queue not empty.
CAsyncIOManager: 0 threads terminating. 0 reads, 0 writes, 0 deferrals.
CAsyncIOManager: 750 single object sleeps, 328 multi object sleeps
CAsyncIOManager: 0 single object alertable sleeps, 2 multi object alertable sleeps


voilà, je n'en sais pas plus et n'ai aucune idée de comment solutionner ce problème... (à savoir que ma première installation et essai d'utilisation de steam date d'aujourd'hui)

merci pour l'aide
 

tomahawkcochise

Membre confirmé
14 Juin 2007
326
7
C'est pas d'une grande aide, mais peut-être devrais-tu poser ta question sur le forum de Valve (y'a une section francophone ici), là-bas j'y ai trouvé ceci, peu probable que ça te soit utile...mais dans le doute.
merci pour les infos, je me suis donc baladé sur ce forum de steam... pour ne trouver aucune solution... pour sûr il y a pas mal de posts qui disent que depuis un mois des gens n'arrivent pas à se connecter, mais il n'y a pas de solution postée (pour mac, j'entends)...

le souci est que j'aimerai savoir si cela vient du logiciel steam lui-même ou bien si le souci provient du fait que les serveurs steam sont débordés... c'est pour cela que j'ai posté ce qui apparait dans le Terminal lorsque je lance l'application steam...

j'ai créé un nouveau compte et avec celui-ci l'application steam se lance, cherche à se connecter, ça moulin quelques instants (parfois une minute), puis l'application se ferme... je ne peux être en mode hors connexion car je n'ai pas encore téléchargé le programme du jeu, une connexion aux serveurs de steam est donc nécessaire pour télécharger et installer le jeu pour la première fois...

m'enfin, ça m'a l'air d'être bien la misère cette histoire de steam..:D

je ne suis pas un joueur, mais alors pas du tout, je voulais simplement profiter de l'offre gratuite du jeu "portal" (offre qui se termine le 20 septembre), juste histoire de voir par curiosité car d'un point de vue logique, ce jeu parait tout de même complètement barré!
 

Aurélie85

Membre d’élite
Club MacG
23 Juillet 2005
2 928
1 360
34
Lausanne
Viiiiite! il faut faire vite avant que l'offre prenne fin, "portal" est vraiment vraiment bien ! J'ai vite croché...!

Je me souviens que j'avais eu le même problème et que j'avais trouvé la solution sur le forum de Valve, mais dans une section anglophone...! J'arrive par contre plus à trouver le bon fil !... :( Je sais, c'est con, mais avec de la persévérance, on retrouvera le filon en question !
 

Mobyduck

Vétéran
Club MacG
10 Août 2005
7 140
1 727
Le resto' en bas de la rue...
Si tu veux être certain d'avoir le jeu sur ton compte avant la fin de l'offre, suffit de te connecter à Steam via ton navigateur internet et de l'y ajouter (Portal est ici, clic sur installer le jeu et il te proposera de te connecter...si c'est pas déjà fait). Ca résout pas ton problème, mais au moins ça t'assure de pouvoir y jouer une fois le soucis disparu.
 

tomahawkcochise

Membre confirmé
14 Juin 2007
326
7
merci bien, oui je crois que, effectivement, même si rien ne fonctionne, c'est ajouté à mon compte. Mais c'est quand même du délire cette histoire de steam : j'imagine ceux qui ont acheté un programme, bonjour l'embrouille :D.
 

Mobyduck

Vétéran
Club MacG
10 Août 2005
7 140
1 727
Le resto' en bas de la rue...
Pas faux. Sinon tu peux toujours désinstaller entièrement Steam, c'est à dire l'application et son dossier affilié*, puis le réinstaller. Tu peux également vérifier que le Coupe-feu ne le bloque pas. Après je ne vois pas quoi d'autre te dire, désolé.

* : Maison >> Bibliothèque >> Application Support >> Steam (Avec Lion: Commande + Majuscule + G >> ~/library/ Ensuite >> Application Support >> Steam)
 

tomahawkcochise

Membre confirmé
14 Juin 2007
326
7
Merci, mais j'avais déjà essayé tout cela; pour la peine, j'ai recommencé! mais lorsque je dé-installle steam complètement, puis ré-installe l'application, celle-ci ne communique plus automatiquement avec le site web (puisque les informations de compte stockées dans l'ordinateur ont été jetées à la poubelle...), la seule solution, à partir du Mac est de cliquer sur "connexion à un compte", ce qui renvoie encore et toujours sur le même message d'erreur. Si sur le site web mon compte steam est ouvert et que j'opère à partir du site web ("play now"), j'ai encore et toujours la même erreur qui s'affiche. C'est plutôt rageant :mad:.

Quand je lance steam fraichement installé... le programme commence par faire un update :
Voir la pièce jointe 71722

puis je tombe sur la fenêtre d'accueil :

Voir la pièce jointe 71732

voilà ce que dit la console à ce stade :
20/09/11 11:00:46 [0x0-0x168168].com.valvesoftware.steam[4208] found breakpad via in process memory: '/Applications/Steam.app/Contents/MacOS/osx32/../Frameworks/Breakpad.framework/Versions/A/Resources'
20/09/11 11:00:46 [0x0-0x168168].com.valvesoftware.steam[4208] Installing breakpad crash handler
20/09/11 11:00:47 [0x0-0x168168].com.valvesoftware.steam[4208] unlinked 0 orphaned pipes
20/09/11 11:00:47 [0x0-0x168168].com.valvesoftware.steam[4208] SteamID: 0, universe Public
20/09/11 11:00:47 [0x0-0x168168].com.valvesoftware.steam[4208] Failed to load Steam Service
20/09/11 11:00:47 [0x0-0x168168].com.valvesoftware.steam[4208] ServiceStart: failed to start
20/09/11 11:00:47 [0x0-0x168168].com.valvesoftware.steam[4208] Errors in resource/styles/steam.styles:
20/09/11 11:00:47 [0x0-0x168168].com.valvesoftware.steam[4208] Unknown key 'visible' set in style 'html-findbar' in file 'resource/styles/steam.styles'
20/09/11 11:01:46 [0x0-0x168168].com.valvesoftware.steam[4208] SteamID: 0, universe Public


si je clique "connexion à un compte", pendant une demi seconde une fenêtre de connexion s'affiche, puis est remplacée par la fenêtre d'erreur :

Voir la pièce jointe 71742

...une fois cliqué sur "OK" dans la fenêtre d'erreur, le programme quitte.

voilà ce que dit la console :
20/09/11 11:02:19 [0x0-0x168168].com.valvesoftware.steam[4208] KQ: Error reading KQ:Interrupted system call
20/09/11 11:02:19 [0x0-0x168168].com.valvesoftware.steam[4208] unlinked 2 orphaned pipes
20/09/11 11:02:19 com.valvesoftware.steam.ipctool[4218] ipcserver exiting with status 0
20/09/11 11:02:19 [0x0-0x168168].com.valvesoftware.steam[4208] CAsyncIOManager: 0 threads terminating. 0 reads, 0 writes, 0 deferrals.
20/09/11 11:02:19 [0x0-0x168168].com.valvesoftware.steam[4208] CAsyncIOManager: 1027 single object sleeps, 450 multi object sleeps
20/09/11 11:02:19 [0x0-0x168168].com.valvesoftware.steam[4208] CAsyncIOManager: 0 single object alertable sleeps, 2 multi object alertable sleeps
20/09/11 11:02:19 [0x0-0x168168].com.valvesoftware.steam[4208] Shutting down. . .
20/09/11 11:02:19 [0x0-0x168168].com.valvesoftware.steam[4208] CWorkThreadPool::~CWorkThreadPool:: work complete queue not empty.


... même chose si je clique "play now" à partir du site web de steam (ce qui correspond à "télécharger le jeu" puisque je n'ai jamais réussi à ce que le moindre téléchargement commence). Voilà ce que la console affiche :
20/09/11 11:07:01 [0x0-0x16a16a].com.valvesoftware.steam[4234] found breakpad via in process memory: '/Applications/Steam.app/Contents/MacOS/osx32/../Frameworks/Breakpad.framework/Versions/A/Resources'
20/09/11 11:07:01 [0x0-0x16a16a].com.valvesoftware.steam[4234] Installing breakpad crash handler
20/09/11 11:07:01 [0x0-0x16a16a].com.valvesoftware.steam[4234] unlinked 0 orphaned pipes
20/09/11 11:07:01 [0x0-0x16a16a].com.valvesoftware.steam[4234] SteamID: 0, universe Public
20/09/11 11:07:01 [0x0-0x16a16a].com.valvesoftware.steam[4234] SteamID: 0, universe Public
20/09/11 11:07:01 [0x0-0x16a16a].com.valvesoftware.steam[4234] Failed to load Steam Service
20/09/11 11:07:01 [0x0-0x16a16a].com.valvesoftware.steam[4234] ServiceStart: failed to start
20/09/11 11:07:01 [0x0-0x16a16a].com.valvesoftware.steam[4234] Errors in resource/styles/steam.styles:
20/09/11 11:07:01 [0x0-0x16a16a].com.valvesoftware.steam[4234] Unknown key 'visible' set in style 'html-findbar' in file 'resource/styles/steam.styles'
20/09/11 11:08:01 [0x0-0x16a16a].com.valvesoftware.steam[4234] SteamID: 0, universe Public





J'ai bien sûr essayé en arrêtant mon coupe-feu, même en ayant arrêté tout programme qui tourne en tâche de fond (finderpop, growl, etc.)

Je ne sais pas interpréter les messages de la console concernant le dysfonctionnement de steam...

pour plus d'informations, voici ce qui apparait dans le fichier "steam.log" :

CsComm Session Sep-20-2011 11:00:47.081 [2958647296] ReconnectThread (2958647296) Starting
CsComm Session Sep-20-2011 11:02:19.491 [2958647296] ReconnectThread (2958647296) Told to exit


Voilà, j'ai posté la totalité des informations que je peux avoir, je n'y comprends rien.:D
Donc si quelqu'un peut au moins m'éclairer sur le sens des log console... merci :cool: : mais ne serait-ce pas un problème de code html? :
"Unknown key 'visible' set in style 'html-findbar' in file 'resource/styles/steam.styles'" ??? :mouais::p
 

Mobyduck

Vétéran
Club MacG
10 Août 2005
7 140
1 727
Le resto' en bas de la rue...
Je vois que deux alternatives, soit tu contactes directement l'assistance de Valve, soit tu passes par leur forum. J'ai fureté un peu là-bas voir si une solution existait à ton problème, ou du moins une piste, malheureusement j'ai fait chou blanc… :^/
 

El_groom

Membre junior
3 Février 2010
15
0
Paris (France, Europe (?))
Et ne parlons même pas de charger le jeu Portal, actuellement impossible de créer un compte.

Il m'est venu une idée à la dixième tentative : les codes "clavier" du Mac sont exactement les même que ceux de windows (ce qui expliquerai que le Chapka soit rejeté par Valve ? car tapé sur un Mac ?) ???
Je pense que oui, mais si par cas il y avait une différence ?

Mais j'avai eu ce jeu sous windaube et j'aurais été heureux de le retrouver sur mon Mac...

Bon portal pour ceux qui l'ont chargés !