• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

CSS, .php et MAMP 5.2 : quelques bizarreries ?

smog

Membre émérite
17 Août 2005
635
44
45
Bonjour à tous,

Je me suis arraché les cheveux pas mal de temps avec MAMP 5.2 et mon fichier CSS.

D'abord, ce dernier, bien que mis à jour, n'était plus pris en compte lors du rafraichissement de la page dans safari (via MAMP, serveur en route bien sûr). J'ai renommé le fichier CSS et là ça passe...

Mais autre chose plus embêtant : mes instructions du type

Bloc de code:
#wrapper header {
    height: 50px;
    color: red;
}
ne sont pas prises en compte pour mes fichiers .php
#wrapper ou header "tout seuls" ne posent pas de problème, pas l'association des deux.
Si je fais un même fichier mais en .html, là, pas de problème, ça marche.

Ai-je loupé quelque chose ? Bug ? Méconnaissance de propriétés CSS "incompatibles" avec l'extension .php du fichier (!) ?

Merci pour votre aide !
 

smog

Membre émérite
17 Août 2005
635
44
45
Bon, pour ma première remarque, en cherchant un peu ce qui pouvait expliquer le problème, il semble que ce soit "tout simplement" le cache... En serveur local, il n'y a pas de requête envoyée lors du simple rafraichissement de page semble-t-il (je ne suis pas spécialiste) et il faut le faire via le menu DÉVELOPPEMENT > Vider le cache. Je vais voir si le problème survient de nouveau.
 

smog

Membre émérite
17 Août 2005
635
44
45
Après plusieurs tests, je crois pouvoir affirmer que le problème vient du cache.
En vidant celui-ci, mes balises sont fonctionnelles. Ouf !