"Database Daemon" - erreur de bibliothèque partagée

Nanie2

Nouveau membre
18 Septembre 2009
6
0
Bonjour à tous,

je suis très embêtée avec mon vieil IMac G5 (datant de décembre 2005):
mercredi, j'ai lancé une mise à jour automatique des logiciels et j'en ai téléchargé 2:
- une de QuickTime 7.6.4
- une MAJ de sécurité, je crois, mais dont je n'arrive pas à retrouver la trace....
Le téléchargement se passe normalement... mais après redémarrage, plus rien ne va :affraid:

Un message s'affiche:

Echec de lancement de l'application:
Impossible de lancer l'application "Database Daemon" à cause d'une erreur de bibliothèque partagée "<<Microsoft Database Daemon> >CarbonLib>< CFMPriv_CarbonCore><>"

- Je n'ai plus d'icônes dans la barre du dock
- Je n'ai plus accès dans les menus à "Redémarrer", "Eteindre" et "Forcer à quitter" (en revanche, bizarrement, je peux "mettre en veille"): je dois donc éteindre avec l'interrupteur
- Je n'ai plus accès aux applis (Office, Onyx, etc.) avec des messages d'erreur d'Apple Script (par exemple quand j'ai voulu lancer Onyx: "Erreur d'Apple Scrip - 1700")
- en revanche, j'arrive toujours à ouvrir Firefox et à avoir accès à Internet

Je suis allée voir dans le logiciel de téléchargement et voici ce que j'y ai trouvé (mais je ne suis pas certaine que ça ait un rapport avec mon problème):

Mac OS X Version 10.4.11 (assemblage 8S165)
2009-09-16 08:58:55 +0200
2009-09-16 08:58:56.469 Finder[181] CFLog (0):
CFPropertyListCreateFromXMLData(): plist parse failed; the data is not proper UTF-8. The file name for this data could be:
(UNKNOWN)
The parser will retry as in 10.2, but the problem should be corrected in the plist.
/Applications/Microsoft Office X/Office/Microsoft Database Daemon[188] Launch failed with error code -2820 (cfragFragmentCorruptErr) for application -psn_0_1179649
Sep 16 08:58:56 imac-g5-de-admin /Applications/Microsoft Office X/Office/Microsoft Database Daemon: launch failed with error code -2820 (cfragFragmentCorruptErr) for application -psn_0_1179649\n
Bref, je suis très embêtée car je suis complètement coincée sans savoir d'où vient le problème car au premier abord je n'ai téléchargé que des choses que le logiciel dédié d'Apple m'a proposées...

Comme vous l'aurez compris, je suis une bille en informatique...
alors si l'un d'entre vous pouvait m'aider à me sortir de ce sac de noeuds, ce serait vraiment très sympa!

merci beaucoup d'avance
:zen:


Personne ne pourra t'aider, du moins, pas dans "Applications", parce que les problèmes système, c'est dans "Mac OS X", qu'on les aborde !

On déménage !
 

pickwick

Membre d’élite
Club MacG
1 Octobre 2001
4 584
204
67
Genève
www.aucoeurdumac.com
Vue la situation, si vous avez le DVD de votre machine ou celui de mac os X.4 redémarrez votre machine dessus en maintenant appuyée la touche C pendant tout le démarrage.
Dans un premier temps, une fois passée l'écran de choix des langues, allez dans le menu utilitaires en haut et choisissez Utilitaire de disques. Tenter de vérifier et de réparer le disque interne de votre mac.
Une fois ces réparations effectuées, poursuivez la réinstallation de mac osx en choisissant l'option "Archivez et installez" pour ne pas perdre vos données et vos réglages.
Une fois l'installation de 10.4 terminée, redémarrez et faites toutes les mises à jour logicielles successives proposées ( plusieurs fois avec redémarrages intermédiaires) jusqu'à la combo 10.4.11 et les diverses mises à jour de sécurité et Safari, et j'espère que tout rentrera dans l'ordre.
 

Nanie2

Nouveau membre
18 Septembre 2009
6
0
Merci beaucoup, pickwick !
J'essayerai cela ce soir (car pour l'instant je suis au bureau sur un affreux PC !!)
J'espère que j'ai bien le DVD quelque part :confused::confused:
si je ne le trouvais plus... qu'est-ce qui se passe??
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 053
983
Toulouse.cong
faq.office.macintosh.free.fr
Echec de lancement de l'application:
Impossible de lancer l'application "Database Daemon" à cause d'une erreur de bibliothèque partagée "<<Microsoft Database Daemon> >CarbonLib>< CFMPriv_CarbonCore><>"
Database Daemon, c'est l'outil qui donne l'accès à la base de données d'Entourage dès le lancement (par exemple pour les alertes du calendrier). Dans le options de démarrage du compte (voir dans le panneau de préférences système "Comptes") tu as une ligne qui permet de le lancer.

Souvent, les problèmes avec le "Database Daemon" viennent d'une désinstallation/réinstallation d'Office mal faite (c'est à dire sans utiliser l'outil "Supprimer Office") et du coup, on se retrouve avec deux lignes. Quand ce n'est que ça, on peut tenter de s'en sortir en supprimant les deux lignes (il s'en recrée une au prochain lancement d'Office).

Par ailleurs le code d'erreur peut aussi laisser penser à une corruption de la base de donénes (ce qui pourrait également expliquer l'impossibilité de lancer le Daemon) et ça peut se réparer en tenant la touche "Option" enfoncée lors du lancement d'Entourage (demander une "reconstruction"). En espérant que ce soit bien ça et qu'alors la base ne soit pas trop corrompue pour être réparée (on te souhaite sinon d'avoir des sauvegardes, bien sûr).

Reste que dans le cas présent, les choses semblent plus compliquées, puisque sans rapport direct avec Office :

- Je n'ai plus d'icônes dans la barre du dock
- Je n'ai plus accès dans les menus à "Redémarrer", "Eteindre" et "Forcer à quitter" (en revanche, bizarrement, je peux "mettre en veille"): je dois donc éteindre avec l'interrupteur
- Je n'ai plus accès aux applis (Office, Onyx, etc.) avec des messages d'erreur d'Apple Script (par exemple quand j'ai voulu lancer Onyx: "Erreur d'Apple Scrip - 1700")
Les indications données par Pickwick sont peut-être un peu radicales (on n'est pas encore sûr qu'il soit nécessaire de réinstaller) même si elles seront peut-être incontournables in fine. En tout cas, il est sûr que tu peux commencer par (au minimum) une réparation des autorisations (sans le disque, ça se fait via "Utilitaire de disque" qui se trouve dans /Applications/Utilitaires).

Ensuite, tu peux toujours tenter de créer un nouveau compte utilisateur Mac OS X (toujours via le panneau de préférences système "Comptes") et voir si tes soucis sont toujours présents, à l'identique, ou si les choses sont différentes. Décris précisement ce que tu observes, ça permettra de déterminer un peu mieux où chercher la cause de tes soucis.
 

Nanie2

Nouveau membre
18 Septembre 2009
6
0
Merci beaucoup Aliboron pour tes conseils!

je commencerai par suivre tes indications et si malheureusement ce n'est pas suffisant (ce qui est à craindre...) je passerai à la grande lessive indiquée par Pickwick (enfin, si je remets la main sur le DVD.... j'ai peur :nailbiting: ...)

Une précision supplémentaire: hier soir j'ai mis Office à la poubelle, eteint avec l'interrupteur (pas le choix...) et réallumé un peu après, mais ça n'a rien changé...

Quelle galère... :(

Enfin, on verra ça tout à l'heure!

Merci encore!
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 053
983
Toulouse.cong
faq.office.macintosh.free.fr
Une précision supplémentaire: hier soir j'ai mis Office à la poubelle, eteint avec l'interrupteur (pas le choix...) et réallumé un peu après, mais ça n'a rien changé...
C'est typiquement le genre de choses à ne pas faire ;) Rien de bien grave, ceci dit, mais pour désinstaller proprement Office, il faut utiliser l'outil "Supprimer Office" qui est justement fait pour ça. Il va non seulement supprimer les applications mais aussi enlever un certain nombre d'éléments qui se trouvent ailleurs (comme justement celui qui lance le "Database Daemon" au démarrage). Par contre, il ne touche pas au contenu du dossier utilisateur, et en particulier au dossier "Identité principale" qui contient tous les messages, contacts et autres éléments d'Entourage.

Avant de réinstaller Office, il te faudra passer par là. Donc, on récapitule : désinstaller avec l'outil "Supprimer Office" (qui est sur le CD d'Office si tu ne l'as pas recopié sur ton DD), puis vider la corbeille, redémarrer, faire une réparation des autorisations, installer depuis le CD et pour finir faire les mises à jour (Office v.X doit être en version 10.1.8, si je me souviens bien).

Mais bon, si ceci est une étape utile (et probablement incontournable), il n'est pas évident que ça suffise à traiter les problèmes que tu rencontres, lesquels semblent plus larges, comme on l'a vu.
 

Nanie2

Nouveau membre
18 Septembre 2009
6
0
Alors, voici le résultat des courses... résultat mitigé!

D'abord, j'ai mis Office à la poubelle (impossible de lancer la désinstallation: même message d'erreur!)
j'ai vidé la poubelle en mode sécurisé (ça a été super long!)
j'ai éteint et rallumé
j'ai lancé l'utilitaire de disque : vérification et réparations (il y en a eu une liste longue comme le bras!!)
je suis allée dans Préférences système => Comptes et j'ai enlevé les 2 lignes Database Daemon
j'ai éteint et rallumé...
et là, ô miracle, quand l'écran s'est rallumé, ma barre d'icônes du dock était revenue et je pouvais de nouveau éteindre et redémarrer mon ordi!

ça c'est la super bonne nouvelle! :up:

En revanche, côté Office c'est toujours la panade:
je l'ai réinstallé et impossible de rien ouvrir.
A chaque fois il y a un message d'erreur qui dit:

Echec de lancement de l'application
Impossible de lancer l'apllication Word à cause d'une erreur de bibliothèque partagée "4<Microsoft Word"><CarbonLib><CFMPriv_OpenScripting><>"

Et même chose, je ne peux pas désinstaller!

Est-ce que la "solution radicale" de Pickwick pourrait changer quelque chose à la situation bloquée??

(parce qu'il faut que je vous dise que ça m'a pris une heure, mais j'ai retrouvé le CD d'installation, ou plutôt les 2 CD d'installation pour l'IMac G5! :D)

Un grand merci déjà pour m'avoir permis de revenir à un état vivable... et si vous avez encore une idée sur mes problèmes de d'Office et de Librairie partagée... je suis preneuse avec beaucoup de reconnaissance :zen:
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 053
983
Toulouse.cong
faq.office.macintosh.free.fr
Pas mieux. Les problèmes liés à CarbonLib se terminent en effet généralement par une réinstallation de Mac OS X (voir les fils qui en ont déjà traité sur le forum). D'une façon ou d'une autre, pour une raison ou une autre, une partie des composants du système ont été endommagés et ce que tu en vois sont des symptômes liés à l'impossibilité de lancer les applications "Carbon" (un des langages de développement d'applications pour Mac OS X - pour faire simple). Ce qui explique pourquoi certaines applications peuvent se lancer (celles en "Cocoa") et d'autres pas (celles en "Carbon").

Comme le dit Pickwick : courage (ce n'est pas trop long non plus, ceci dit) !
 

Nanie2

Nouveau membre
18 Septembre 2009
6
0
Bonjour à tous et en particulier à mes deux valeureux "aides"! :up:
Victoire! grâce à vous, j'ai pu tout récupérer.... je ne m'en serais jamais sortie seule...
Après les progrès enregistrés hier soir, j'ai pris mon courage à 2 mains et mes 2 CD d'installation et j'ai tout réinstallé ce matin: ça a mis un peu de temps mais ça s'est fait.
J'ai fait ensuite les mises à jour logicielles
J'ai remis Office.... et ça marche!
Merci encore !