désactiver "classic" sous os x?

mr_awd

Membre junior
13 Juin 2005
50
1
45
En voulant installer un logiciel sur mon powerbook avec "tiger" il m'as demandé si je voulais activer classic ou pas dans les préférences système.
J'ai cliqué les cases a cocher suivantes:
L'onglet Démarrer/Arrêter
Démarrer Classic a l'ouverture de session
Avertir avant de démarrer classic

et j'ai fermé la fenêtre des préférences système. L'appli ne voulais pas se lancer car os 9 n'as pas été retrouvé sur mon disque....
Ensuite, j'avais completement oublié que j'avais activé ce Classic (je suis novice dans le monde MAC) , et a l'ouverture de session
j'ai eu droit a message suivant:
Classic n'a pas trouvé de dossier système Mac OS 9 sur le disque de démarrage à utiliser.
Vous devrez peut-être Mac OS 9.1 ou ultérieur (gestion de classic) sur votre ordinateur.
Pour sélectionner un dossier système sur un autre volume.....préf.système.

Finalement j'en veux plus de classic dans mon os x :) ou en tout cas je ne veux plus qu'il se lance avec l'ouverture de la session.
Je retourne dans les préférences système je choisis classic... et la dans l'onglet Démarrer/Arrêter la case a cocher "Démarrer Classic a l'ouverture de session" n'est plus disponible !!!! enfin elle est dispo mais je ne sais pas la décocher!
Ca fait qu'a chaque ouverture/fermeture de la session j'ai droit a ce foutu message de démarrage de classic ....
Comment rendre la case a cocher disponible du nouveau afin de l'enlever?
Merci pour vos éclaircissements,

mr_awd
 

mr_awd

Membre junior
13 Juin 2005
50
1
45
beh non, pas de cadena en bas a gauche ni a droite d'ailleurs.... partout dans la fenêtre non plus!
merci quand même :)
 

mr_awd

Membre junior
13 Juin 2005
50
1
45
Encore plus bizarre que géstion "Classic" de compte admin (root) n'existe même pas dans les préf. système!
Que ce passe t-il avec mon "tiger"?
 

da capo

abonné absent
Club MacG
12 Août 2001
17 417
3 675
Salut,
Que vois-tu dans le dossier suivant :
TonDisqueDur/Bibliothèque/Preferences
Y trouves-tu un élément nommé com.apple.Classic.plist ?
 

mr_awd

Membre junior
13 Juin 2005
50
1
45
non, ce fichier n'est pas dans le dossier preferences.
J'ai même vérifié en chercheant avec spotlight pour être certain.
Il sert a quoi ce fichier?
 

jojoleretour

Membre d’élite
Club MacG
3 Mai 2005
2 811
232
sur le deuxieme dvd fournit de tiger qui s'apelle Mac os X install disc 2 il y'a un package qui s'apelle install os 9 system support, clique dessu et installe le, car je pense que tiger a un peu planté car il cherche classic sur ton HD et comme tu ne l'a pas intalle complement cela fait buggé le systeme. et pares tu pourra l 'empecher de se lancer au demarrage.

ou as tu fait reparer les autorisations ? ds l'application utilitaire de disque
 

mr_awd

Membre junior
13 Juin 2005
50
1
45
j'ai fais cela, mais bon je ne suis pas certain que les autorisations ont qque chose à voir avec mon problème... quoi que :)
 

da capo

abonné absent
Club MacG
12 Août 2001
17 417
3 675
mr_awd a dit:
non, ce fichier n'est pas dans le dossier preferences.
J'ai même vérifié en chercheant avec spotlight pour être certain.
Il sert a quoi ce fichier?
C'est un fichier de préférences pour Classic.

Et dans Tondisquedur/Système/Bibliothèque/StartUpItems ? rien à propos de Classic ?
 

jojoleretour

Membre d’élite
Club MacG
3 Mai 2005
2 811
232
et ça tu la fait ; sur le deuxieme dvd fournit de tiger qui s'apelle Mac os X install disc 2 il y'a un package qui s'apelle install os 9 system support, clique dessu et installe le, car je pense que tiger a un peu planté car il cherche classic sur ton HD et comme tu ne l'a pas intalle complement cela fait buggé le systeme. et pares tu pourra l 'empecher de se lancer au demarrage.
 

da capo

abonné absent
Club MacG
12 Août 2001
17 417
3 675
Bon dernière idée : lance l'application Moniteur d'activité et cherche un truc avec blue dans le nom
 

mr_awd

Membre junior
13 Juin 2005
50
1
45
jojoleretour a dit:
et ça tu la fait ; sur le deuxieme dvd fournit de tiger qui s'apelle Mac os X install disc 2 il y'a un package qui s'apelle install os 9 system support, clique dessu et installe le, car je pense que tiger a un peu planté car il cherche classic sur ton HD et comme tu ne l'a pas intalle complement cela fait buggé le systeme. et pares tu pourra l 'empecher de se lancer au demarrage.
c'est le dèrnier recour car effectivement j'ai ce disc mais j'ai tout mon projet de fin d'études sur mon powerbook...; alors tu comprendra vite que.... :)
 

da capo

abonné absent
Club MacG
12 Août 2001
17 417
3 675
mr_awd a dit:
vu... et je fais quoi avec... c'est blued et executé avec l'utilisateur "root"
Aucun moyen de l'arréter depuis là pour ensuite aller modifier les paramètres dans le panneau de préférences Classic ?
 

mr_awd

Membre junior
13 Juin 2005
50
1
45
Si je peux le forcer a quitter, mais toujours même problème au niveau du config de Classic, càd. la case a cocher reste "engrisé" ....
Ahh, presque oublié, merci pour ton temps! :)
 

da capo

abonné absent
Club MacG
12 Août 2001
17 417
3 675
Bon là, moi je sèche car sur ma machine je n'ai pas installé Classic et donc rien ne me permet de comparer. Je ne dispose que de qulques bouts d'infos.
Ceci dit, tu n'éteins pas ta machine à tout bout de champ non plus ?
Tu peux sauvegarder ton boulot proprement, tu pourras refaire une installation au besoin.

Désolé.
 

mr_awd

Membre junior
13 Juin 2005
50
1
45
Ne soit pas desolé!
Entre deux posts j'ai sauvegardé mon projet et les infos importants sur mon nouveau ipod nano :) et j'ai fais comme "jojoleretour" me disait.... et là tout fonctionne parfaitement :)

Super et merci a vous deux :)

mr_awd
 

jojoleretour

Membre d’élite
Club MacG
3 Mai 2005
2 811
232
et ma manip n'intalle que des modules de clasic sur tiger, c tj tiger le systeme, moi j'ai fait la manip depuis 1 mois et rien n'a planté.
tu peut tj sauvegarde tes doc sur cd avant de faire la manip
 

mr_awd

Membre junior
13 Juin 2005
50
1
45
jojoleretour a dit:
et ma manip n'intalle que des modules de clasic sur tiger, c tj tiger le systeme, moi j'ai fait la manip depuis 1 mois et rien n'a planté.
tu peut tj sauvegarde tes doc sur cd avant de faire la manip
Nous avons posté en même temps :)
Oui, j'ai fais ce que tu m'avais conseillé depuis le debut et la tout marche parfaitement bien :)
De tout façons les 320 Mb utilisés avec l'install de classic ne font aucune difference avec sur mon Powerbook avec 80 Gb de base et 50 Gb de dispo... J'avais peur de ne pas faire planter mon install car j'ai tout mon projet dessus avec une installation de postgresql d'une manière un peu spéciale et tout la config "spéciale" et bien sur tout la base de données (45 tables) plus les procedures stockées et rien n'as était sauvegardé depuis un certain temps déjà. En plus de tout ca, j'ai aussi 52 classes en php ....
Bref, j'ai tout mis sur mon ipod nano:) en plus j'ai tout uploade sur mon serveur et je me suis auto-envoyé un mail avec tout le code en attachement et comme mon compte est en imap tout reste sur un autre serveur :) Je suis bien protégé, il peut planter mon mac maintenant :)

Merci beaucoup,
mr_awd