10.10 Yosemite Disparition de DD & code 8

Pnuk

Membre junior
31 Décembre 2011
27
2
Parfait, merci. CCC est lancé et travaille, je publierais un petit compte rendu une fois le clonage fini.
... bonne nuit !
 

Pnuk

Membre junior
31 Décembre 2011
27
2
Bon matin ! Clonage accomplit. J’éteins et allume avec alt mais quand j'arrive au fameux choix des disques, je n'ai pas Macintosh HD ! J'ai évidemment Clone ainsi qu'un autre choix, avec logo de HDD, mais répondant au nom de EFI Boot. Sur lequel, quand je démarre, je tombe sur choix des langues puis Utilitaires (identique à un Recovery Mode).

Est-ce que c'est normal (il faut par exemple suivre Réinstaller Mac OSX) ? Ou quelque chose ne s'est pas bien passé quelque part ?

diskutil list, en sortie de clonage, affichait :

Bloc de code:
Last login: Sun Sep  2 15:20:04 on ttys000
MacBook-Pro-de-Emilien-2:~ Emilien$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage                         499.2 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                  Apple_HFS Clone                   999.8 GB   disk1s2
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           *498.9 GB   disk2
                                 Logical Volume on disk0s2
                                 51545A8E-6ACE-4D95-BF7C-40A0F56EFD27
                                 Unlocked Encrypted
MacBook-Pro-de-Emilien-2:~ Emilien$
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
77 130
23 722
Forêt de Fontainebleau
Hé ! hé ! CCC qui se fait prendre en flagrant délit de loupé : ce n'est pas courant. Mais ça apporte de quoi s'amuser un peu à essuyer les plâtres.


Passe les commandes :
Bloc de code:
df -H
bless --info /Volumes/Mac*

  • la 1ère mesure l'occupation de tous les volumes montés
  • la 2è retourne le chemin de démarrage du volume Macintosh HD (ou son absence de chemin)

Poste ces affichages.
 

Pnuk

Membre junior
31 Décembre 2011
27
2
Je serais paniqué si j'étais tout seul, mais si tu dis que c'est amusant tout va bien !

J'ai passé les commandes dans le Terminal en ayant démarré sur EFI Boot et non Clone, c'est bien ce qu'il fallait faire ? (ça ne change peut-être rien) :
Bloc de code:
-bash-3.2# df -H
Filesystem     Size   Used  Avail Capacity  iused     ifree %iused  Mounted on
/dev/disk1s2   1.3G   1.3G    31M    98%   317359      7640   98%   /
devfs          201k   201k     0B   100%      680         0  100%   /dev
/dev/disk3     5.2M   369k   4.9M     8%       88      1190    7%   /private/var/log
/dev/disk4     524k   147k   377k    29%       34        92   27%   /Volumes
/dev/disk5     524k   143k   381k    28%       33        93   26%   /private/var/tmp
/dev/disk6     524k   160k   365k    31%       37        89   29%   /private/var/run
/dev/disk7     524k   147k   377k    29%       34        92   27%   /System/Installation
/dev/disk8     524k   270k   254k    52%       64        62   51%   /private/var/db
/dev/disk9     6.3M   2.7M   3.6M    43%      650       884   42%   /private/var/folders
/dev/disk10    2.1M   209k   1.9M    10%       49       461   10%   /private/var/root/Library
/dev/disk11    1.0M   152k   897k    15%       35       219   14%   /Library/ColorSync/Profiles/Displays
/dev/disk12    524k   168k   356k    33%       39        87   31%   /Library/Preferences
/dev/disk13    524k   168k   356k    33%       39        87   31%   /Library/Preferences/SystemConfiguration
/dev/disk14    1.0M   143k   905k    14%       33       221   13%   /Library/Keychains
/dev/disk15    6.3M   176k   6.1M     3%       41      1493    3%   /private/var/tmp/RecoveryTemp
/dev/disk2s2   1000   243G   757G    25% 59308859 184789433   24%   /Volumes/Clone
/dev/disk0s3   650M   554M    89M    87%   136865     21825   86%   /Volumes/Image Volume
-bash-3.2# bless --info /Volumes/Mac*
No mount point for /Volumes/Mac*
Can't get mount point for /Volumes/Mac*
-bash-3.2#
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 929
3 161
Pour la seconde commande, suite à ton démarrage, ce serait plutôt :
Bloc de code:
bless --info /Volumes/Clone
qui devrait indiquer le dossier à partir duquel sera effectué le démarrage, si tu cherches à démarrer sur le volume Clone.
C'est une manière de vérifier qu'effectivement, les informations nécessaires au démarrage sur Clone sont bien présentes.
 

Pnuk

Membre junior
31 Décembre 2011
27
2
Oh ok, alors voici :

Bloc de code:
-bash-3.2# bless --info /Volumes/Clone
finderinfo[0]: 410822 => Blessed System Folder is /Volumes/Clone/System/Library/CoreServices
finderinfo[1]: 419415 => Blessed System File is /Volumes/Clone/System/Library/CoreServices/boot.efi
finderinfo[2]:      0 => Open-folder linked list empty
finderinfo[3]:      0 => No alternate OS blessed file/folder
finderinfo[4]:      0 => Unused field unset
finderinfo[5]: 410822 => OS X blessed folder is /Volumes/Clone/System/Library/CoreServices
64-bit VSDB volume id:  0x60DB11BAB0109E02
-bash-3.2#
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 929
3 161
Comme ça, c'est mieux ;)
Cela dit, j'ai un perdu le fil de ce que vous tentez de faire...
 

Pnuk

Membre junior
31 Décembre 2011
27
2
Pour résumé : depuis un DDE, je peux démarrer sur le clone de mon DD. L'idée était de cloner ce clone sur le DDI (fait avec CCC), mais quand je vais pour choisir (en ayant démarrer avec alt) le disque de démarrage, pas de Macintosh HD en vue mais à la place un EFI Boot. Lequel m'amène à la même interface que le Recovery Mode une fois sélectionné...
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 929
3 161
OK.
=======================​
Tu as réussi à créer un clone du disque interne sur le disque externe.
Tu peux démarrer sur ce disque externe.
Tu as alors réinitialisé le disque interne.
Puis cloné à rebours le disque externe sur le disque interne (avec CCC, cette fois-ci).
Pas de chance, tu ne parviens toujours pas à démarrer sur le disque interne.

Il me semble que, finalement, trois opérations sensibles ont été réalisées :
  1. un clonage dans un sens ; a priori la commande a repris à peu près tout sauf la description des périphériques ;
  2. la réinitialisation du disque interne ; mais sans supprimer Filevault, si je ne me trompe pas ?
  3. un clonage à rebours : même remarque qu'en 1)
Finalement, peu de choses ont changé entre le point de départ et maintenant ; je veux dire que c'est pour l'essentiel le même système.

=======================​

Ton problème actuel est de ne pas pouvoir démarrer sur le disque interne : il est bien possible que la bénédiction (blessing en anglais : mais où sont-ils allés chercher ce mot...) n'ait pas fonctionné comme attendu.
Dans ce cas je te conseille :
  • de démarrer sur le système cloné ;
  • de monter la partition du disque interne contenant le système, si ce n'est pas fait automatiquement ;
  • de tenter la bénédiction,
    • soit depuis les Préférences Systèmes, où tu peux choisir le système de démarrage ;
    • soit depuis Terminal en passant une commande bless :
      Bloc de code:
      bless --folder "/Volumes/Macintosh HD/System/Library/CoreServices" --file "/Volumes/Macintosh HD/System/Library/CoreServices/boot.efi"
Puis redémarrer.

Note : tu ne souhaites pas virer Filevault ? On pourrait imaginer que, pour une raison à déterminer, c'est lui qui met le bazar.
 

Pnuk

Membre junior
31 Décembre 2011
27
2
=======================
Tu as réussi à créer un clone du disque interne sur le disque externe.
Tu peux démarrer sur ce disque externe.
Tu as alors réinitialisé le disque interne.
Puis cloné à rebours le disque externe sur le disque interne (avec CCC, cette fois-ci).
Pas de chance, tu ne parviens toujours pas à démarrer sur le disque interne.

Il me semble que, finalement, trois opérations sensibles ont été réalisées :
  1. un clonage dans un sens ; a priori la commande a repris à peu près tout sauf la description des périphériques ;
  2. la réinitialisation du disque interne ; mais sans supprimer Filevault, si je ne me trompe pas ?
  3. un clonage à rebours : même remarque qu'en 1)
Finalement, peu de choses ont changé entre le point de départ et maintenant ; je veux dire que c'est pour l'essentiel le même système.

Oui, c'est bien ça !

de monter la partition du disque interne contenant le système, si ce n'est pas fait automatiquement ;

Je ne suis pas sûr de comment faire ça. Par instinct, je pense que ça se joue dans Utilitaires de Disques ? Si oui, le disque interne Macintosh HD est déjà affiché comme monté. J'attends ta validation (ou non) avant de passer à la bénédiction (je ne m'imaginais pas faire ça de si bon matin !)

Concernant le redémarrage final, j'y vais avec alt + choix du disque interne ? Ou un simple redémarrage classique ?

Note : tu ne souhaites pas virer Filevault ? On pourrait imaginer que, pour une raison à déterminer, c'est lui qui met le bazar.

@macomaniac m'avait posé la question en effet, mais je ne m'y connais pas assez pour décider. S'il n'y a pas de danger à "vivre" sans, qu'au contraire cela peut régler le problème, alors je suis ok pour le désactiver/supprimer.
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 929
3 161
Je commence par la fin : Filevault protège ton disque donc en soi, c'est une bonne chose.
Toutefois, il est un peu maximaliste dans le sens que absolument tout est chiffré sur le disque. Du coup, je trouve que c'est un peu excessif. Une version précédente se contentait de chiffrer la maison de l'utilisateur et ça suffisait amplement.

Disons donc que si tu le désactives, il est préférable :
  1. d'identifier les données qui sont sensibles : celles que tu souhaites protéger, dont tu ne veux pas qu'elles puissent être lues par quelqu'un te volant ta machine ou, plus simplement, qui l'utilise avec un autre compte ;
  2. de créer une image disque chiffrée (sorte de pseudo-volume) que tu montes au démarrage et dans lequel tu stockes les données sensibles.
C'est moins immédiat, c'est moins "global" mais c'est largement suffisant dans la grande majorité des cas.
==== ==== ==== ====​
Revenons à ce pauvre disque interne : effectivement, si tu vois "Macintosh HD" dans la liste des volumes du Finder, c'est qu'il est déjà monté. Tu peux alors tenter de le bénir de nouveau.

Note que, en toute logique, cela peut se faire tout simplement par le choix du disque de démarrage dans les Préférences Systèmes. Ensuite tu éteins l'ordinateur. Puis tu débranches le disque externe.
Puis tu rallumes l'ordinateur qui devrait démarrer directement sur le disque interne.

Si, comme on peut le craindre, ça ne veut toujours pas passer, alors je te conseillerais de :
  1. éteindre l'ordinateur ;
  2. rebrancher le disque externe ;
  3. redémarrer sur le disque externe en maintenant la touche alt enfoncée et en choisissant le disque externe ;
  4. totalement réinitialiser le disque interne avec l'Utilitaire de disque :
    • choisir de nouveau le type de partitionnement GPT ;
    • donner un nom sans espace à l'unique partition (les espaces, c'est casse-pied) ;
    • si possible sans Filevault (de toutes façons, si tout marche bien, tu pourras réactiver Filevault après coup).
  5. cloner de nouveau le disque externe vers le disque interne ;
  6. vérifier / refaire une petite bénédiction...
  7. redémarrer en maintenant alt enfoncée pour voir si ce fichu disque interne veut bien revenir à un meilleur comportement.
[On peut dire que tout ceci est un peu long et galère...]
 
  • J’aime
Réactions: Pnuk

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
77 130
23 722
Forêt de Fontainebleau
@ Pnuk

Les commandes que je t'avais proposées supposaient bien entendu que tu sois resté dans ta session de Clone. Car pour cette session le volume Macintosh HD était monté. Quand tu as redémarré pour te loger dans la session de secours --> le volume Macintosh HD a été aussitôt reverrouillé et il est resté verrouillé et non monté. Il ne pouvait alors qu'échapper à la commande mesurant (entre autre) son occupation. De même qu'à la commande s'enquérant de son chemin de démarrage.

Loge-toi dans ta session Emilien de Clone. Déverrouille et remonte le volume Macintosh HD. Repasse les commandes :
Bloc de code:
df -H
bless --info /Volumes/Mac*

  • tu vas obtenir le tableau des occupations des volumes montés > et le chemin (ou non chemin) de démarrage de Macintosh HD

Poste ces retours ici : on saura si CCC a bien cloné une quantité de données en accord avec celles contenues dans Clone > et si le volume Macintosh HD a bien un chemin de démarrage valide. Il ne doit pas en avoir un > puisque qu'il est invisible à l'écran du gestionnaire de démarrage (touche "alt").
 

Pnuk

Membre junior
31 Décembre 2011
27
2
Messieurs,
nous sommes sur la bonne voie, voire peut-être arrivés au bout du chemin !
Note que, en toute logique, cela peut se faire tout simplement par le choix du disque de démarrage dans les Préférences Systèmes. Ensuite tu éteins l'ordinateur. Puis tu débranches le disque externe.
Puis tu rallumes l'ordinateur qui devrait démarrer directement sur le disque interne.

Suite à cette manip, j'ai pu retomber comme auparavant sur la fenêtre d'ouverture de session (avec invité également proposé), parcourir mes fichiers, ouvrir quelques logiciels : tout semble bon ! Je prévois de faire une sauvegarde Time Machine, de me séparer du clone, d'utiliser le Mac pendant quelques jours...
... puis de revenir vous donner des nouvelles. Plus probablement un immense remerciement :up:
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 929
3 161
Espérons que tout est revenu à la normale.
Note quand même qu'il est bien pratique d'avoir, sinon un clone complet, au moins un système sur lequel démarrer quand le système interne ne va pas bien.
Pour cette raison, j'ai toujours un système prêt à l'emploi sur un disque externe (clone ou pas) pour parer au plus pressé.

Tu remarqueras que, dans tout ça, on n'a pas élucidé la cause de tes problèmes : cela milite pour une certaine prévoyance ;)
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
77 130
23 722
Forêt de Fontainebleau
@ Pnuk

Content pour toi !

Si tu n'en as pas l'emploi --> je te conseille de désactiver FileVault (Menu  > Préférences Système > Sécurité et confidentialité > FileVault). Faire dépendre le volume de démarrage Macintosh HD d'une architecture CoreStorage chiffrée complique énormément la donne.
 

Pnuk

Membre junior
31 Décembre 2011
27
2
Une semaine plus tard, tout roule toujours très bien ! La leçon est toujours la même : il faut multiplier les sauvegardes. Dans mon cas, je ne vais pas dédier trop de temps à la recherche de la source du problème car je vais incessamment sous peu changer de disque dur et en profiter pour procéder à une clean install.

Immense merci à vous @bompi et @macomaniac... Est-ce votre métier d'aider la communauté du forum ? Votre accompagnement est si professionnel, mais pourtant gratuit... Ça pique ma curiosité ! En tout cas, s'il y a quelque chose que je peux faire en retour, dites le moi.

Finalement, j'espère que ce premier thread public, qui était le premier pour moi, pourra servir à quelqu'un en détresse !
 
  • J’aime
Réactions: peyret et macomaniac