• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

El Capitain ... et Java

PatrickQuebec

Membre confirmé
15 Avril 2008
112
2
Une question toute simple.

Depuis l'installation d'El Capitain, j'ai un pop up qui s'ouvre me proposant d'installer JAVA.

Le hic... c'est que j'ai deja installe JAVA ...et le pop up s'ouvre encore et encore

J'ai loupé une manipulation ?

Par avance, je vous remercie de votre réponse.
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 453
4 222
57
St Germain en Laye - FRANCE
C'est un problème que certains ont rencontré lors du passage à Yosemite.

Il semble qu'il y ait des elements ajoutés au Mac ayant besoin d'une ancienne version de Java (version 6 diffusée par Apple et "adaptée" à la gestion de certains éléments spécifiques au Mac).

Cette version est toujours diffusée par Apple et il est indiqué clairement qu'elle convient à El Capitan

Pour supprimer ce message à chaque allumage, il faut aller telecharger JAVA 6 sur le site Apple et l'installer (par dessus la version 8 fournie par Oracle


Autre option: trouver l'application réclamant cette ancienne version de Java et la désinstaller. Mais dans tout ce que j'ai lu, je n'ai jamais vu personne avoir réussi à identifier l'application en question....
 

PatrickQuebec

Membre confirmé
15 Avril 2008
112
2
Merci :)
j'ai installe la version que tu indiques, affaire à suivre ;)

Petite precision, en ce qui me concerne, j'ai ce Pop-up plusieurs par jour, quelques soit l'activité, et pas uniquement quand je sorts mon MBA de sa veille.
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 453
4 222
57
St Germain en Laye - FRANCE
Certains l'ont à l'ouverture de session, d'autres à la sortie de veille, d'autres de façon beaucoup plus aléatoire et à tous bouts de champs... Probablement que ça dépend de l'application tournant en tâche de fond et qui a besoin de ces resources Java6

Cela dit, je pense qu'il serait prudent d'essayer de trouver qu'elle application nécessite cette vieille version de Java pour, si possible, la supprimer ou la mettre à jour

C'est tout de même embêtant de conserver une version de Java comportant pas mal de failles de sécurité.
 

Arthemus

Membre d’élite
Club MacG
6 Juin 2002
1 698
17
Oise
J'ai eu le problème aussi. Du coup j'ai télécharger la dernière version depuis le site d'Oracle directement et tout fonctionne !
 

PatrickQuebec

Membre confirmé
15 Avril 2008
112
2
J'ai eu le problème aussi. Du coup j'ai télécharger la dernière version depuis le site d'Oracle directement et tout fonctionne !
Ben justement, j'ai telecharge la version 8 depuis le site d'oracle et ca n'a pas reglé le probleme d'ou mon message.

avec la version 6 ca semble fonctionner.
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 453
4 222
57
St Germain en Laye - FRANCE
oui et c'est spécifiquement pour d'anciennes applications nécessitant cette vieille version de Java et ne sachant utiliser la version 8, qu'Apple diffuse toujours cette version de Java en confirmant, à chaque nouvelle version d'OS X qu'elle est bien toujours fonctionnelle (cf le message l'accompagnant, qui a été actualisé à la sortie d'ElCapitan):

Java for OS X 2015-001 installs the legacy Java 6 runtime for OS X 10.11 El Capitan, OS X 10.10 Yosemite, OS X 10.9 Mavericks, OS X 10.8 Mountain Lion, and OS X 10.7 Lion.

This package is exclusively intended for support of legacy software and installs the same deprecated version of Java 6 included in the 2014-001 and 2013-005 releases.
 

brubru

Membre junior
1 Décembre 2003
74
3
Ah ! Je remonte le sujet car je connais ça et c'est un peu pénible de voir cette fenêtre intempestive demandant d'installer Java.
Ca fait cela depuis l'installation de El Capitan sur mon mac pro (début 2009)
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 453
4 222
57
St Germain en Laye - FRANCE
La solution préconisée par Apple, je l'ai donnée plus haut (installer la version 6 "spéciale Apple" en plus de la version 8 d'Oracle), par contre, personnellement je chercherais plutot à identifier l'application demandant cette vieille version de Java pour la supprimer ou la mettre à jour (installer les mises à jour de Java comblant les failles de sécurité identifiée ne sert à rien, si on réinstalle une vieille version 6 comportant ces failles!)
 

lolipale

Membre émérite
9 Janvier 2011
751
99
58
Thonon-les-Bains
Bonjour,
oui et c'est spécifiquement pour d'anciennes applications nécessitant cette vieille version de Java
Euh ... Pour info, Adobe Illustrator réclame toujours et encore ce logiciel ...
 

PatrickQuebec

Membre confirmé
15 Avril 2008
112
2
En ce qui me concerne, depuis que j'ai mis la solution proposée par REMY, je n'ai plus aucun problème.

Java vient de proposer une mise à jour ... peut être que cela règle le problème.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
30 448
3 142
Euh ... Pour info, Adobe Illustrator réclame toujours et encore ce logiciel ...
Quelle version ?

Avec Illustrator CC 2015, je n'ai jamais vu une demande d'installation de Java.
 

Deuxnattes

Nouveau membre
9 Février 2016
6
0
32
Salut à tous,
J'ai le même problème ! J'ai besoin de Java SE 6 pour utiliser mes logiciels de graphisme : illustrator etc).
Savez ou ou je peux trouver la version 6 ?
Je ne la trouve pas !
Merci d'avance :)
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 453
4 222
57
St Germain en Laye - FRANCE
Solution au post #4
 

lolipale

Membre émérite
9 Janvier 2011
751
99
58
Thonon-les-Bains

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 453
4 222
57
St Germain en Laye - FRANCE
Oui j'ai bien vu mais pour a part ça ne fonctionne pas/
Alors le problème est sans doute ailleurs...
Quel message d'erreur au lancement d'Illustrator par exemple?