Erreur mysql sous léopard

benassis

Membre junior
10 Janvier 2006
73
0
Bonjour,

J'ai récemment installé Léopard sur un imac intel dual core. J'ai aussi installé la librairie GD préparée par Marc liyanage sur ce site, avec apache et php5. :http://www.entropy.ch/phpbb2/viewtopic.php?t=2668&postdays=0&postorder=asc&start=105.
Maintenant, j'essaie d'installer mysql-5.0.45-osx10.4-i686.tar (à noter que la version pour Léopard n'est pas encore disponible).
Depuis une semaine, je galère pour démarrer mysql. J'ai réinstallé mysql 3 trois plutôt qu'une mais je reçois constamment des messages d'erreur. Dans le terminal, à la commande
Bloc de code:
./bin/mysqld -u root -p

je reçois :
Bloc de code:
...(je vous fais grâce d'une trentaine de lignes comme les suivantes
...
InnoDB: Unable to lock ./ibdata1, error: 35
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
InnoDB: Unable to lock ./ibdata1, error: 35
InnoDB: Check that you do not already have another mysqld process
InnoDB: using the same InnoDB data or log files.
071128 10:34:44  InnoDB: Unable to open the first data file
InnoDB: Error in opening ./ibdata1
071128 10:34:44  InnoDB: Operating system error number 35 in a file operation.
InnoDB: Error number 35 means 'Resource temporarily unavailable'.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.0/en/operating-system-error-codes.html
InnoDB: Could not open or create data files.
InnoDB: If you tried to add new data files, and it failed here,
InnoDB: you should now edit innodb_data_file_path in my.cnf back
InnoDB: to what it was, and remove the new ibdata files InnoDB created
InnoDB: in this failed attempt. InnoDB only wrote those files full of
InnoDB: zeros, but did not yet use them in any way. But be careful: do not
InnoDB: remove old data files which contain your precious data!
071128 10:34:44 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use
071128 10:34:44 [ERROR] Do you already have another mysqld server running on port: 3306 ?
071128 10:34:44 [ERROR] Aborting

071128 10:34:44 [Note] ./bin/mysqld: Shutdown complete
Ensuite, j'envoie les commandes suivantes :
Bloc de code:
bash-3.2# /usr/local/mysql-5.0.45-osx10.4-i686/support-files/mysql.server stop
Shutting down MySQL
.. SUCCESS! 
bash-3.2# /usr/local/mysql-5.0.45-osx10.4-i686/support-files/mysql.server start
Starting MySQL
 SUCCESS! 
bash-3.2# apachectl stop
bash-3.2# apachectl start
bash-3.2# /usr/local/mysql-5.0.45-osx10.4-i686/support-files/mysql.server stop
Shutting down MySQL
.. SUCCESS! 
bash-3.2# ./bin/mysqld -u root
071128 11:47:05 [Warning] Setting lower_case_table_names=2 because file system for /usr/local/mysql/data/ is case insensitive
071128 11:47:05  InnoDB: Started; log sequence number 0 43655
071128 11:47:05 [Note] ./bin/mysqld: ready for connections.
Version: '5.0.45'  socket: '/tmp/mysql.sock'  port: 3306  MySQL Community Server (GPL)
Ici, après ces dernières llgnes, je perds le contrôle du terminal qui ne répond plus à mes commandes tandis que le Moniteur d'activité m'indique qu'il n'y a aucun démon mysql...
Quelqu'un a une idée du problème ou une solution ?
 

benassis

Membre junior
10 Janvier 2006
73
0
J'ai finalement réussi à installer et configurer mysql après de nombreux essais.
Maintenant, il fonctionne normalement lorsque je consulte une base et une table avec une interface php/mysql que j'ai créée. Pourtant, phpmyadmin refuse de démarrer et le message d'erreur suivant s'affiche dans mon navigateur :
Safari ne peut ouvrir la page « http://mon_no_ip:8080/phpmyadmin/ » car le serveur a inopinément interrompu la connexion, ce qui se produit parfois lorsqu’il est occupé. Vous serez peut-être en mesure d’ouvrir la page ultérieurement.
Aussi, je suis étonné qu'une fois activé mysql ne crée pas de démon (daemon) visible depuis le moniteur d'activité, comme je suis habitué de le voir. Est-ce normal ?
Quelqu'un a une idée ?
 

benassis

Membre junior
10 Janvier 2006
73
0
J'ai résolu le problème pour phpmyadmin : dans le fichier config.inc.php il faut pour l'authentification remplacer cookie par http comme ceci :
Bloc de code:
$cfg['Servers'][$i]['auth_type'] = 'http';
Je ne sais pas pourquoi, mais ça fonctionne en tout cas.

Mais je relance l'autre question :
Je suis étonné qu'une fois activé mysql ne crée pas de démon (daemon) visible depuis le moniteur d'activité, comme je suis habitué de le voir. Est-ce normal ?