ffmpegX pas de son

boddy

Membre d’élite
Club MacG
17 Mars 2005
3 727
350
Face à la Méditerranée
Bonjour,
J'ai téléchargé ffmpegX et tous ses composants ce matin. Il fonctionne normalement (pas de message d'erreur). Je veux transformer un fichier .mov en .avi pour le regarder sur un lecteur de salon en divX.

J'ai bien un nouveau fichier qui se crée en .avi : il y a les images, mais pas le son.
Comment faire ?
 

samalaplaya

Membre d’élite
Club MacG
16 Mars 2005
3 164
120
Hello,

Quelle est le format de la piste audio de ton mov ? Pour le savoir: pomme + j dans QT ou pomme + i dans VLC... Ensuite, quand tu donnes ton mov dans le format source d'ffmpegX, il n'y a pas de "illisible" dans audio... mais quoi, alors ?
 

Paski.pne

Membre d’élite
Club MacG
7 Novembre 2005
4 468
769
on the Lost Highway
perso.wanadoo.fr
Salut,
Il y a peut-être un autre problème, un mauvais choix de la piste audio dans ffmpegX.

Lorsque tu es dans ffmpegX, quand tu as sélectionné ton film à compresser et que tu cliques sur "joue" en haut à droite, est-ce que le film est joué avec le son ?

Si ce n'est pas le cas, c'est que ce n'est pas la bonne piste audio qui est choisie. Alors, tu cliques sur l'onglet audio, tu changes la piste audio (ex : 1 à la place de 0) et tu re-cliques sur joue, et tu modifies cette valeur jusqu'à que le film joué le soit avec le son.
 

samalaplaya

Membre d’élite
Club MacG
16 Mars 2005
3 164
120
Non, si tu fais "joue", il lit la piste source, c'est tout. ça sert surtout lorsqu'il a on container avec différents fichiers dedans, comme les ST ou des pistes audio diverses (mpeg2 multiplexé vob, ...) pour savoir si c'est le bon titre, angle etc. que l'on va encoder.
S'il ne la lit pas, c'est qu'il n'a pas le codec (c'est rare mais du son de WM par ex.) pour le lire...
Ce que tu voulais lui dire se fait avec "prévis.", une prévis. du film avec tous les paramètres des onglets tel qu'il les as définis.
Cependant, dans un mov, il ne doit pas y avoir 36 pistes audio, je pense ;)
 

Paski.pne

Membre d’élite
Club MacG
7 Novembre 2005
4 468
769
on the Lost Highway
perso.wanadoo.fr
Ce n'est pas seulement un problème avec le film encodé, mais aussi avec le film d'origine. Il m'est arrivé que sur le film encodé il n'y ait pas de son et qu'en vérifiant le film d'origine en le faisant jouer avec ffmpegX je remarque que le son n'apparaissait pas, et en changeant alors de piste, le film joue avec le son et le film encodé ensuite possédait ce son. Mais tout ça est un vieux souvenir ;), donc tu as peut-être raison et c'est seulement par la "Pévis" que l'on réussit à voir si le son passe. Je ne m'en rappelle plus :rose:.

Je ne suis pas connaisseur de ffmpegX, mais je pense qu'il faut être sûr de la piste son à lui donner à encoder, car s'il en sélectionne une vide (un reste probable des différentes versions audio que possédait le film d'origine) le film encodé n'aura pas de son.

Mais bien sûr, il faut aussi que la piste audio soit dans un format reconnu par ffmpegX ;).
 

samalaplaya

Membre d’élite
Club MacG
16 Mars 2005
3 164
120
Oui. D'ailleurs, la meilleure manière de connaitre le format et n° de piste d'un fichier est de l'ouvrir dans VLC et de faire pomme + i.
 

boddy

Membre d’élite
Club MacG
17 Mars 2005
3 727
350
Face à la Méditerranée
J'étais partie... mais me voilà revenue ! avec tous mes problèmes...

D'abord, si ça peut aider, voilà l'animation que je veux pouvoir lire sur un lecteur de salon : http://www.storewars.org/flash/index.html

Je l'ai donc téléchargée et j'ai un fichier sw_8M.mov que je peux lire avec VLC (son et image). Voilà ce que je trouve quand je fais Pomme + i :

Flux O
- Codec - mp4a
- Langue - ___
- Type - Audio
- Canaux - 1
- Débit d'échantillons - 32000 Hz
- Bits par échantillons - 16
- Débits - 512 kb/s

Flux 1
- Codec - mp4v
- Langue - ___
- Type - Vidéo
- Résolution - 320x180
- Débit d'images - 11.988000

Général
- Durée 0:05:48

Dans ffmpegX, si je clique sur "joue", il n'y a pas de son. Si je rajoute 1 dans adio = idem.

D'ailleurs, ffmpegX ne m'intéresse que parce qu'il peut me créer un fichier .avi, parce que vous aurez remarqué que je n'ai pas besoin de compression.

J'essaie de vous joindre aussi une copie d'écran de ffmpegX, et j'attends votre aide... MERCI.
 

samalaplaya

Membre d’élite
Club MacG
16 Mars 2005
3 164
120
Dans ffmpegX, si je clique sur "joue", il n'y a pas de son.
Oui, c'est vrai, j'ai vu que ffmpegX lit à tort dans l'entête "o channels" d'AAC en audio...
Sache aussi que vu la taille (320/180), ça va être horrible sur ta tv :eek:
J'ai pas le temps maintenant, mais je te l'envoie en MP ce soir, en divx avi (divx6/mp3)
 

boddy

Membre d’élite
Club MacG
17 Mars 2005
3 727
350
Face à la Méditerranée
samalaplaya a dit:
Oui, c'est vrai, j'ai vu que ffmpegX lit à tort dans l'entête "o channels" d'AAC en audio...
Sache aussi que vu la taille (320/180), ça va être horrible sur ta tv :eek:
J'ai pas le temps maintenant, mais je te l'envoie en MP ce soir, en divx avi (divx6/mp3)

Alors ça ce serait drôlement sympa de ta part.

Parce que j'ai envoyé cette animation à la famille de mon mari aux States et ils ont tous beaucoup rit. Et nous n'avons pas d'ordi à la maison, alors j'aimerais bien qu'il puisse voir cette animation lui-aussi (je fais rire toute sa famille, alors pourquoi pas lui ?).
 

Paski.pne

Membre d’élite
Club MacG
7 Novembre 2005
4 468
769
on the Lost Highway
perso.wanadoo.fr
boddy a dit:
Dans ffmpegX, si je clique sur "joue", il n'y a pas de son. Si je rajoute 1 dans adio = idem.
samalaplaya a dit:
Oui, c'est vrai, j'ai vu que ffmpegX lit à tort dans l'entête "o channels" d'AAC en audio...
Ce qui me surprend, c'est que j'ai une version plus ancienne de ffmpegX, la 0.0.9g, et avec celle-ci, pas de problème. Si je joue le film avec ffmpegX, le son est présent. Serait-ce un bug de la version 0.0.9u ??? :mouais:

En tout cas, ce que te propose samalaplaya est bien mieux et très sympa de sa part :zen:
 

boddy

Membre d’élite
Club MacG
17 Mars 2005
3 727
350
Face à la Méditerranée
Paski.pne a dit:
Ce qui me surprend, c'est que j'ai une version plus ancienne de ffmpegX, la 0.0.9g, et avec celle-ci, pas de problème. Si je joue le film avec ffmpegX, le son est présent. Serait-ce un bug de la version 0.0.9u ??? :mouais:

En tout cas, ce que te propose samalaplaya est bien mieux et très sympa de sa part :zen:

Tout à fait d'accord : samalaplaya est très sympa.
 

samalaplaya

Membre d’élite
Club MacG
16 Mars 2005
3 164
120
Ouais, mais j'braque des banques aussi... et j'pique les cabas des mamies...
Alors, hein, toujours sympa ? ;)
Bon, ton fichier est passé de 7,9 Mo à 6,6 péniblement (j'ai aussi une version de 27 Mo inutile en gain de qualité), et la hauteur du fichier est de 176 et non plus 180 (il faut un multiple de 16).
Mais sur une platine de salon qui va agrandir le 320/176 en largeur d'écran TV, tu vas être hyper déçue... Pas grave, j'te maile le lien en MP.
PS: je te suggère fortement de changer l'extension ".divx" (des divx6) en ".avi" pour ta platine de salon. Le reste est ok...
 

boddy

Membre d’élite
Club MacG
17 Mars 2005
3 727
350
Face à la Méditerranée
samalaplaya a dit:
Ouais, mais j'braque des banques aussi... et j'pique les cabas des mamies...
Alors, hein, toujours sympa ? ;)
Bon, ton fichier est passé de 7,9 Mo à 6,6 péniblement (j'ai aussi une version de 27 Mo inutile en gain de qualité), et la hauteur du fichier est de 176 et non plus 180 (il faut un multiple de 16).
Mais sur une platine de salon qui va agrandir le 320/176 en largeur d'écran TV, tu vas être hyper déçue... Pas grave, j'te maile le lien en MP.
PS: je te suggère fortement de changer l'extension ".divx" (des divx6) en ".avi" pour ta platine de salon. Le reste est ok...

Personne n'a jamais dit que moi je suis sympa. La preuve ? Maintenant que je sais tout de ta vie privée, j'attends ma "com" sur tous les braquages et je te laisse les légumes pour la soupe des mamies (j'ai tout ce qu'il me faut dans l'animation !).

Ceci dit : téléchargement + avi + ouverture + gravure sans aucun problème. Ce soir, visionnage.

Je sais pas comment t'as fait... je suppose que ça n'a pas été facile... si t'as rien de mieux à faire tu pourrais peut-être m'expliquer ?

En tout cas : MERCI