• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

10.13 High Sierra Impossible d'installer High Sierra sur raid 0

SylvainMBP

Membre junior
25 Mars 2011
64
0
Plan d'Orgon
Pourtant avec Sierra il n'y avait pas eu ce soucis, le changement de format de fichiers y est certainement pour quelque chose. Bon ben je vais attendre une solution, en attendant je reste sous sierra. Merci pour ta réponse.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
59 394
19 701
Forêt de Fontainebleau
Salut Sylvain

Va à : Applications > Utilitaires > lance le «Terminal». Saisis les commandes (informatives) :
Bloc de code:
diskutil list
diskutil ar list
et ↩︎ (presse la touche "Entrée" après chaque commande pour l'exécuter)

  • la 1ère commande retourne le tableau des disques attachés au Mac (en interne / externe > physiques / virtuels) > avec leurs paramètres de tables de partitions et de partitions
  • la 2è > le dispositif de ta matrice RAID 0

Tu n'as qu'à les poster ici en copier coller > mais attention ! avant de faire ton coller > presse le bouton (4è avant la fin à droite) dans la barre de menus au-dessus du champ de saisie d'un message > menu : </> Code > par ⌘V colle dans la fenêtre Code > presse le bouton Insérer (ce procédé permet un affichage fenêtré qui économise l'espace de page en respectant la mise en forme des tableaux du «Terminal» --> d'où une plus grande lisibilité).

=> ça me donnera une idée de la configuration de tes disques. J'ai une idée de la réponse > mais je préfère l'étayer en référence aux identifiants de devices de tes disques.
 

mokuchley

Membre d’élite
Club MacG
27 Août 2010
3 435
154
mais c'est peut-être le raid 0 qu'il ne digère pas
 

SylvainMBP

Membre junior
25 Mars 2011
64
0
Plan d'Orgon
Tout d'abord un grand merci de te pencher sur mon soucis, j'ai copié le résultat renvoyé par le terminal, en espérant que tu puisses y trouver une solution.

Merci par avance, Sylvain.





Bloc de code:
Last login: Wed Sep 27 21:19:15 on console
Mac-mini:~ sylvain$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *256.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                 Apple_RAID                         255.7 GB   disk0s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk0s3

/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *256.1 GB   disk1
   1:                        EFI                         209.7 MB   disk1s1
   2:                 Apple_RAID                         255.7 GB   disk1s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk1s3

/dev/disk2 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS SSD RAID 0             +511.4 GB   disk2

Mac-mini:~ sylvain$ diskutil ar list
AppleRAID sets (1 found)
===============================================================================
Name:                 SSD RAID 0
Unique ID:            ED2A7670-6EBB-4FE0-BBBE-F42345C31A0D
Type:                 Stripe
Status:               Online
Size:                 511.4 GB (511417974784 Bytes)
Rebuild:              manual
Device Node:          disk2
-------------------------------------------------------------------------------
#  DevNode   UUID                                  Status     Size
-------------------------------------------------------------------------------
0  disk0s2   A436106A-4B12-4C07-94AF-294DFC26CFDD  Online     255708987392
1  disk1s2   92E073C9-E78C-459F-A9E5-814614C52663  Online     255708987392
===============================================================================
Mac-mini:~ sylvain$
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
59 394
19 701
Forêt de Fontainebleau
:coucou: Sylvain

Je vois que tu as une jolie configuration : 2 SSD internes de 256 Go associés dans un matrice RAID 0 pour exporter un volume SSD RAID 0 de 511 Go. Ça doit bien marcher - le procédé RAID par bandes arrivant quasiment à doubler le débit d'un SDD solitaire.

Alors je me suis livré à plusieurs expérimentations de mon côté, que je te livre. Je dispose d'un MacBook Pro 17" i7 Late_2011 avec 2 SSD internes (non associés en RAID actuellement) > et je dispose d'une station Thunderbolt-1 incluant 4 SSD > avec un chaînage de 2 convertisseurs Thunderbolt avec un SSD attaché à chaque. J'ai donc un foison de SSD sous la main pour me livrer à diverses expériences.


- a) j'ai associé 2 SSD externe Thunderbolt dans une matrice RAID 0 classique (= exportant un volume unique au format de système de fichiers JHFS+). J'ai lancé l'installateur de High Sierra à destination de ce volume JHFS+ (RAID 0) --> il y a rejet radical du volume par l'installateur, le volume étant grisé. Si je le sélectionne en l'état --> le message suivant apparaît : impossible d'installer High Sierra sur un RAID.

----------

- b) me demandant si l'erreur ne provenait pas du placement en externe des SSD (malgré la connexion Thunderbolt) --> j'ai créé sur chacun de mes 2 SSD internes (connexion SATA-3) une partition de 50 Go > et j'ai solidarisé ces 2 partitions dans une matrice RAID 0 exportant un volume JHFS+ classique de 100 Go (je sais que le procédé RAID préfère gérer des disques entiers que des partitions - mais je n'avais pas envie d'initialiser les autres volumes de mes SSD internes). Résultat : même rejet du volume par l'installateur de High Sierra.

----------

- c) j'ai supprimé la matrice RAID 0 associant les 2 SSD externes et j'ai recréé une matrice RAID 0 supportant l'exportation d'un volume APFS. Supposant (comme dans ton cas de figure) que les 2 SSD soient identifiés comme disk0 et disk1 (et que tu sois démarré sur un Système tiers) --> la commande ad hoc serait :
Bloc de code:
diskutil ar create stripe "SSD RAID 0" apfs disk0 disk1
Cette commande est très bien suivie > et crée une configuration que j'appellerais : RAID 0 APFS. J'ai déclenché l'installateur de High Sierra à destination du volume APFS exporté par cette matrice RAID 0 --> le processus d'installation s'engage (j'ai eu un espoir) > puis avorte sur le message d'échec : le programme d'installation n'a pas pu créer un volume de pré-démarrage sur le disque (il s'agit du volume APFS Preboot qui assume la fonction de « booter » ("starter") du volume APFS Macintosh HD - les 2 résidents d'un même Conteneur APFS).

----------

- d) la même mésaventure surgit > si je crée le dispositif : matrice RAID 0 APFS avec les 2 partitions de mes SSD internes.

----------

Voici mes conclusions de ces expériences :

  • un RAID 0 préexistant exportant un volume JHFS+ classique est refusé pour conversion à l'APFS. Je ne sais pas si la conversion volume JHFS+ => volume APFS sera supportée dans un proche avenir.

  • un RAID 0 préexistant exportant un volume APFS est "presque accepté" comme destination d'installation. Mais il y a actuellement un blocage de l'installateur pour créer le volume Preboot de pré-démarrage.

Un dispositif RAID 0 de type APFS étant formellement supporté > je conjecture que High Sierra sera prochainement installable dans son volume exporté. Mais qu'actuellement il y a standby > exactement comme pour les CoreStorage Fusion Drive associant un SDD et un HDD.

Je te conseille de patienter en restant pour l'instant sur «Sierra 10.12». Et d'attendre une MÀJ de «High Sierra» supportant la configuration RAID (0 ou autre).
 

SylvainMBP

Membre junior
25 Mars 2011
64
0
Plan d'Orgon
Tout d'abord, un grand merci pour avoir pris le temps de tester tout ça ;)
Je vais patienter le temps qu'Apple sorte une mise à jour, en meme temps sierra marche bien sur ma config un peu musclée comme tu as pu le voir, j'arrive à un debit supérieur à 1go en Raid 0 avec mes SSD, et avec puis 16Go de Ram, ça me permet d'être à l'aise sous Final Cut Pro/Photoshop et Lightroom.

Encore merci à toi,
Sylvain.
 

Iacos23

Nouveau membre
19 Novembre 2017
1
0
31
Bonjour, j'ai à peut près le même problème. J'ai un imac de fin 2009 j'ai formater le SSD mais une fois à la fin de l'installation de High Sierra il dit "impossible de créer un volume de prédémarrage pour l'installation apfs" or j'ai bien formater le ssd dans le bon format. Je commence à perdre espoirs. Merki :)
 

r e m y

Cas clinique
Club MacG
4 Novembre 2000
41 453
4 222
57
St Germain en Laye - FRANCE
En quel format le SSD a-t-il été formatté ?

Essayer peut-être de formatter en HFS+ et table de partition GUID et laisser l'installeur faire la conversion en APFS (à moins que votre SSD soit l'un de ceux incompatibles avec APFS)
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
59 394
19 701
Forêt de Fontainebleau
Quel rapport avec la comptabilité de High Sierra et d'un RAID 0 (le sujet spécifique de ce fil) > ce qui implique au moins 2 disques de taille égale, par exemple 2 SSD ; s'il n'est ici question que d'un échec à installer High Sierra sur 1 SSD solitaire (= sans RAID) ?