Impression de code à barres sous Acrobat

TYPO 48

Membre junior
11 Juin 2007
97
4
Liège
Bonjour,
Je travaille avec un logiciel en ligne de La Poste (Belgique). Ce service génère des étiquettes d'expédition munies d'un numéro de code à barres. Ces étiquettes me sont envoyées au format Pdf. Elles apparaissent tout à fait normalement à l'écran. Mais, lorsque je les imprime (sur une imprimante laser noir/blanc Hewlett Packard 4M Plus) les numéros (sous les barres) s'impriment normalement alors que les barres sont masquées par un rectangle gris foncés. Toutefois, elles débordent légèrement (env. 0,5 mm) sous ce rectangle. J'ai résolu provisoirement ce problème en faisant une capture d'écran du document Pdf, ce qui me donne un document Jpeg que j'importe dans un document XPress (pour le mettre à dimensions). Mais c'est un chipotage et j'aimerais pouvoir faire une impression directe qui me ferait gagner du temps.
J'ai interrogé le service technique de La Poste le 17 septembre et je n'ai jamais reçu de réponse. Pas même un accusé de réception. :(
NB - Je travaille avec Adobe Reader 7.0.0 Professional sous MAC OS X 10.4.11.
Merci pour vos réponses. :zen:
 

magicPDF

abracadabrantesque
Modérateur
Club MacG
5 Décembre 2007
7 461
669
43.93 N / 4.84 E
abracadabraPDF.net
Je pense qu'il doit y avoir un problème de transparence ou de version du format PDF, pour aller plus loin il faudrait connaitre le numéro de version PDF (dans Acrobat > Fichier > Propriétés... > panneau Général) et la version d'XPress utilisée.

NB - Je travaille avec Adobe Reader 7.0.0 Professional sous MAC OS X 10.4.11.
Ce logiciel n'existe pas : c'est soit Adobe Reader, soit Acrobat Pro. Et dans tous les cas je te conseille fortement d'effectuer les mises à jour, la 7.0 est buggée à mort.

:up:
 

TYPO 48

Membre junior
11 Juin 2007
97
4
Liège
Merci Abracadabra de me répondre.

J'ai ouvert le document PDF et le menu Fichier>Propriétés>Description et j'y ai trouvé :
- Application : JasperReports (eso_label_pro)
- Description avancée : Version PDF : 1.4 (Acrobat 5.x)

J'utilise XPress 6.52 mais je n'ai pas de problèmes avec cette application.

Après vérification, j'utilise Adobe Reader 7.0.0. et Adobe Acrobat 7.0 Professional.
En fait, dans cette dernière application, la fonction A propos de ouvre une fenêtre titrée Adobe Acrobat 7.0 et affichant curieusement Version 7.1.0 :confused:

J'ai fait une recherche de mise à jour pour cette application. On me propose les mises à jour suivantes :
- Adobe Acrobat 7.0.7 Professional Update
- Adobe Acrobat 7.0.8 Professional Update
- Adobe Acrobat 7.0.9 Professional Update
- Adobe Acrobat 7.1.10 Professional Update
- Mise à jour Adobe Acrobat 7.0.5 Professional

Je vais exécuter la mise à jour. On verra bien... :nailbiting:
 

TYPO 48

Membre junior
11 Juin 2007
97
4
Liège
J'ai lancé le téléchargement des mises à jour successives.
Il s'est déroulé sans problèmes mais l'installation a échoué.
Une fenêtre est apparue qui indiquait : La version de l'application sélectionnée se trouve hors de la plage pouvant être mise à jour à l'aide de ce programme d'installation. Il s'agit de AUM (Adobe Update Manager).
Que faire ?
:confused::confused::confused:
 

magicPDF

abracadabrantesque
Modérateur
Club MacG
5 Décembre 2007
7 461
669
43.93 N / 4.84 E
abracadabraPDF.net
Pour ce qui est de la mise à jour tu trouveras tout ici :
http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Macintosh

Tu télécharges et ensuite tu installes, parce que j'imagine que AUM ne prend plus cette version en charge... (Profites en pour installer Reader 9).


Pour ce qui est du PDF il faudrait que tu l'aplatisses, mais je ne me rappelle plus si cette opération est possible dans Acrobat 7...
Si non il suffit de re-Distiller le PDF, ça le passera en version 1.3 : c'est à dire sans transparence, et dans une version reconnue par XPress 6.x.

:)
 

TYPO 48

Membre junior
11 Juin 2007
97
4
Liège
Je suis désolé d'avoir tardé à répondre, mais j'ai été très occupé ces derniers jours.

Voilà, j'ai installé Acrobat Reader 9.0.0 et j'ai ouvert les documents PDF dont question.
À l'impression, il n'y a plus de problème. Les codes à barre s'impriment correctement sur la HP. Ce problème est donc résolu.

Mais l'application s'ouvre maintenant en anglais.
Je suppose qu'elle est multilingue mais je ne trouve pas le moyen de la basculer en français. J'ai fouillé dans les préférences et je ne trouve rien.
J'ai été voir du côté de l'aide qui me fournit une aide en ligne (en anglais, bien sûr). J'ai été étonné de ne plus trouver l'aide complète des versions précédentes avec fonctions de sommaire, d'index et de recherche. Comment procéder pour la faire fonctionner en français ? :nailbiting:
 

magicPDF

abracadabrantesque
Modérateur
Club MacG
5 Décembre 2007
7 461
669
43.93 N / 4.84 E
abracadabraPDF.net
Sur Mac il faut aller dans les Préférences système > International pour paramétrer la langue préférée à l'ouverture des logiciels, mais si tes autres logiciels Apple (Aperçu, Safari...) s'ouvrent en français c'est que le réglage est OK.

Auquel cas c'est probablement parce que tu as installé une version américaine de Adobe Reader : il te faut la désinstaller et réinstaller la version française (multilingue en fait : anglais, français, allemand) :
http://www.adobe.com/fr/products/acrobat/readstep2.html

A propos d'Adobe Reader, il y a un utilitaire aussi gratuit que sympathique par ici :
http://abracadabrapdf.net/articles.php?lng=fr&pg=17

:up:
 

magicPDF

abracadabrantesque
Modérateur
Club MacG
5 Décembre 2007
7 461
669
43.93 N / 4.84 E
abracadabraPDF.net
Voilà, j'ai installé Acrobat Reader 9.0.0 et j'ai ouvert les documents PDF dont question.
À l'impression, il n'y a plus de problème. Les codes à barre s'impriment correctement sur la HP. Ce problème est donc résolu.

Probablement donc une "limitation" d'Acrobat 7.x ...

:confused:
 

TYPO 48

Membre junior
11 Juin 2007
97
4
Liège
Sur Mac il faut aller dans les Préférences système > International pour paramétrer la langue préférée à l'ouverture des logiciels, mais si tes autres logiciels Apple (Aperçu, Safari...) s'ouvrent en français c'est que le réglage est OK.

Auquel cas c'est probablement parce que tu as installé une version américaine de Adobe Reader : il te faut la désinstaller et réinstaller la version française (multilingue en fait : anglais, français, allemand) :
http://www.adobe.com/fr/products/acrobat/readstep2.html

A propos d'Adobe Reader, il y a un utilitaire aussi gratuit que sympathique par ici :
http://abracadabrapdf.net/articles.php?lng=fr&pg=17

:up:

OK ! J'ai installé Adobe Reader 9 en français, mais je ne trouve pas le moyen de désinstaller la version américaine en sécurité. J'ai donc les deux versions en coexistence. Est-ce que je peux simplement glisser le dossier à la corbeille ?
Pour l'utilitaire "aussi gratuit que sympathique", je verrai plus tard. Pour l'heure, je vais me coucher.:sleep:

Encore merci ! :zen:
 

magicPDF

abracadabrantesque
Modérateur
Club MacG
5 Décembre 2007
7 461
669
43.93 N / 4.84 E
abracadabraPDF.net
Est-ce que je peux simplement glisser le dossier à la corbeille ?

Oui, ça devrait le faire.

Sinon dans le menu Aide tu demandes à "Réparer l'installation" et il me semble bien que dans les choix suivant il y a possibilité de désinstaller. Mais si tu fais ça il y a de grandes chances pour que tu sois obligé de réinstaller la version française (il y a des éléments partagés...).

:)
 

TYPO 48

Membre junior
11 Juin 2007
97
4
Liège
J'ai viré le dossier Adobe Reader 9 en anglais et cela semble marcher.
À la première ouverture de la nouvelle version, le système m'a demandé mon mot de passe. Pas de problème.
J'ai configuré globalement tous les documents PDF pour qu'ils s'ouvrent avec cette nouvelle version. Mais, lorsque j'essaye d'ouvrir un document depuis le Finder et si l'application n'est pas ouverte, le message suivant apparaît : L'opération n'a pu être effectuée - Une erreur est survenue (code - 10660).
Par contre, si l'application est déjà ouverte ou si je fais glisser l'icône du document sur celle de l'application (fermée), l'ouverture se fait sans problème. Peut-être qu'après un démarrage, cela rentrera dans l'ordre.
Je n'y comprends rien, mais cela n'est pas grave. Le principal est que cela fonctionne.
Encore merci.
:up: