Latence à l'exécution de ssh

Emerout

Membre junior
14 Janvier 2004
60
0
Bonjour,

J'utilise ssh pour me connecter à mon Mac mini, à partir de mon iBook (ethernet et wifi avec un routeur linksys).
Le pare-feu Mac OS est actif sur les deux machines.

Je lance ssh, et il y a systématiquement une latence de 1 ou 2 secondes (je n'ai pas mesuré mais c'est toujours la même), avant que le prompt du password n'arrive.

Est-ce normal, y-a-t'il un remède ?

Merci.
 

daffyb

-Duck Warrior-
Modérateur
Club MacG
18 Octobre 2001
13 867
1 719
Angoulême
ben, oui, c'est normal... faut le temps de se connecter. Il faut lancer la session ssh, récupérer ton login, vérifier si les clef pour le cryptage sont bonnes, etc. En fait, je ne comprends pas vraimement. Pour moi, il ne s'agit pas d'un problème :confused:
 

Emerout

Membre junior
14 Janvier 2004
60
0
Merci de ta réponse,

Ce n'est pas vraiment un problème, c'est juste que je n'ai pas l'habitude d'attendre pour avoir le prompt à ce moment-là ...

Sur les machines Unix au boulot, c'est immédiat, que ce soit en rlogin ou ssh. Certes, c'est pas des G4 à 1.4ghz, mais je ne comprends pourquoi le mini met autant de temps à me répondre !
 

daffyb

-Duck Warrior-
Modérateur
Club MacG
18 Octobre 2001
13 867
1 719
Angoulême
En effet, c'est bien possible. Il se peut aussi que ca soit du à une latence due à la connexion réseau. Je constate cette même latence entre ma linuxette et mon Mac. (il faudrait que je regarde dans l'autre sens ;))
 

YannisA

Membre junior
9 Mars 2005
79
0
48
Bruxelles
Emerout,

J'ai le meme souci que toi mais en pire....lorsque je lance une connexion ssh vers un systeme dont la connexioin se fait via un VPN, j'ai le prompt apres 1 à 2 min!!!

Alors que je fais la meme chose sur mon portable Windoze (et oui je suis obligé d'avoir un portable du bureau qui est sous Windoze) et la, le prompt se fait en moins de 2 s????

J'ai dejà cherché sur le Net pour voir à quoi cela serait du...mais aucune réponse....
Ce serait probablement un souci dans l'implementation de ssh sur MacOSX????