LES COOKIES !! une bonne fois pour toute

Bambix

Membre junior
25 Janvier 2005
27
1
39
Salut à tous !!

J'ai flâné sur le forum (et d'autres) pour trouver une réponse à ma question : en vain.
Le sujet à en effet été traité, mais n'a de cesse de diverger vers la caisse d'épargne, la déclaration d'impôt ou des adresses internet alternatives pour contourner le probleme.
Alors je me permets d'y revenir :

Quand j'essaie de me connecter à certains sites (et ils sont nombreux), ce classique message d'erreur apparaît : votre navigateur DOIT être réglé pour accepter les 'cookies'
Alors je suis evidemment aller voir dans les préférences de mon Safari 1.3.1 (v312.3.1), pour Toujours accepter les cookies. Rien.
J'ai ensuite fermé Netbarrier : rien.
J'ai désactivé le Firewall de OS : rien.
J'ai essayé avec IE : rien.
J'ai installé Firefox : rien.
J'ai installé Netscape : rien.
Je me suis tappé la tête avec une planche à clous : toujours rien.

Alors, le post que vous lisez messieurs-dames n'est pas qu'une demande de soutient, mais un vrai cri de détresse.

S'il vous plaît, volez à mon secours !
 

Anabys

Membre d’élite
Club MacG
2 Août 2004
1 099
67
Paris
www.valhalla.fr
Si tu règles Safari pour qu'il accepte les cookies, il les acceptera. L'option concernant les cookies dans les préférences de Safari, ce n'est pas que 3 boutons radio sans rien derrière, il y a une vrai fonction qui fait ce pour quoi elle a été conçue. De même pour Firefox et Netscape. Le problème n'est pas là.

Le problème est que ton site qui ne fonctionne pas a été élaboré par un webmaster incompétent au possible et peu scrupuleux qui n'a pris la peine de le faire fonctionner que pour IE Windows. Le message d'erreur renvoyé ne correspond pas à la réalité, il devrait plutot être "Ce site ne fonctionne qu'avec IE Windows". Ils te parlent de cookies, alors que ce n'est pas le problème. Il n'y a rien à faire pour résoudre ce problème, à part utiliser IE PC ou attendre que le webmaster fasse son boulot et rende le site conforme aux standards. Heureusement, ce genre de site est assez rare...
 

Bambix

Membre junior
25 Janvier 2005
27
1
39
Salut !

Merci à toi d'avoir pris le temps de répondre à ma question.
Malheureusement, j'ai peur que ça ne soit pas aussi simple, car mon problème couvre un quantité de sites trops nombreux et trop importants pour qu'il s'agisse d'un manque de sérieux du webmaster qui les a conçu.

Rapidement, voici une liste des sites auxquels je ne peux plus acceder : allocine, macmusic, ugc, ma boite hotmail, ebay...

A mon avis, il s'agit bien d'un problème de configuration, mais j'ai beau retourner tout les paramètres de mon iBook, je n'en trouve pas la source...

:confused: :( :sick:
 

ntx

Vénérable sage
Club MacG
15 Octobre 2004
12 072
376
92
Bonjour,
Bambix a dit:
Rapidement, voici une liste des sites auxquels je ne peux plus acceder : allocine, macmusic, ugc, ma boite hotmail, ebay...
le problème vient de ta configuration car chez moi UGC et Allocine marchent très bien ... heureusement.
Essaies de virer toutes les préférences Safari ou de voir avec un autre utilisateur si le problème existe.
 

Bambix

Membre junior
25 Janvier 2005
27
1
39
Paski.pne, j'ai en effet configuré Safari comme tu le montres sur ton image. J'ai même essayé en acceptant TOUS les cookies. Rien n'y fait.

ntx, j'ai déjà remis à zéro mes preférences Safari, vidé les cookies, essayé sous un autre utilisateur : RIEN !

J'ai les boules, je me sens trop impuissant, je ne sais vraiment pas quoi faire.
Je vais quand même pas réinstaller panther ?!?!?!?!?!?!?!?!?!?!+$*¤#!
 

bobbynountchak

Vétéran
Club MacG
19 Novembre 2004
7 803
2 289
16
tiontiondubois
pourquoi pas reinstaller safari?

edit : ah nan, j'ai rien dit... firefox et IE sont concernes donc ça servirait a rien...
desole
 

Bambix

Membre junior
25 Janvier 2005
27
1
39
En effet bobbynountchak, IE, netscape et firefox souffrent du meme probleme.

Je suis administrateur, aucune restriction possible Anabys...
 

Anabys

Membre d’élite
Club MacG
2 Août 2004
1 099
67
Paris
www.valhalla.fr
C'est délirant ton problème là... les sites que tu indiques passent parfaitement sous Safari et Firefox chez moi. A vrai dire, le seul site qui m'affiche une erreur de cookies (et j'en visite des tonnes de sites) c'est le webmail de wanadoo (il affiche un message avec Safari disant que le navigateur doit autoriser les cookies, et une fois le message viré, le webmail fonctionne tout à fait normalement, donc c'est un message fausse alerte).

Est ce que tu n'aurais pas un utilitaire ou un plugin qui serait la cause du problème ? Du genre Intego, Norton, ou des plugin Safari genre Saft, PitHelmet, etc.
 

Bambix

Membre junior
25 Janvier 2005
27
1
39
A vrai dire, et comme indiqué dans mon premier post, je fonctionne avec le firewall de panther plus netbarrier.
J'ai donc essayé en désactivant d'abord netbarrier, puis le firewall de mon systeme, mais rien n'y fait.
Decidemment rien ...............:sick:

Et je suis bien sûr qu'aucun autre utilitaire n'est là pour m'embêter...
 

Anabys

Membre d’élite
Club MacG
2 Août 2004
1 099
67
Paris
www.valhalla.fr
Je ne connais pas Netbarrier, mais s'il a une fonction de gestion des cookies, cherche pas plus loi, c'est lui. Essaye de le désinstaller complètement, et de redémarrer l'ordi, pour voir si ça fonctionne. Si non, il sera toujours temps de le réinstaller.
 

Bambix

Membre junior
25 Janvier 2005
27
1
39
Ok, ça avance.

Mon netbarrier était bien éteind, donc je pensais qu'il n'y aurait pas de problème.
Je l'ai remis en fonction, puis j'ai désactivé la fonction de filtrage des cookies, et là, miracle : ça marche.

Alors maintenant, j'aimerais bien comprendre comment netbarrier peut filtrer les cookies s'il est éteind..........

Bon, maintenant, mon soucis, c'est que sur les sites sur lesquels j'avais ces problèmes, certaines pages ne s'affichent pas. Il faut que je stop le chargement de la page pour que son contenu s'affiche.

Un problème qui me semble être lié à celui que je rencontre sur amule (pour partager mes fichiers favoris avec mes amis) : j'ai toujours une low ID, même apres avoir autorisé les ports adéquats dans netbarrier et dans le firewall de panther.
A voir , rien a voir ?

En tout cas, merci de ton soutient Anabys.
 

Bambix

Membre junior
25 Janvier 2005
27
1
39
En effet, les services blocage des cookies doivent rester actif quand même (logique n'est-ce pas ?)

Assez d'accord avec toi bobbynountchak. Tu utilises quoi toi ?
 

bobbynountchak

Vétéran
Club MacG
19 Novembre 2004
7 803
2 289
16
tiontiondubois
ben rien du tout...
je me branche, je navigue avec safari, firefox pour les quelques sites ou ça ne passe pas, point...
et ya pas de souci.

:)
 

Anabys

Membre d’élite
Club MacG
2 Août 2004
1 099
67
Paris
www.valhalla.fr
Je ne connais pas du tout netbarrier, mais s'il utilise un daemon c'est normal qu'il continue à foutre le dawa, même si l'interface graphique est fermée. Ou encore, s'il modifie les réglages des navigateurs une bonne fois pour toutes au lieu de filter en "live".

Pour emule, ça peut venir de netbarrier, mais si tu as un routeur c'est plutot un problème de mappage de ports.
 

Bambix

Membre junior
25 Janvier 2005
27
1
39
Bon, alors comme ça, c'est dit. Netbarrier : à la poubelle.

En tout cas, merci à tous pour votre patience, votre aide et votre gentillesse.

Un good feeling disco pour tous.

Macamicalement votre