Mac Pro (ancien) partager la connexion

powernoob

Membre junior
3 Septembre 2012
27
0
Bonjour à tous,

J'ai un MacPro de 2009 qui marche très bien (je touche du bois).
Je viens d'avoir un mac mini, mais je n'ai pas de câble réseau sur mon bureau, et je veux éviter d'utiliser le wifi.

Comme il y a 2 ports réseaux sur mon MacPro, j'ai essayé de branché un RJ45 depuis le MacPro jusqu'au mac mini et de partager la connexion internet.
Et bien, cela ne fonctionne pas...

Est-il possible de récupérer la connexion sur le 1er port du macpro et de la renvoyer dans le 2nd port vers une autre machine ?

Merci :zen:
 

Polo35230

Membre d’élite
Club MacG
4 Janvier 2011
1 555
82
Bonsoir,

Ça devrait marcher...
Dans le Mac Pro, le partage est bien configuré comme ceci:
Partager Port EthernetCôtéBox aux ordinateurs via PortEthernetCôtéMacMini

Le Mac Mini est bien en DHCP auto?
Qu'y-a--il dans la conf réseau du Mac Mini?
Adresse IP:
masque:
routeur:
DNS:
 

powernoob

Membre junior
3 Septembre 2012
27
0
Alors j'ai fais une config : Ethernet 1 vers Box, Ethernet 2 vers Mac Mini.

Du coup sur le Mac Mini, j'ai en DHCP, une config IP qui n'a rien avoir avec le reste du réseau.
Mon Mac Pro est en 192.168.1.X et le Mac Mini en 192.168.2.X, mais il ne sort pas sur internet.

J'ai essayé de mettre l'IP du MacPro comme passerelle/Router, mais rien à faire.

Par contre de l'autre côté sur le MacPro, dans réseau, Ethernet 2 me met une config DHCP qui n'a rien avoir non plus...

Dois-je mettre la config d'ethernet 2, à l'identique d'ethernet 1 ?
Dois-je ensuite mettre sur le Mac Mini une config identique ?
Bref, j'ai essayé des trucs, mais rien de vraiment efficace...

Merci de votre aide :)
 

Polo35230

Membre d’élite
Club MacG
4 Janvier 2011
1 555
82
Du coup sur le Mac Mini, j'ai en DHCP, une config IP qui n'a rien avoir avec le reste du réseau.
Mon Mac Pro est en 192.168.1.X et le Mac Mini en 192.168.2.X, mais il ne sort pas sur internet.
C'est normal, c'est le principe du partage. Il y a un réseau 192.168.1.0/24 (entre la box et eth1) et un autre 192.168.2.0/24 (entre eth2 et le Mac mini)

Essaye de configurer le réseau côté Mac mini:
Adresse IP 192.168.2.xxx (tu n'as pas indiqué le xxx. je suppose que c'est 2 ?)
Le masque doit-être à 255.255.255.0
Essaye de mettre le routeur à 192.168.2.1 et 8.8.8.8 comme DNS.

Si ça ne marche pas, dans une fenêtre Terminal, tape la commande ifconfig dans le Mac Pro et le Mac Mini. On y verra plus clair.
 

powernoob

Membre junior
3 Septembre 2012
27
0
Alors moi et le terminal, c'est pas une grande histoire...
Donc je veux bien te laisser interpréter ;)

Sur le MacMini :

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
ether 00:17:f2:d3:49:22
inet6 fe80::217:f2ff:fed3:4922%en0 prefixlen 64 scopeid 0x4
inet 192.168.2.2 netmask 0xffffff00 broadcast 192.168.2.255
media: autoselect (100baseTX <full-duplex,flow-control>)
status: active
en1: flags=8823<UP,BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500
ether 00:19:e3:db:55:c8
media: autoselect (<unknown type>)
status: inactive
fw0: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 2030
lladdr 00:19:e3:ff:fe:74:a0:c4
media: autoselect <full-duplex>
status: inactive


Et sur le MacPro :

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
options=3<RXCSUM,TXCSUM>
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
inet6 ::1 prefixlen 128
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4>
ether 00:1f:5b:3c:b7:a0
inet6 fe80::21f:5bff:fe3c:b7a0%en0 prefixlen 64 scopeid 0x4
inet 192.168.0.12 netmask 0xffffff00 broadcast 192.168.0.255
media: autoselect (100baseTX <full-duplex>)
status: active
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4>
ether 00:1f:5b:3c:b7:a1
media: autoselect
status: inactive
fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078
lladdr 00:21:e9:ff:fe:cb:c7:52
media: autoselect <full-duplex>
status: inactive

Si ca peut t'aider, j'ai fais un traceroute vers 8.8.8.8 depuis le MacMini et j'ai eu 2 lignes
1 192.168.2.1 (192.168.2.1) 0.596 ms 8.461 ms 0.170 ms
2 192.168.2.1 (192.168.2.1) 0.238 ms !H 0.457 ms !H 0.375 ms !H

Merci encore de ton aide.
 

Polo35230

Membre d’élite
Club MacG
4 Janvier 2011
1 555
82
Alors, la chaîne de liaison:
Box---enoMP(MP)en1MP-----en0MM(MM)
en0MM OK
en0MP OK
en1MP Là, je ne sais pas trop quoi dire, parce que l'interface est inactive, et on ne voit pas l'adresse IP (qui devrait être 192.168.2.1). Mais le traceroute ci-dessous montre bien qu'elle est bonne...

Si ca peut t'aider, j'ai fais un traceroute vers 8.8.8.8 depuis le MacMini et j'ai eu 2 lignes
1 192.168.2.1 (192.168.2.1) 0.596 ms 8.461 ms 0.170 ms
2 192.168.2.1 (192.168.2.1) 0.238 ms !H 0.457 ms !H 0.375 ms !H
Le test est bien.
Il montre que tu arrives bien dans le MP (via en1MP), que la liaison est bonne et que le routeur est bien 192.168.2.1
Le pb, c'est que tu ne traverses pas le MP.
Si tu traversais le MP, en 3ème ligne, tu aurais 192.168.0.1
Fait un test en désactivant le firewall du MP.
Tu n'as pas littleSnitch (ou un autre firewall du marché) par hasard?

Pourvoir si c'est nickel entre le Mp et le MM, peux-tu:
Dans le MP faire un ping 192.168.2.2 (devrait marcher)
et dans le MM faire un ping 192.168.2.1 (devrait marcher) , un ping 192.168.0.1 (ne devrait pas marcher)
Et aussi, dans le MP, un netstat -r pour voir les tables de routage.
 
Dernière édition:

powernoob

Membre junior
3 Septembre 2012
27
0
Désolé pour la réponse tardive.

Et merci pour les conseils.
J'ai un little snitch, je vais le désactiver pour vérifier cette histoire.

---------- Nouveau message ajouté à 20h17 ---------- Le message précédent a été envoyé à 18h39 ----------

Bon, même avec little snitch off, ça ne fonctionne pas...
Mais pas grave, j'ai retrouver un petit switch 4 ports et j'ai partagé le câble qui arrivait jusqu'au MP avec le MM.

J'aurais bien aimé résoudre ce problème quand même, mais je chercherais sans stress, il me fallait vraiment une connexion sur le MM. :)

Merci beaucoup de ton aide. Polo35230