Mail ne saurait pas envoyer de mails mis en forme?

Steve J.

Membre junior
16 Juin 2007
47
2
j'ai tenté de poser mon problème en déterrant un vieux topic qui était dans une mauvaise catégorie, sans succès, j'ai donc créé mon topic dans la bonne rubrique:

Bonjour,

J'ai recherché sur le forum et pas de réponse à mon problème et c'est ce qui m'inquiète : c'est pas normal car quasiment tout le monde devrait avoir le même problème que moi:

J'utilise Mail pour écrire et recevoir mes...mails, et je constate qu'en fait, le corps des messages est en fait du texte "brut", sans aucune mise en forme, puisque mes destinataires sur PC (où également sur mon serveur exchange, dans éléments envoyés), je vois que la police utilisée pour la rédaction de mes mails n'est pas reprise.
Que j'utilise celle par défaut (Helvetica), ou une autre dans la catégorie "compatible windows", c'est toujours une police standard moche qui est utilisée.

Donc ce n'est pas un problème d'encodage (je n'ai pas le problèmes de caractères spéciaux), mais simplement un problème de mise en forme.

Mail est bien configuré en RTF...

LE pire c'est qu'on ne s'en rend pas compte puisque sur le Mac, tous mes messages sont bien avec la bonne police, mais j'ai l'impression que le paramètre de choix de police n'intervient que pour transformer simplement l'affichage des mails avec cette police, mais le texte en lui même reste en "brut".

Suis-je vraiment le seul? :confused:

Merci d'avance pour votre aide
 

pascalformac

Légende
Club MacG
23 Novembre 2003
58 699
1 814
bonjour
j'ai tenté de poser mon problème en déterrant un vieux topic qui était dans une mauvaise catégorie, sans succès, j'ai donc créé mon topic dans la bonne rubrique:
ben non
raté
:D
-
Mail c'est internet


table d'orientation des forums macg

ce fil sera déplacé ou fermé par un modo

ensuite voir les sujets là dessus
ca peut etre une affaire de preference Mail comme gestion foutraque des polices sur le mac
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 098
1 000
Toulouse.cong
faq.office.macintosh.free.fr
Que j'utilise celle par défaut (Helvetica), ou une autre dans la catégorie "compatible windows", c'est toujours une police standard moche qui est utilisée.
Que vois-tu dans le fichier source comme paramètre pour la balise FONT ? Est-ce que tu utilises une police suffisamment courante pour être sûr que tes correspondants sous Windows en disposent sur leur machine ?

Donc ce n'est pas un problème d'encodage (je n'ai pas le problèmes de caractères spéciaux), mais simplement un problème de mise en forme.
Ben, si, c'est un problème d'encodage HTML. Pas le même que celui qui concerne l'encodage du message lui-même, auquel tu fais allusion. Mais les balises HTML, c'est tout de même du code... ;)
 

Steve J.

Membre junior
16 Juin 2007
47
2
Merci pour ta réponse.

Que vois-tu dans le fichier source comme paramètre pour la balise FONT ?
Je ne vois pas ce que tu veux dire par fichier source?

Est-ce que tu utilises une police suffisamment courante pour être sûr que tes correspondants sous Windows en disposent sur leur machine ?
Oui j'ai même testé 4 ou 5 polices différentes, dont plusieurs dans la catégories "compatibles windows", mais rien y fait...

Ben, si, c'est un problème d'encodage HTML. Pas le même que celui qui concerne l'encodage du message lui-même, auquel tu fais allusion. Mais les balises HTML, c'est tout de même du code... ;)
Ah ok! désolé
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 098
1 000
Toulouse.cong
faq.office.macintosh.free.fr
Je ne vois pas ce que tu veux dire par fichier source ?
C'est le contenu réellement transmis du message, qu'on peut voir dans "Présentation" > "Message" > "Contenu brut" lorsqu'il s'agit de Mail. Et c'est là que tu peux voir ce qui est envoyé comme code concernant la police (balise <FONT xxxxx>)...
 

Steve J.

Membre junior
16 Juin 2007
47
2
Je ne vois pas ce que tu veux dire par fichier source?

j'ai recherché dans le détail du message (contenu brut), j'ai ceci:

Accept-Language: fr-FR
Content-Language: fr-FR
X-MS-Has-Attach:
X-MS-Exchange-Organization-SCL: -1
X-MS-TNEF-Correlator:
Content-Type: text/plain; charset="Windows-1252"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0

ça peut t'aider?

---------- Nouveau message ajouté à 21h01 ---------- Le message précédent a été envoyé à 20h58 ----------

je n'ai donc pas de balise HTML du type <FONT...>

ça veut donc dire que Mail n'encode pas mes mails en HTML.

je rappelle que Mail est configuré en RTF.

---------- Nouveau message ajouté à 21h09 ---------- Le message précédent a été envoyé à 21h01 ----------

je continue mes tests:

-quand j'envoie un mail avec une police par défaut (Helvetica, ou Arial), le message n'est pas encodé en HTML.
-quand j'envoie un mail en changeant manuellement la police (par défaut Helvetica, mais changé en Arial manuellement), le message est correctement encodé en HTML.

Ca serait donc la police par défaut qui ne serait pas appliquée par Mail?
Je précise que j'ai le souci sur mes 2 macs différents...

Avez vous le même cas que moi?
 

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 098
1 000
Toulouse.cong
faq.office.macintosh.free.fr
j'ai recherché dans le détail du message (contenu brut), j'ai ceci:
.../...
ça peut t'aider?
;) moi personnellement non. D'autant qu'il s'agit là des en-têtes, pas des balises dans la partie HTML du message. Ce ne sont donc pas là que se cachent les balises.

La partie concernant les polices, la couleur, etc. commence par la balise <html> et ensuite, tu trouves (ou pas) la balise <font>

- quand j'envoie un mail avec une police par défaut (Helvetica, ou Arial), le message n'est pas encodé en HTML.
Tout dépend de ce que tu as choisi dans le menu "Format" mais, si tu as choisi "RTF", tu es forcément en HTML. Mais la police étant celle par défaut, rien n'est mentionné dans le fichier source, c'est normal, il applique chez toi et chez le destinataire, la police qui est sélectionnée "par défaut" dans le logiciel utilisé. Chacun le sien. C'est seulement lorsque tu forces la police que ce sera mentionné.

Ceci dit, ne te casses pas trop le bonnet avec ça. Tout le monde n'apprécie pas forcément de recevoir des messages avec des polices plus ou moins lisibles (surtout que, s'ils n'ont pas justement cette police chez eux, ce sera une police "de remplacement"). Et je ne te dis pas pour ceux qui lisent via Webmail... Fais simple. Et si tu veux vraiment que ton oeuvre passe à la postérité, envoie des documents en PDF, au moins tu seras sûr que le document sera vu exactement comme tu le souhaites.
 

Steve J.

Membre junior
16 Juin 2007
47
2
Merci Aliboron,

Tu me confirmes donc que toi aussi, en laissant la police par défaut, Mail n'ajoute pas les balises HTML <FONT...> correspondantes à cete police. Je suis donc rassuré, mais je trouve ce fonctionnement pas très logique...

Comme tu dis ce n'est pas grave, mais je voulais comprendre pourquoi en tant qu'utilisateur Mac (Mail), mes mails n'étaient pas mis en forme quand je les vois sur le PC de mes destinataires (j'ai déjà eu la remarque, c'est pour ça que ça m'a interpelé...).

Dommage qu'on ne puisse pas forcer le formatage HTML avec la police choisie par défaut.

Je classe en RESOLU, mais je reste sur ma faim :p

Merci encore Aliboron

Et moi, je confirme que Mail, c'est dans "Internet et réseau qu'on en parle !