Mandrake 7 vieux PC et mémoire vive

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 298
3 483
67
Sous la limite KT
Hello folks,

Alors voilà, d'un côté, j'ai un vieux PC de 1998 ou 1999 (portable 12 pouces Medion, Pentium MMX 300 Mhz) doté de 96 Mo de Ram et d'un disque dur de 4 Go, mais dépourvu de toute interface réseau. D'un autre côté, j'ai une distrib sur CD de Mandrake 7 en français qui date de 2000, donc, je me dis "ces deux là sont fait pour s'entendre, et moi, je vais pouvoir explorer un peu Linux que je ne connais pas !".

L'installation se fait sans problème (le CD est fourni avec un pavé de 700 pages dont les 20 ou 30 premières donnent toutes les instructions nécessaires). Je démarre l'ordi, tout fonctionne … Sauf que Linux ne reconnait que 64 de mes 96 Mo.

Une recherche plus avancée dans les 700 pages du pavé m'apprend que :

Parfois, pour des raisons mal définies, Linux ne reconnait que 64 Mo de Ram.

Explorant par ailleurs un autre ouvrage, téléchargeable sur internet, "le guide du rootard", j'ai confirmation du fait que :

en théorie, jusqu'à un 1 Go; plus sur les plateformes 64 bits, mais cette quantité de mémoire n'a jamais été testée. Attention : certaines personnes (dont Linus Torvalds) ont remarqué qu'ajouter de la mémoire sans dans le même temps augmenter la quantité de cache peut ralentir la machine dans des proportions considérables. Au-delà de 64 Mo, il faut spécifier la quantité de mémoire en paramètre lors de l'amorçage car le BIOS des PC est limité et ne sait pas indiquer plus de 64 Mo.

Enfin, de retour sur mon pavé, au chapitre "Lilo", je suis informé que :

Si, lors de l'initialisation, Linux ne reconnait pas la totalité de la mémoire que vous avez installé dans votre ordinateur …l'option "append" vous permet de corriger cet état de fait. Ainsi, si vous avez installé 256 Mo de mémoire et que Linux n'en reconnaît qu'une partie, vous pouvez ajouter la ligne append = "mem =256M" dans le fichier "lilo.conf" ou sur la ligne de démarrage.

La bascule entre la ligne de démarrage "console" et la fenêtre de login de KDE étant trop rapide pour me permettre d'y saisir quoi que ce soit, j'inclue donc la dite ligne dans le fichier "lilo.conf" (etc/lilo.conf) avec 96M au lieu de 256M, of course.

Seulement, quelque soi l'endroit du fichier où je l'insère, et quel que soit les diverses combinaisons d'inclusions ou non d'espaces dans la dite ligne, rien à faire, Linux n'utilise toujours que 64 des 96 Mo de Ram, ce qui n'est pas rédhibitoire, mais doit, je pense, pénaliser un peu la performance.

Donc voilà, si tout ceci disait quelque chose à l'un d'entre vous, et qu'il avait une solution à me proposer, ça me ferait bien plaisir.
 
Dernière édition:

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 928
3 161
Ouh la la... Je ne me souvenais plus de tout ça...

Je suppose que tu l'as fait mais (au cas où) après avoir modifié /etc/lilo.conf je pense qu'il faut relancer la commande lilo pour qu'elle prenne en compte les paramètres.
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 298
3 483
67
Sous la limite KT
Ouh la la... Je ne me souvenais plus de tout ça...

Je suppose que tu l'as fait mais (au cas où) après avoir modifié /etc/lilo.conf je pense qu'il faut relancer la commande lilo pour qu'elle prenne en compte les paramètres.

Ben nan, je ne l'ai pas fait, je pensais que redémarrer le système était suffisant pour qu'il relise le contenu du fichier.

Il y a une syntaxe à respecter ? (bon, de toute manière, je vais tester).

EDIT : Bon, j'ai essayé "sbin/lilo -R", ça ne m'a pas renvoyé de message d'erreur, mais (après redémarrage) Linux ne voit toujours que 64 Mo sur les 96 installés. :confused:
 
Dernière édition:

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 928
3 161
Si j'en crois la page de manuel de lilo (mais je ne suis pas sûr que cela corresponde à ta version) pas besoin de l'option -R. L'option -v permet d'avoir un petit retour sur ce que fait la commande.

Peux-tu nous afficher le contenu de ton fichier /etc/lilo.conf ?
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 298
3 483
67
Sous la limite KT
Pas la peine, j'ai trouvé : j'avais ajouté une ligne "append" alors qu'il y en avait déjà une, plus loin, qui disait append="", donc qui annulait la mienne.

Ça y est, Linux utilise les 96 Mo de Ram.

Cela dit, si tu ne m'avais pas demandé de retranscrire ici le lilo.conf, je chercherais encore, donc merci à toi pour ton aide efficace :zen:

Bon, ménant, plus qu'à trouver une carte PCMCIA ethernet, parce que ma carte WiFi, rien à faire sous Linux.