Numbers : formules pour doublons

Rollmops

Membre émérite
17 Juillet 2006
961
27
Bonsoir à tous ;)

Quelqu'un pourrait-il m'indiquer quelle est la formule pour faire ressortir les doublons dans un tableau Numbers ?

Merci

J'ai essayé

SI (A3) = (A2), "Dupliquer", ""

J'ai une erreur de syntaxe…
6E84FFD8-1309-4A66-B913-D24BA32D692C.png
J'ai essayé aussi :

=COUNTIF (A, A2)

Mais idem > erreur de syntaxe
 
Dernière édition par un modérateur:

zeltron54

Membre d’élite
29 Mars 2008
2 148
335
Lorraine
Bonsoir,
La syntaxe de SI est:

=SI( "le test";si vrai;si faux)
Le séparateur d'éléments est le ";" pas la ","
Donc pour tester si A3 = A2 on à
=SI(A2=A3;"Oui";"Non")

Dans numbers tu as une aide avec des exemples pour chaque fonction...:siffle:
 

Rollmops

Membre émérite
17 Juillet 2006
961
27
Merci ;)

Je suppose que dans la fonction : "le test" est la valeur est cherchée pour "oui" ou "non" ?

Il y a un truc que je ne comprends pas :
Il y a 2 formules ?

1 =SI( "le test";si vrai;si faux)
2 =SI(A2=A3;"Oui";"Non")

J'ai essayé :
=SI(A2=A3;"▪︎"-si; si-vrai; si-faux)
"▪︎" est un caractère spécial de mon clavier qui se trouve dans certaines rangées du tableau.
erreur de syntaxe !

J'ai aussi essayé :

=SI( "▪︎";si vrai;si faux)(A2=A3;"Oui";"Non")

=SI( "▪︎";si vrai;si faux;A2=A3;"Oui";"Non")

Ne fonctionnent pas non plus !
 
Dernière édition par un modérateur:

Rollmops

Membre émérite
17 Juillet 2006
961
27
Bon je me suis un peux mélangé les pinceaux avec ce caractère que j'ai inclus dans les formules…:shy:

J'ai donc essayé cette formule :

=SI( "A3=A2";si vrai;si faux)

-Elle fonctionne mais elle a un inconvénient : elle affiche un panneau rouge "Attention !" dans les cellules où se trouve un doublon et si je veux trier ma colonne, ils disparaissent !

Comment peut-on remédier à cela ?


-Autre question : cette formule affiche les doublons certes mais n'affiche pas l'original.

Par exemple si j'ai le mot "orange" doublonné j'aurai par ex trois fois "orange" comme doublons mais je n'aurais pas un "orange" original ce qui fait que si je supprime les doublons "orange" je n'aurais plus d'"orange" du tout dans mon tableau…

Comment faire pour afficher les doublons sauf 1 ?

D52A3E1F-8649-40E3-8660-B438869A8F2D.png
 
Dernière édition par un modérateur:

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 048
981
Toulouse.cong
faq.office.macintosh.free.fr
Une possibilité, en reprenant plus ou moins ton exemple, serait d'utiliser la formule suivante en C2 (puis de la recopier vers le bas) :

=SI(NB.SI(B2:B$14;"="&B2)>1;"x";"")

Capture d’écran.png
Ensuite, pour finir ton tri tu copies toute la colonne C, tu fais un collage des "résultats de la formule" (menu "Fichier") pour figer le tout et tu peux alors trier pour ne conserver que les lignes où la colonne C est vide.

NB : si tu préfères tu peux saisir la formule comme ceci : =SI(NB.SI(B2:B$14;"="&B2)>1;"";"x") pour n'afficher le x que dans la ligne à conserver (comme dans ta capture d'écran).
 
Dernière édition:

Rollmops

Membre émérite
17 Juillet 2006
961
27
Une possibilité, en reprenant plus ou moins ton exemple, serait d'utiliser la formule suivante en C2 (puis de la recopier vers le bas) :

=SI(NB.SI(B2:B$14;"="&B2)>1;"x";"")

Génial ! Merci ;)

J'ai aussi essayé ça :

=SI(B2=B3;"Oui";"Non")

Ça marche aussi. Tu connaissais ? 6C261F2F-D531-45A9-82A7-3B13A55A7484.png
 
Dernière édition par un modérateur:

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 048
981
Toulouse.cong
faq.office.macintosh.free.fr
J'ai aussi essayé ça : =SI(B2=B3;"Oui";"Non") Ça marche aussi.
Oui, mais ça présente l'inconvénient de ne marcher que si tes doublons sont bien rangés à la suite les uns des autres. Si c'est en désordre, par contre, ça va t'en sortir beaucoup trop puisqu'à chaque changement de valeur tu auras ton alerte et donc des tas de doublons ne seront pas isolés (j'ai mis en jaune les cas où ta formule trouve des doublons, soit quatre alors qu'il y en a neuf en réalité) :
Capture d’écran.png

Tu connaissais ?
Un peu, oui... :)
 

Rollmops

Membre émérite
17 Juillet 2006
961
27
Je reviens vers toi Aliboron ;) car j'ai un problème avec le tri et le filtrage quand j'utilise tes formules.

Et j'ai des panneaux danger triangulaires rouges dans certaines cellules !

2EAA86CB-AB98-45D5-A1B0-F2FCA6FA9824.png
 
Dernière édition par un modérateur:

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 048
981
Toulouse.cong
faq.office.macintosh.free.fr
Ben, il faut regarder dans ces cellules quel est le problème avec les formules. D'ici, je ne vois pas bien... ;)

Précise aussi ce que tu as fait (en pas à pas), etc. Si tu fais un tri, je t'avais recommandé de commencer par coller les résultats à la place des formules. Est-ce que tu l'as fait (manifestement pas) ? Pourquoi ?
 

Rollmops

Membre émérite
17 Juillet 2006
961
27
Ben, il faut regarder dans ces cellules quel est le problème avec les formules. D'ici, je ne vois pas bien... ;)
Voici qui est plus clair :

0381329D-605C-42CB-99F7-933A977D0B7E.png 099609A0-109D-4F38-BE80-D398A08D1010.png

Si tu fais un tri, je t'avais recommandé de commencer par coller les résultats à la place des formules. Est-ce que tu l'as fait (manifestement pas) ? Pourquoi ?
Non je ne l'ai pas fait car je suis sur un iPad et je n'ai pas le menu Fichier dont tu parles.

Sis-tu comment faire dans fe cas là ?
 
Dernière édition par un modérateur:

zeltron54

Membre d’élite
29 Mars 2008
2 148
335
Lorraine
@Rollmops
Tu dois avoir une erreur dans la recopie de formules car tu dois avoir en :

D13: SI(NB.SI(B13:B24;"="&B13)>1;"x")
D14 : SI(NB.SI(B14:B24;"="&B14)>1;"x")
E13 : SI(NB.SI(B13:B$14;"="&B13)>1;"";"x")
E14 : SI(NB.SI(B14:B$14;"="&B14)>1;"";"x")

Vérifie ces 4 formules . ;)

Si le but final est de ne voir que les valeurs en 1 seul exemplaire, utilises les filtres, sur la colonne E texte est égal à x.
 
Dernière édition:

Rollmops

Membre émérite
17 Juillet 2006
961
27
Merci ;)


Ci-joint 3 exemples. Il semble que c'est correct.

Par contre la "solu 2" (E) filtre "contient X" fonctionne

Mais "Solu 1" (D) filtre "contient X" ne fonctionne pas mais "contient FAUX" fonctionne

144D3E59-A4C0-44D9-991B-8D4799E321F0.png 27790DBF-B10A-430C-B9CD-D83BD9BB163E.png 16883DC4-DE36-4DE7-A486-CF73A74B22C4.png
 
Dernière édition par un modérateur:

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 048
981
Toulouse.cong
faq.office.macintosh.free.fr
Voici qui est plus clair :
Pas tellement, parce que tu n'indiques pas la formule telle qu'elle est dans les cellules "à problème". Je note toutefois que tu as recopié de façon incomplète la première formule. Ce devrait être =SI(NB.SI(B2:B$14;"="&B2)>1;"x";"") et pas =SI(NB.SI(B2:B$14;"="&B2)>1;"x") (mais ça peut être dû à ton navigateur, il semble que certains n'affichent pas les derniers caractères). Ce n'est pas bien grave, mais c'est ce qui provoque l'affichage "FAUX" dans les cellules qui devraient être vides.

Je vois dans la suite de l'échange que tu as apparemment modifié la formule dans les dernières cellules, en élargissant la plage jusqu'à la ligne 18 au lieu de 14. Du coup, ça ne peut pas fonctionner correctement, puisque ça fait une recherche sur des cellules vides et Numbers a l'air de ne pas aimer ça...

Non je ne l'ai pas fait car je suis sur un iPad et je n'ai pas le menu Fichier dont tu parles. Sais-tu comment faire dans fe cas là ?
Non : je n'ai pas d'iPad.
 
Dernière édition:

Rollmops

Membre émérite
17 Juillet 2006
961
27
Merci ;)

Curieux , je n'ai pas les mêmes phrases sur mon navigateur et sur mon appli Mail :

Navigateur (forum) :

Je note toutefois que tu as recopié de façon incomplète la première formule. Ce devrait être =SI(NB.SI(B2:B$14;"="&B2)>1;"xNB.SNB.SI(B2:B$14;"="&B2)>1;"x

Mail :

Je note toutefois que tu as recopié de façon incomplète la première formule. Ce devrait être =SI(NB.SI(B2:B$14;"="&B2)>1;"x") et pas =SI(NB.SI(B2:B$14;"="&B2)>1;"x";"")

On voit qu'il manque une bonne partie dans le texte du forum…

Ceci dit (et ça n'a rien à voir) n'as-tu pas inversé les deux formules ?
En effet, ma formule se termine par "x" Et non par ""
87FC77EA-DF62-4037-90F2-CD0897223134.png
 
Dernière édition par un modérateur:

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
14 048
981
Toulouse.cong
faq.office.macintosh.free.fr
Curieux , je n'ai pas les mêmes phrases sur mon navigateur et sur mon appli Mail :
.../...
On voit qu'il manque une bonne partie dans le texte du forum…
C'est précisément le sens de mon message ci-dessus : tu utilises un navigateur (Chrome ?) qui interprète abusivement le texte du forum. Avec Safari ou Firefox tu aurais le texte correct, je pense. En tout cas, chez moi, pas de souci avec ces deux applications :

Capture d’écran.png


Par contre avec les "Chrome-like" (j'ai essayé Microsoft Edge, Opera et Vivaldi, pour ma part) c'est tronçonné.

Reprends cet échange avec un lecteur qui ne tronque pas le texte ou réfère-toi aux courriels que tu as reçu pour voir les formules dans les messages précédents (mais pas le dernier, donc).

Ceci dit (et ça n'a rien à voir) n'as-tu pas inversé les deux formules ?
En effet, ma formule se termine par "x" Et non par ""
Eh oui, je pense que je devais déjà être bien endormi, parce que j'ai interverti les deux formules alors que je voulais justement t'indiquer une erreur ! ;) J'aurais dû écrire (je le mets en code, en espérant que ça soit lu proprement) :

Bloc de code:
Ce devrait être =SI(NB.SI(B2:B$14;"="&B2)>1;"x";"") et pas =SI(NB.SI(B2:B$14;"="&B2)>1;"x")

Désolé pour cette gaffe (je vais d'ailleurs corriger l'original, pour la postérité) ! :shy:

Par ailleurs, dans ton dernier tableau, la formule est (encore) plus fausse qu'avant, puisque tu te réfères toujours à des cellules vides et que tu as mis en référence absolue la première. En D14, tu as :
Bloc de code:
=SI(NB.SI(B$14:B18;"="&B14)>1;"x")
alors que tu devrais avoir :
Bloc de code:
=SI(NB.SI(B14:B$14;"="&B14)>1;"x";"")
 
Dernière édition:

baron

Membre d’élite
22 Avril 2008
1 711
451
LLN
Pour info, avec mon vieux Firefox 48, les formules apparaissaient tronquées mais quand elles sont placées dans un bloc code, c'est impeccable.
 

Rollmops

Membre émérite
17 Juillet 2006
961
27
Moi je suis sur Safari, dernière version pour iPad, et c'est la première fois que j'ai ce problème et pourtant je vais sur pas mal de forums.
 
Dernière édition par un modérateur: