Ooo et BDD

A

Anonyme

Invité
Bonjour

Quand je veux enregistrer une table au format .dbf, je dois chosir quel jeu de caractères sous Mac ?

Je cherche dans un deuxième temps à transférer une table de Ooo sur ma base Sql

Albert
 

ericb2

Membre confirmé
16 Novembre 2003
337
22
ericb2-> Halbert

Quel choix as-tu ? Normalement, il ne devrait pas y avoir de problème.

En attendant, comme je suis nul en bdd, je te conseille de demander sur la liste users@fr.openoffice.org , car il y a plein de gens très bons qui te répondront avec précision.

On essaie de centraliser les questions sur cette liste pour contituer une FAQ mais ensuite, rien n'empêche d'épingler ici la réponse, car je ne doute pas qu'elle resserve.

P.S. : personne n'a essayé d'ouvrir un fichier Access avec la m138 (lecture seule). Cela devrait fonctionner pour cette version.
 

FjRond

Membre émérite
16 Février 2004
797
14
62
Vendée
homepage.mac.com
Petit souci avec la dernière version d'OOo : impossible de l'ouvrir sur mon eMac (il s'ouvre sur mon iMac). Et je ne voit pas. X11 se lance, puis je vois OOo quelques instants dans la barre des menus, et plus rien. Qu'est-ce qui ne va pas ?
Une précision néanmoins: dropplet rsrc reste ouvert. Mais je n'obtiens aucune fenêtre.
 

ericb2

Membre confirmé
16 Novembre 2003
337
22
Bonjour,

FjRond a dit:
Petit souci avec la dernière version d'OOo : impossible de l'ouvrir sur mon eMac (il s'ouvre sur mon iMac). Et je ne voit pas. X11 se lance, puis je vois OOo quelques instants dans la barre des menus, et plus rien. Qu'est-ce qui ne va pas ?
Une précision néanmoins: dropplet rsrc reste ouvert. Mais je n'obtiens aucune fenêtre.
Je n'ai pas beaucoup d'informations, donc je ne suis pas sûr de pouvoir aider efficacement à ce stade.

Tout d'abord il faut 10.3 ou 10.4. Nous n'avons pas assez de ressources pour maintenir une version 10.2. Et si ça fonctionnait avec une autre version 2.0 d'OpenOffice.org , X11 est certainement la bonne version. Dans le cas contraire, bien vérifier que X11User.pkg soit installé, et pour la bonne version de Mac OS X.

Si le problème n'est toujours pas résolu, et qu'OpenOffice.org semble fonctionner, alors tenter, dans un terminal, un " killall -9 soffice.bin ". Cela peut peut-être aider...
( forcer X11 à se terminer est une autre solution )
 

FjRond

Membre émérite
16 Février 2004
797
14
62
Vendée
homepage.mac.com
ericb2 a dit:
Bonjour,


Je n'ai pas beaucoup d'informations, donc je ne suis pas sûr de pouvoir aider efficacement à ce stade.

Tout d'abord il faut 10.3 ou 10.4. Nous n'avons pas assez de ressources pour maintenir une version 10.2. Et si ça fonctionnait avec une autre version 2.0 d'OpenOffice.org , X11 est certainement la bonne version. Dans le cas contraire, bien vérifier que X11User.pkg soit installé, et pour la bonne version de Mac OS X.

Si le problème n'est toujours pas résolu, et qu'OpenOffice.org semble fonctionner, alors tenter, dans un terminal, un " killall -9 soffice.bin ". Cela peut peut-être aider...
( forcer X11 à se terminer est une autre solution )
Je suis sur 10.4.3 (voir signature). La version de X11 est correcte et OOo 136m fonctionnait parfaitement (elle fonctionne parfaitement avec fink et les unstable).
Je charge à présent la v. 138m, au cas où.
 
A

Anonyme

Invité
ericb2 a dit:
ericb2-> Halbert

Quel choix as-tu ? Normalement, il ne devrait pas y avoir de problème.

En attendant, comme je suis nul en bdd, je te conseille de demander sur la liste users@fr.openoffice.org , car il y a plein de gens très bons qui te répondront avec précision.

On essaie de centraliser les questions sur cette liste pour contituer une FAQ mais ensuite, rien n'empêche d'épingler ici la réponse, car je ne doute pas qu'elle resserve.

P.S. : personne n'a essayé d'ouvrir un fichier Access avec la m138 (lecture seule). Cela devrait fonctionner pour cette version.
Il y a un problème : seuls les titres s'enregistrent. J'ai choisi le codage ISO-8859-15

Albert
 

ericb2

Membre confirmé
16 Novembre 2003
337
22
Halbert a dit:
Il y a un problème : seuls les titres s'enregistrent. J'ai choisi le codage ISO-8859-15

Albert
Tu veux dire que tu ne peux pas enregistrer les bases de données Access que tu as ouvertes ? Normalement, seul l'accès en lecture est possible. En fait, comme je n'y connais pas grand chose en bdd, je demande :)
 

FjRond

Membre émérite
16 Février 2004
797
14
62
Vendée
homepage.mac.com
Je viens d'essayer la version OOo.2 m138. Même résultat: elle ne s'ouvre pas. Mes autres applications X11 fonctionnent normalement.
 

FjRond

Membre émérite
16 Février 2004
797
14
62
Vendée
homepage.mac.com
J'ai fait un essai sur une autre session : OOo fonctionne normalement (la version que je viens de télécharger). Alors d'où vient le problème ?
Je remarque ces jours-ci que lorsque je répare les autorisations (deux fois en moins d'une semaine), le rapport est extrêmement long et concerne beaucoup la librairie de widgets. Y aurait-il un quelconque rapport ?
Donc OOo est hors de cause. Mais pourquoi est-il seul à être touché ?

J'ai fait un nettoyage avec OnyX, redémarré… rien n'y fait.
 

ericb2

Membre confirmé
16 Novembre 2003
337
22
ericb2->FjRond

Est-ce que tu peux, s'il te plait, essayer de taper la commande ci-dessous dans un xterm (pas " Terminal.app " ). Le xterm est normalement dispo dans les applications X11. Attention à bien respecter les majuscules, expaces ..etc :

/Applications/OpenOffice.org\ 2.0.app/Contents/openoffice.org/program/soffice

S'il y a un problème, un message d'erreur devrait s'afficher. Merci de me le retourner. Je crois que tu peux copier ( Pomme-C) et ensuite coller avec CTRL-V dans le terminal

Pendant que tu y es, merci de taper aussi les commandes suivantes, qui donneront les versions exactes de X11 et de Mac OS X utilisés :
X -version

Ainsi que : uname -a

D'avance merci :)
 

FjRond

Membre émérite
16 Février 2004
797
14
62
Vendée
homepage.mac.com
ericb2 a dit:
Est-ce que tu peux, s'il te plait, essayer de taper la commande ci-dessous dans un xterm (pas " Terminal.app " ). Le xterm est normalement dispo dans les applications X11. Attention à bien respecter les majuscules, expaces ..etc :

/Applications/OpenOffice.org\ 2.0.app/Contents/openoffice.org/program/soffice

S'il y a un problème, un message d'erreur devrait s'afficher. Merci de me le retourner. Je crois que tu peux copier ( Pomme-C) et ensuite coller avec CTRL-V dans le terminal
Ça marche, malgré un message d'erreur:
Erreur lors du chargement du BASIC du document
file:///Applications/OpenOffice.org1.1.3/share/basic/WebWizard/dialog.xlb/:
Erreur générale.
Erreur générale d'entrée/sortie.
OK
Mais je ne peux toujours pas ouvrir OOo par un clic sur l'icône ou sur un fichier.
ericb2 a dit:
Pendant que tu y es, merci de taper aussi les commandes suivantes, qui donneront les versions exactes de X11 et de Mac OS X utilisés :
X -version

Ainsi que : uname -a

D'avance merci :)
Bloc de code:
[frangi - 14 novembre 2005]~ % X -version                                 15:34

XFree86 Version 4.4.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
[frangi - 14 novembre 2005]~ % uname -a                                   15:34
Darwin eMac.local 8.3.0 Darwin Kernel Version 8.3.0: Mon Oct  3 20:04:04 PDT 2005; root:xnu-792.6.22.obj~2/RELEASE_PPC Power Macintosh powerpc
[frangi - 14 novembre 2005]~ %
Halbert a dit:
La discussion lancée portait sur Ooo et les bases de données !!!
Albert
Tout à fait. C'est de ma faute, je n'ai pas fait attentiion au BDD (je suis un peu fâché avec les sigles).:zen: