OS X et les disques externes

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 555
3 553
68
Sous la limite KT
Là, je me pose des questions à propos des versions 10.8.5 et 10.9 d'OS X : en effet, dans les deux cas, je me retrouve avec un Mac qui ne veut plus démarrer : voici le contexte :

MacBook Pro 15" "mid/late 2007", sur cette machine est installé en interne Snow Leopard (à jour) et Windows XP sur sa partition BootCamp. En raison de l'impossibilité de mise à jour de certains logiciels en code "PPC", impossible d'aller au delà de 10.6.8.

Ayant récemment récupéré un "Mini Partner" de Macway (concept mis au point par collaboration entre Macway et MacBidouille) :

minipartner.jpg

Dont le disque de 320 Go est relié en Firewire 400 au MBP, j'ai installé dessus il y a quelques temps Mac OS X 10.8.3. La tentative de mise à jour "Combo" en 10.8.5 ayant avorté (blocage vers la fin de la séquence "roue dentée" du démarrage), j'ai tenté la mise à jour 10.8.4 : 10.8.4 fonctionne parfaitement. Je me dis que c'est peut-être la MàJ "combo" qui a un problème, donc je tente la mise à jour 10.8.5 "pas combo" sur mon 10.8.4 : même chose (sauf que là le plantage est un poil plus tardif, juste à l'apparition du premier écran bleu). Qu'à celà ne tienne, c'est juste pour pouvoir, le cas échéant, faire tourner telle ou telle application qui demanderait 10.7 ou 10.8 pour fonctionner, donc, je décide de rester en 10.8.4.

Arrivée de Mavericks : je démarre en 10.8.4 et lances la mise à jour depuis le MAS : même chose qu'avec la 10.8.5 combo : après le second redémarrage : plantage au même stade (roue dentée qui se bloque. Je n'ai pas encore eu le temps de tenter le démarrage en mode verbose pour voir où ça plante, mais j'en arrive à me demander : Apple aurait-il bloqué, depuis la 10.8.5 la possibilité d'installer Mac OS X sur un disque externe ?
 

Dos Jones

Va modo va molo...
Club MacG
17 Juin 2004
19 591
1 937
67
A pas de loups...
Là, je me pose des questions à propos des versions 10.8.5 et 10.9 d'OS X : en effet, dans les deux cas, je me retrouve avec un Mac qui ne veut plus démarrer : voici le contexte :

MacBook Pro 15" "mid/late 2007", sur cette machine est installé en interne Snow Leopard (à jour) et Windows XP sur sa partition BootCamp. En raison de l'impossibilité de mise à jour de certains logiciels en code "PPC", impossible d'aller au delà de 10.6.8.

Ayant récemment récupéré un "Mini Partner" de Macway (concept mis au point par collaboration entre Macway et MacBidouille) :

Dont le disque de 320 Go est relié en Firewire 400 au MBP, j'ai installé dessus il y a quelques temps Mac OS X 10.8.3. La tentative de mise à jour "Combo" en 10.8.5 ayant avorté (blocage vers la fin de la séquence "roue dentée" du démarrage), j'ai tenté la mise à jour 10.8.4 : 10.8.4 fonctionne parfaitement. Je me dis que c'est peut-être la MàJ "combo" qui a un problème, donc je tente la mise à jour 10.8.5 "pas combo" sur mon 10.8.4 : même chose (sauf que là le plantage est un poil plus tardif, juste à l'apparition du premier écran bleu). Qu'à celà ne tienne, c'est juste pour pouvoir, le cas échéant, faire tourner telle ou telle application qui demanderait 10.7 ou 10.8 pour fonctionner, donc, je décide de rester en 10.8.4.

Arrivée de Mavericks : je démarre en 10.8.4 et lances la mise à jour depuis le MAS : même chose qu'avec la 10.8.5 combo : après le second redémarrage : plantage au même stade (roue dentée qui se bloque. Je n'ai pas encore eu le temps de tenter le démarrage en mode verbose pour voir où ça plante, mais j'en arrive à me demander : Apple aurait-il bloqué, depuis la 10.8.5 la possibilité d'installer Mac OS X sur un disque externe ?
Bonne question… ;)

Pour vérifier tu pourrais cloner SL et la partition bootcamp (Via Winclone) sur ce mini Partner puis tenter l'install sur le DD interne…

J'ai installé Lion et ML sur des disques externes et les MAj se sont déroulés sans problèmes à priori… Pour Mavericks j'attends un peu car j'ai l'impression que les serveurs d'Apple rament à mort depuis qu'il est proposé…

PS : Le "Mini Partner" n'est plus en vente sur MacWay :mouais:
 
Dernière édition:

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 555
3 553
68
Sous la limite KT
Pour Mavericks j'attends un peu car j'ai l'impression que les serveurs d'Apple rament à mort depuis qu'il est proposé…

Ben ce matin, en tous cas, j'ai pu le télécharger à 8-10 Mb/s

PS : Le "Mini Partner" n'est plus en vente sur MacWay :mouais:

Ben nan, c'est vieux, ça, pour tout te dire, le disque dedans, c'est un ATA 133 !

Cela dit, avoir un disque Firewire qui fait aussi "hub" Firewire, et hub USB alimenté, c'est quand même pas mal ! ;)
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 555
3 553
68
Sous la limite KT
Bon, j'ai complété mes tests avec Mavericks : une tentative de démarrage en mode Verbose montre qu'il se bloque exactement au même endroit que Mountain Lion mis à jour en 10.8.5 au moyen de la mise à jour "Combo".

Par ailleurs, un autre test au moyen d'un disque dur "USB", cette fois montre que ça n'est pas lié à un disque en particulier, ça bloque exactement au même point !

La seule chose que je n'ai pas essayé (vu le temps que ça prendrait), c'est de cloner mon disque interne sur le Mini Partner, et d'installer Mavericks sur le disque interne, mais cela dit, le fait que jusqu'à 10.8.4, tout fonctionne normalement, et que 10.8.5 et 10.9 bloquent exactement au même stade me laisse assez dubitatif.


EDIT : Bon, alors en fait, le problème semblait venir de Mountain Lion. En effet, j'ai formaté le Mini Partner, et ai réinstallé Mavericks sur un disque vierge depuis Snow Leopard, et là, ça a fonctionné (là, je poste depuis Mavericks). Pourquoi mon cougouar (autre nom du Puma/Lion de montagne) ne voulait pas dépasser 10.8.4, par contre, mystère et boules de gomme.
 
Dernière édition:

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 555
3 553
68
Sous la limite KT
Bon, hier (avant la coupure d'internet pour l'après midi :sick:), je me suis réjouis trop vite, en fait Mavericks plante aussi, des fois au démarrage, des fois un peu plus tard, j'ai un instant pensé que c'était lié au démarrage en 64 bits du noyau, je l'ai donc repassé en 32 bits, mais ça plante toujours. Reste que l'installation a été faite en 64 bits, je vais essayer de tout réinstaller en 32 bits, pour voir (bon, je vais devoir partitionner mon Mini Partner :rateau:).
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 555
3 553
68
Sous la limite KT
Bon, ben apparemment, en ce qui concerne Mavericks, c'est "disque interne only", j'ai créé une partition de test sur mon disque interne, et là, ça fait trois démarrages et une heure et demi que j'en use sans problème.

C'est quand même bizarre, cette impossibilité de le faire fonctionner correctement sur un disque externe :confused:
 

thebiglebowsky

Skippy le grand gourou
Club MacG
22 Mai 2001
16 077
9 072
71
Belgique
Bon, ben apparemment, en ce qui concerne Mavericks, c'est "disque interne only", j'ai créé une partition de test sur mon disque interne, et là, ça fait trois démarrages et une heure et demi que j'en use sans problème.

C'est quand même bizarre, cette impossibilité de le faire fonctionner correctement sur un disque externe :confused:

Je suis surpris !:eek: ... ça fait plus de 3 ans que je suis sur DD externe en FW800 (mon DD interne est "mort") et je n'ai pas eu de problème pour l'install.

Mais c'est peut être le fait que mon DD externe est mon DD principal et que j'ai fait la MAJ depuis ce disque là ?
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 555
3 553
68
Sous la limite KT
Je suis surpris !:eek: ... ça fait plus de 3 ans que je suis sur DD externe en FW800 (mon DD interne est "mort") et je n'ai pas eu de problème pour l'install.

Mais c'est peut être le fait que mon DD externe est mon DD principal et que j'ai fait la MAJ depuis ce disque là ?

Nan, c'est surtout le fait que, si j'en crois ton profil, tu n'as pas bien tout lu : Tu es en 10.7, d'après tes infos, or je n'ai rencontré ce problème qu'avec 10.8.5 (10.8.4, ça va impec sur mes disques externes) et 10.9 ! :p
 

thebiglebowsky

Skippy le grand gourou
Club MacG
22 Mai 2001
16 077
9 072
71
Belgique
Nan, c'est surtout le fait que, si j'en crois ton profil, tu n'as pas bien tout lu : Tu es en 10.7, d'après tes infos, or je n'ai rencontré ce problème qu'avec 10.8.5 (10.8.4, ça va impec sur mes disques externes) et 10.9 ! :p

Non ! Mon profil doit être réactualisé ... j'étais en 10.8.5 et je suis passé en 10.9 sans passer par mon DD interne (raide comme une saillie !):rateau:
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 555
3 553
68
Sous la limite KT
Non ! Mon profil doit être réactualisé ... j'étais en 10.8.5 et je suis passé en 10.9 sans passer par mon DD interne (raide comme une saillie !):rateau:

Alors c'est peut-être un problème de ration machine/disque, mon MBP est le plus ancien des modèles qui sont admissibles à 10.8 et 10.9. :nailbiting: :mouais:

Cela dit, mon bon Zebigounet chéri chéri, un disque interne en carafe, ça se change, hein :siffle:

:D
 

thebiglebowsky

Skippy le grand gourou
Club MacG
22 Mai 2001
16 077
9 072
71
Belgique
Cela dit, mon bon Zebigounet chéri chéri, un disque interne en carafe, ça se change, hein :siffle:
:D

Je sais bien, mon Pascalounet, mais comme je suis nul de chez nul en bidouille et bricolage, j'ai préféré une solution simple et surtout sans risque !!!:rateau:
 

Dos Jones

Va modo va molo...
Club MacG
17 Juin 2004
19 591
1 937
67
A pas de loups...
Je sais bien, mon Pascalounet, mais comme je suis nul de chez nul en bidouille et bricolage, j'ai préféré une solution simple et surtout sans risque !!!:rateau:
C'est quoi ton modèle d'iMac ?

Si tu m'invites chez toi, logé, nourri, blanchi, filles de confort fournies je te fais le changement sans problèmes… :D
 

da capo

abonné absent
Club MacG
12 Août 2001
17 454
3 572
je ramène ma fraise dans la discussion des anciens ,)

Tout ça pour dire que l'installation de Maverick est tout à fait possible sur un DD externe.
Je l'ai personnellement faite le temps de vérifier la compatibilité de mes applications et je me prépare à le refaire pour créer une installation propre avec toutes mes applications sensibles sur un disque dédié que je clonerai au besoin.

Pour info, la machine qui a été le relai pour cette installation sur DD externe est un MBP 15" mid-2010. Donc pas une nouveauté nin vraiment une bête de course.
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 555
3 553
68
Sous la limite KT
Pour info, la machine qui a été le relai pour cette installation sur DD externe est un MBP 15" mid-2010. Donc pas une nouveauté nin vraiment une bête de course.

Comparé à mon MBP 15" "mid/late 2007", si, un peu des deux quand même ! :rateau:

Cela dit, je pense que le problème vient de mon Mac, parce que l'installation faite hier soir sur une partition du disque interne, qui a fonctionné sans problème une bonne partie de l'après midi, avec au moins trois ou quatre "redémarrages" (et que je croyais enfin stable), ben ce matin, elle ne veut plus rien savoir, soit elle plante pendant la "roue dentée", soit pendant le lancement du Finder.

Donc, tout bien pesé, je crois que je vais renoncer à tester Mavericks en attendant de pouvoir renouveler mon matos. vu le problème exposé ici, j'ai fait une clean install de Snow Leopard sur mon disque externe, là, je suis en train de procéder au transfert de toutes mes petites affaires sur ce système "propre" (où ma Magic-mouse fonctionne correctement), puis, une fois tout ceci fait, je formaterais la partition Mac de mon disque interne, et y re-transfèrerais le système "propre" via CCC.

Ce qui me sauve, là, c'est que l'emploi de mon vieux PM G4 comme serveur fait qu'en fait, point de vue "documents", je n'ai pas eu grand-chose à transférer. Les applications, par contre, c'est ça qui va me prendre du temps, j'en ai une partie qui peuvent se copier d'un disque à l'autre, mais il va y en avoir quand même pas mal à ré-installer depuis les CD/DVD d'origine ! :sick: :casse:
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 555
3 553
68
Sous la limite KT
Bon, Apple sort le 10.9.1, occasion de voir si elle change quelque chose … ben nan, rien ! Installa tion de 10.9.1 sur une partoche du disque externe (sur l'autre, il y a Lion), démarrage, tout semble aller bien, un peu de surf sur MacGé, tentative de post ici : tout se fige.
Re-démarrage : ça se fige sur la roue dentée
Re-démarrage en mode verbose : dernière ligne affichée anodine (pas de message d'erreur, notamment), mais ça se bloque.

Un symptôme tout de même, température et ventilos s'emballent, je me demande si le Mac qui se fige, ça n'est pas le processeur qui se met en sécurité (c'est lui qui chauffe, pas la carte gtaphique). Re-démarrage sous Snow Leo, il aura fallu 10 bonnes minutes pour que les ventilos redescendent à 2000 tr (vitesse "de base") et que la température du processeur repasse de 96° à 57-58°, ce qui est sa température normale en fonctionnement "peu sollicité".

Je sens qu'à l'occasion, mon MBP va aller faire un tour à l'Apple Store de Val d'Europe !