Partage de connexion: livebox 2 - mac - pc

Silmar

Membre junior
27 Octobre 2011
10
0
32
Bonjour,

Dans l'optique de monter un petit studio d'enregistrement, j'aimerais profiter de la fiabilité du mac et de la compatibilité logiciel du pc, en créant un réseau pouvant partager des fichiers et pouvant se connecter à internet.

J’ai regardé quelques centaines de pages sur des sites variés et ou tout le monde, au final, se contredit.

Ma configuration est la suivante :

Le mac est relié à la box par airport et le pc est relié au mac par ethernet (RJ 45 croisé).

Le mac est le « maître », Imac OSX tournant sous snow léopard 10.6.8.
Le pc est l’ « esclave », pc tournant sous windows vista SP2.
Le routeur est une Livebox 2 située trop loin pour tout relier en filaire.
Le FAI, Orange donc.

Les parefeu sont désactivés sur pc et mac.
J’ai donc créé un réseau « STUDIO », même nom sur le pc et sur le mac.


J’ai activé le partage de fichiers et le partage de connexion sur le pc et sur le mac.
Pour tout ce qui concerne les connexions et le partage, j’ai préféré faire des captures d’écran.

Capture PC 1: centre réseau et partage



Capture PC 2: connexions réseau



Capture PC 3: paramètres TCP/IP



Capture MAC 1: partage des fichiers



Capture MAC 2: partage de la connexion internet



Capture MAC 3: réseau airport



Capture MAC 4: réseau airport TCP/IP



Capture MAC 5: réseau airport DNS



Capture MAC 6: réseau ethernet



Capture MAC 7: réseau ethernet TCP/IP



Capture MAC 8: réseau ethernet DNS



J'ai mis les captures me paraissant les plus pertinentes.

Étant donné que je me retrouve avec une connexion entrante non reconnue sur le PC, cela doit me créer la connexion « réseau non identifié » dans le centre réseau et partage, ce qui doit me créer une sorte de conflit entre les réseaux... (enfin, c’est ce que je pense).

Voilà, si une âme charitable passe par ici, un coup de main serait bienvenu !
Et demandez-moi s’il y a besoin de nouvelles captures ou d’informations complémentaires.

PS: ce message existe également ici:
http://forum.macadsl.com/viewtopic.php?t=23556
 

Larme

Vétéran
Club MacG
11 Décembre 2007
6 491
398
Paris
sur ton PC le masque de sous-réseau est mis en 255.255.255.0 au lieu de 255.255.0.0
Oui, enfin, pour un réseau privé de classe C, j'aurais mis du 255.255.255.0 partout...
Donc, une erreur (s'il n'y en a pas d'autre, j'ai pas cherché, j'avoue, juste lu la réponse de djm), serait de mettre 255.255.255.0 sur l'avant dernier screen ;)
 

Silmar

Membre junior
27 Octobre 2011
10
0
32
Merci pour vos réponses !
Donc, effectivement, je pense qu'à force de faire et refaire les manips, j'ai du faire une erreur...
Et du coup, moi qui avait perdu le partage de fichier sans trop savoir pourquoi, maintenant ça remarche un peu. Je peux accéder au dossier partagé du mac sur le pc et du pc sur le mac.

Mais je n'ai toujours pas la connexion... :(
 

Silmar

Membre junior
27 Octobre 2011
10
0
32
Up !

En guise d'information complémentaire, j'ai remarqué que lorsque je faisais depuis le mac:

"Aller -> Se connecter au serveur -> smb://192.168.0.2"

La fenêtre s'ouvre pour me proposer quels dossier partagé du pc je souhaite ouvrir. Et Lle pc est détecté depuis le finder, sous l'onglet "PARTAGES".

En revanche, sur windows, lorsque je fais:

"Executer -> \\192.168.0.1"

La fenêtre s'ouvre directement sur la fenêtre réseau public partagé du mac. Mais le mac n'apparaît pas dans la fenêtre "Réseau".

En espérant que cette aide complémentaire sera suffisante pour trouver une solution... J'en ai marre de me casser les dents sur ce ****** de partage internet.
 

Polo35230

Membre d’élite
Club MacG
4 Janvier 2011
1 555
82
Bonjour,
Perso, au plan réseau, je n'aurais pas configuré deux plans IP.
J'aurais laissé via DHCP sur les deux interfaces du Mac (Ethernet et wifi). Sur le PC également. Pas de configuration manuelle.
Le PC et le Mac seront alors sur le même réseau.
Le Mac (avec le partage internet configuré comme actuellement) jouant le rôle d'un switch lorsque le PC voudra accéder à internet.

Peut-être que la nlle conf réseau résoudra le pb de partage de fichiers et de dossiers...


A partir d'un PC (windows 7), pour me connecter aux ressources partagées du Mac, je vais dans le centre réseau et partage---Outils---connecter un lecteur réseau, et dans la fenêtre, je tape \\192.168.0.14 (mon Mac)
J'ai alors accès aux ressources partagées du mac.
 
Dernière édition:

Silmar

Membre junior
27 Octobre 2011
10
0
32
Bonjour et merci pour les infos.

Donc sur vista, je suis repassé en IP automatique, sur le mac, je suis repassé en automatique également et, le partage de fichier marche toujours ! (je ne m'y attendais pas mais bon, tant mieux).

Côté pc, toujours une connexion entrante dans les connexions réseaux, mais le réseau non identifié a disparu du centre réseau et partage (cf screen 1).
Sous mac, le réseau que j'avais configuré n'apparaît plus dans le finder, mais l'échange de fichier fonctionne toujours. Par contre, la connexion ethernet apparaît en jaune (cf screen 2)...

Voilà ou j'en suis en paramétrant les IP en automatique. Est ce que j'ai oublié autre chose ?

Screen 1



Screen 2



Accessoirement, le masque sous réseau du screen 2 m'affiche 255.255.0.0, ce qui ne me semble pas très normal... mais bon, j'y connais rien.
 

Polo35230

Membre d’élite
Club MacG
4 Janvier 2011
1 555
82
Je comprends pas comment avec ethernet en jaune, le partage de ficher peut marcher...
Il faudrait (dans la conf réseau) lancer l'assistant, et regarder l'état des voyants dans "diagnostics".
Le PC a une adresse en 169.254..., ça veut dire que la box ne lui a pas affecté d'adresse IP.

Il n'y a pas de pb de connectique ethernet avec le mac?
Quelle est la conf réseau côté Mac?
Voir aussi dans "Avancé" l'onglet ethernet
 

Silmar

Membre junior
27 Octobre 2011
10
0
32
Donc l'adresse indiquée sur le mac en guise d'adresse ip ethernet serait celle du pc et elle devrait être assignée par la box c'est ça ?

Côté connectiques, je suis en rj45 croisé, j'avais commencé par essayer avec un câble droit, mais je n'ai rien réussis à faire.
Puis le transfert de fichier fonctionne, c'est donc qu'il y a quelque chose à l'autre bout du fil.

La config réseau côté mac, euh... airport connecté à la box (voyant vert). Et ethernet connecté au pc (jaune). Les deux connexions configurées en via dhcp.

Dans "Avancé" de l'onglet ethernet, je suis donc en via dhcp et j'ai cet étrange masque sous-réseau: 255.255.0.0, sous l'onglet tcp/ip
Si je vais dans DNS, c'est vierge.
Et les autres ne sont pas configurés (jamais touché).

Lorsque je lance l'assistant en mode diagnostique, il me demande quelle connexion je veux utilisé pour me connecter à internet. Je met airport. Je choisis ma livebox. Et il me dit que ça fonctionne. (Mais ça ne fonctionne pas comme je voudrais, ethernet est toujours jaune).

Si je choisit ethernet intégré comme connexion pour me connecter à internet, il me met directement que tout fonctionne. Mais rien ne change.

Si j'essaye l'assistant de configuration nouvelle connexion, il ne me trouve même pas le réseau airport (alors qu'il y est connecté)...

Plus j'avance, moins j'y vois clair...
 

Polo35230

Membre d’élite
Club MacG
4 Janvier 2011
1 555
82
Bon, il faut tout mettre à plat...:)

La Box (on est chez Orange) doit avoir 192.168.1.1 comme adresse IP.

Mac:
Interface airport (configuration via DHCP)
Adresse IP: 192.168.1.1x (x variable)
Masque: 255.255.255.0
Routeur: 192.168.1.1
Serveurs DNS: 192.168.1.1

Interface ethernet du Mac (configuration en manuel)
Adresse IP: 192.168.1.20
Masque: 255.255.255.0
Routeur: rien
Serveur DNS: rien

PC:
Interface ethernet (configuration en manuel)
Adresse IP: 192.168.1.21
Masque: 255.255.255.0
Routeur: 192.168.1.1
Serveur DNS: 192.168.1.1

A partir du PC, il faudrait faire un ping 192.168.1.20
Si c'est bon, alors, faire un ping 192.168.1.1
Si la connectique est bonne entre le PC et le Mac, ça doit marcher...
Après, ça sera facile...;)
 

Silmar

Membre junior
27 Octobre 2011
10
0
32
Bonjour,

Alors du coup, je suis repassé en manuel, exactement comme indiqué, chiffre pour chiffre.

Le ping 192.168.1.20 fonctionne niquel, le ping 192.168.1.1 me met impossible de joindre l'hôte de destination. J'ai également essayé de suivre cette configuration pour voir:

Interface ethernet du pc (configuration en manuel)
Adresse IP: 192.168.1.21
Masque: 255.255.255.0
Routeur: 192.168.1.1
Serveur DNS: 192.168.1.1
Passerelle par défaut: 192.168.1.1

Lors du ping, il me met pour 4 paquet envoyés: le délai d'attente de la commande dépassé une fois et impossible de joindre l'hôte de destination trois fois.

Et celle là:

Interface ethernet du pc (configuration en manuel)
Adresse IP: 192.168.1.21
Masque: 255.255.255.0
Routeur: 192.168.1.1
Serveur DNS: 192.168.1.1
Passerelle par défaut: 192.168.1.20

Lors du ping, il me met pour 4 paquet envoyés: le délai d'attente de la commande dépassé deux fois et impossible de joindre l'hôte de destination deux fois.

Ce qui signifie concrètement que dans tous les cas de figures, j'arrive jusqu'au mac, mais qu'il ne trouve pas son chemin jusqu'à la box...

Si, à la fin de cette dernière configuration, je rajoute sur la configuration ethernet du mac: 192.168.1.1 en routeur, le ping 192.169.1.1 depuis le pc me met 4 fois impossible de joindre l'hôte.

De cette façon, la "diode ethernet" est de nouveau verte :) mais la connexion du mac commence à beuguer (ne charge plus les sites en dehors de google, je pige plus rien...)
Et si je rentre 192.168.1.1 en guise de dns, toujours sur la configuration ethernet du mac, les diodes de airport et de l'ethernet restent verte, mais je perds totalement ma connexion sur le mac ! Je suis obligé de repasser en configuration dhcp sur l'ethernet du mac (diode jaune) pour avoir une connexion stable.

Je suis en train de me demander si mon problème vient vraiment de là... Est ce que j'ai pu me planter sur le groupe de travail ? Est ce que le rj45 croisé convient bien à ce type d'installation ou un droit serait plus adapté ?

Bref, toujours pas de connexion sur le pc :(
 

Polo35230

Membre d’élite
Club MacG
4 Janvier 2011
1 555
82
Bonjour,

Si on prend la conf du post 11 (Sur l'interface ethernet du Mac, il ne faut rien mettre, ni dans routeur, ni dans serveur DNS), le bilan est donc le suivant:
Le PC pingue bien le mac sur 192.168.1.20 (donc, tout est bon entre le PC et le Mac)
Le PC ne pingue pas la Box (192.168.1.1)
La diode ethernet du Mac est verte.
Le Mac accède bien à internet.

Vous avez raison, tout se passe comme si le ping (du Mac vers la Box) ne traversait pas le Mac.

Comment est configuré la partage internet?
En principe, il faudrait:
Case partage internet cochée
Partager votre connexion depuis: Airport
Aux ordinateurs via: Ethernet

Le câble est bon (les pings entre le PC et le Mac marchent bien)

Quant au groupe de travail, chez moi, je n'ai rien fait (c'est le groupe de travail par défaut workgroup qui est utilisé)

Sur le PC, j'ai créé un nouvel utilisateur avec un mot de passe (il faut absolument un mot de passe)
J'ai activé le partage de fichiers ou répertoires (tt le monde en autorisations)

Sur le Mac, dans le Finder--aller--se connecter au serveur, on tape smb://adresseIPduMac
On voit alors le PC
Toujours dans le Finder, on se positionne sur le PC, et on se connecte comme utilisateur référencé.
Une fenêtre s'ouvre alors, et on rentre l'utilisateur et le mot de passe créés précédemment.
Du Mac, on accède alors aux ressources du PC.

A partir du PC,pour se connecter aux ressources partagées du Mac, on va dans centre réseau et partage---Outils---connecter un lecteur réseau, et dans la fenêtre, on tape \\192.168.0.14 (le Mac)
On a alors accès aux ressources partagées du Mac

Mais le contexte n'est pas le même chez moi (pas de partage internet)
 
Dernière édition:

Silmar

Membre junior
27 Octobre 2011
10
0
32
Ça marche !

Alors honnêtement, c'était tout con (et très blasant il faut l'avouer). Mais dans toutes les manip que j'ai effectuée, j'ai fais une grosse connerie, j'ai modifié le partage internet en mettant la connexion via ethernet et la connexion aux ordinateurs via airport.

Inutile de me demander pourquoi, je ne le sais pas moi même.
Bref, j'ai ensuite repasser la connexion ethernet du pc et de l'ethernet du mac en via dhcp (en automatique en gros) et la petite icône internet s'est affichée sur le pc.

Bon, ce qui est un peu étrange, c'est que je n'ai pas la diode verte sur la connexion ethernet du mac. Et je n'ai pas le mac qui apparaît sur le pc dans réseau, ni le pc qui apparaît dans le finder du mac.
Pour ce dernier point, je pense que c'est à cause du workgroup... enfin... sans grande conviction tout de même, mais bon.
Le principale, c'est qu'après 4 ou 5 jours à me casser les dents sur ce réseau, il fonctionne ! Aussi bien en partage de fichier (via le dossier public), qu'en partage de connexion.

Donc merci pour tout Polo35230, c'est 100% grâce à toi !
 

Polo35230

Membre d’élite
Club MacG
4 Janvier 2011
1 555
82
Que la diode pour la connexion ethernet ne soit pas verte me semble logique. Après tout, la couleur de cette diode est la résultante (je crois) de plusieurs éléments qu'on voit dans les diagnostics réseau (Ethernet intégré, Réglages réseau, FAI, Internet et serveur).
Si tu vas voir dans la conf réseau--Assistant--Diagnostic (ne pas faire continuer ensuite), à mon avis, ethernet doit être vert, mais le reste, pas sûr.... Ce port ethernet n'est pas du côté de la box...

Mais le principal, c'est que tout ça soit tombé en marche....;)
Il faut mettre la conf au coffre...:D
 

Silmar

Membre junior
27 Octobre 2011
10
0
32
En effet, ça tient la route. Toutes les diodes sont vertes dans l'assistant.

Encore merci, ça m'enlève une grosse épine du pied !