10.15 Catalina Partition DDE ne monte plus

mercimille

Nouveau membre
8 Janvier 2018
2
0
45
Bonjour,
Je ne trouve pas le problème exact et j'ai un peu peur de me frotter aux solutions Terminal qui ne seraient pas tout à fait adapté à mon cas…

Le DDE d'1 To est partitionné – l'une de ces partitions ne monte plus sur le bureau suite à une panne de courant (et la 2e partition ne veut pas s’éjecter), elle apparait cependant grisée dans l'utilitaire de disque. Les données contenues sur cette partition sont bien entendu cruciales pour moi, sinon ce ne serait pas drôle…

Je copie-colle les diskutil list et info concernés, ci-dessous, en croisant les doigts pour que l'un de vous (me dise ce que j'ai envie d'entendre) puisse m'en dire plus sur le problème. En vous remerciant.

Bloc de code:
diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         121.0 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +121.0 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD - Données  95.5 GB    disk1s1
   2:                APFS Volume Preboot                 97.4 MB    disk1s2
   3:                APFS Volume Recovery                529.0 MB   disk1s3
   4:                APFS Volume VM                      2.1 GB     disk1s4
   5:                APFS Volume Macintosh HD            11.3 GB    disk1s5
   6:                APFS Volume REBOOT MAVERICKS        1.1 MB     disk1s6

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:       Microsoft Basic Data Elements                1000.0 GB  disk2s2

/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *1.0 TB     disk3
   1:               Windows_NTFS MAX-MOVIE               500.2 GB   disk3s1
   2:               Windows_NTFS MAX-COPIE               500.0 GB   disk3s2

puis

Bloc de code:
diskutil info disk3s2
   Device Identifier:         disk3s2
   Device Node:               /dev/disk3s2
   Whole:                     No
   Part of Whole:             disk3

   Volume Name:               MAX-COPIE
   Mounted:                   No

   Partition Type:            Windows_NTFS
   File System Personality:   ExFAT
   Type (Bundle):             exfat
   Name (User Visible):       ExFAT

   OS Can Be Installed:       No
   Media Type:                Generic
   Protocol:                  USB
   SMART Status:              Not Supported
   Volume UUID:               395AC1E4-4B3D-3966-B676-3D4EDE4C57B8
   Partition Offset:          500236662272 Bytes (977024731 512-Byte-Device-Blocks)

   Disk Size:                 500.0 GB (499968223744 Bytes) (exactly 976500437 512-Byte-Units)
   Device Block Size:         512 Bytes

   Volume Total Space:        0 B (0 Bytes) (exactly 0 512-Byte-Units)
   Volume Free Space:         0 B (0 Bytes) (exactly 0 512-Byte-Units)

   Read-Only Media:           No
   Read-Only Volume:          Not applicable (not mounted)

   Device Location:           External
   Removable Media:           Fixed

   Solid State:               Info not available

J'ajoute qu'à la commande diskutil unmount disk…, le Terminal répond : Volume MAX-MOVIE on disk3s1 timed out while waiting to unmount

Je n'ai pas de succès avec ce post… mais en faisant une recherche ciblée sur @macomaniac, j'ai tout de suite trouvé un sujet similaire, j'ai fait les manip, j'avais les mêmes réponses que la personne en question, et donc la même conclusion : le système de fichiers est HS. Bien mauvaise nouvelle... Comment indiquer que c'est (tristement) "résolu" pour fermer mon fil ?
Merci
 
Dernière édition par un modérateur:

ericse

Membre d’élite
Club MacG
30 Avril 2019
3 681
580
Bonjour,
Désolé pour tes données. Je l'ai dit plusieurs fois ici mais je ne suis pas très entendu : ExFat est un bon format d'échange mais un très mauvais format de stockage, car il n'est pas journalisé, ce qui le rend fragile lors des interruptions brutales.
Ceci dit, si tu as des fichiers à récupérer, tu peux essayer https://www.cgsecurity.org/wiki/PhotoRec_FR , ce n'est pas un programme super ergonomique, mais je l'ai déjà utilisé avec succès pour récupérer des fichiers. Bon courage en tout cas.
 

mercimille

Nouveau membre
8 Janvier 2018
2
0
45
Bonjour au macgénéreux !
et merci ericse pour ton retour – et ton empathie !

ExFat a tout de même l'avantage d'être compatible avec Windows et de n'avoir aucune limite de taille fichier, non ? J'ai l'impression qu'il n'y a pas de format idéal, mais je ne suis pas assez calée…

Là, j'ai acquis un WD MyPassport 3 To (magnifique) mais l'utilitaire de disque me dit qu'on ne peut pas changer la taille du volume. En effet, aucune partition n'a l'air possible… Peut-être que quelqu'un parmi vous peut me dire si par le Terminal, on peut "forcer" tout ça ?

J'ai fait un diskutil list et le volume se compose en disk2 (GUID_partition_scheme) et disk2s1 (Microsoft Basic Data My Passport)… Le mot Microsoft… ça va pas ça, si ?

Merci pour votre aide
 
Dernière édition par un modérateur:

ericse

Membre d’élite
Club MacG
30 Avril 2019
3 681
580