10.15 Catalina Point de montage fixe pour disque USB

MRJG

Membre junior
12 Juillet 2020
29
2
46
Hello,

Même résultats malgré la désactivation du SIP :/

J'ai cherché sur base des codes erreur rencontrés mais je n'ai pas trouvé de réponse qui m'interpelle... si vous avez une idée, je suis preneur...
Dois-je mettre mon point de montage ailleurs ? Où ?
Dois je appliquer d'autres droits à mon point de montage (lesquels ?)
Autre...

PS : je ne peux pas éditer ma dernière réponse une troisième fois donc j'ai rajouté cette réponse
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 412
22 653
Forêt de Fontainebleau
Si l'UUID du volume Brol est : C14766F1-405D-3679-A675-5255FEC16FE6 =>

- contente-toi d'inscrire dans le fichier fstab :​
Bloc de code:
UUID=C14766F1-405D-3679-A675-5255FEC16FE6  none hfs rw,auto
  • comment t'y prends-tu pour procéder à une édition du fichier ? - il est bien dans le dossier /private/etc ? - ses accédants sont bien root : wheel ?
 

MRJG

Membre junior
12 Juillet 2020
29
2
46
Pour éditer le fichier je fais un sudo vim /etc/fstab ("i", modifier, "esc", ":wq!")
Le fichier est donc dans /private/etc/fstab
Bloc de code:
ls -l /private/etc/fstab
-rw-r--r--   1 root  wheel      92 21 jul 08:13 fstab
Bon ben j'ai ce message d'erreur...

Bloc de code:
% mount -a
mount_apfs: volume could not be mounted: Operation not permitted
mount: / failed with 77
mount: realpath /Users/groszaissaiacertia.be/none: No such file or directory

Avec un sudo un peu moins d'erreurs :

Bloc de code:
% sudo mount -a     
mount: realpath /Users/groszaissaiacertia.be/none: No such file or directory
Note qu'il y avait 2 espaces avant none, j'ai essayé avec 1 ou 2, pareil...
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 412
22 653
Forêt de Fontainebleau
La commande mount demande toujours le sudo.

- si tu redémarres simplement => est-ce que le volume correspondant à l'UUID (BROL ?) est monté sans index numérique (commande df -H) ?​
 

MRJG

Membre junior
12 Juillet 2020
29
2
46
La disque semble monté "normalement" (c'est à dire sans prendre en compte le fstab)
Bloc de code:
/dev/disk2s2    640G   621M   639G     1%     694 4294966585    0%   /Volumes/BROL
Petite question, pourquoi proposer "none" comme point de montage ? Est ce pour limiter les sources d'erreur potentielles ?
Bloc de code:
UUID=C14766F1-405D-3679-A675-5255FEC16FE6  none hfs rw,auto
Encore merci
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 412
22 653
Forêt de Fontainebleau
L'option none => signifie qu'aucun point de montage personnalisé n'est assigné. En conséquence : le volume est monté dans le répertoire invisible /Volumes du volume de démarrage > répertoire /Volumes dédié au montage des volumes externes (le volume de démarrage n'y ayant qu'un lien symbolique redirigeant à son point de montage / de volume démarré - point de montage / "en kernel" = noyau du Système chargé en RAM en préambule de démarrage).

- l'instruction actuelle de fstab est redondante du montage par défaut du volume. Mais on peut supposer qu'elle est prise en compte en priorité sur ce montage automatique > avec une identité du volume constituée par son UUID. Reste à voir alors si cette instruction du fichier fstab est capable > itérativement > d'induire un montage de BROL sans index numérique. Indexation numérique qui découle d'un dysfonctionnement manifeste du Système.​

Tu n'as qu'à faire une série de test échelonnés de redémarrages > le DDE du volume BROL toujours branché => et vérifier par la commande : df -H si BROL est toujours monté sans index numérique.
 

MRJG

Membre junior
12 Juillet 2020
29
2
46
N'est il pas possible de lui indiquer un dossier fixe vers lequel faire le montage ?
 

MRJG

Membre junior
12 Juillet 2020
29
2
46
Hello,

Petit délai de réponse (4 jours off puis retard à rattraper)

Bon bein après 20 minutes à brancher/débrancher, monter/démonter, arreter/démarrer, ça recommence, le disque se monte dans /Volumes/BROL 1 à la place de /Volumes/BROL
:/
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 412
22 653
Forêt de Fontainebleau
Je te conseille de réinstaller l'OS -->

- car la raison de ces montages de volumes indexés > alors même qu'aucun volume homonyme n'est pré-monté => est manifestement un dysfonctionnement du Système (du kernel et des services auxiliaires de gestion des volumes comme diskarbitrationd & diskmanagementd. Je pense qu'il est vain de chercher à corriger un tel dysfonctionnement par une espèce de patch au niveau des effets (contrer un dysfonctionnement-Système par un tampon neutralisateur) : il faut intervenir en amont > au plan des causes (le logiciel-Système).​
 
  • Wow
  • J’aime
Réactions: MRJG et litobar71

MRJG

Membre junior
12 Juillet 2020
29
2
46
Je vais tester ça, ça n'est pas trop embêtant vu que mon système est plus une machine de test que de production...

Je te reviens sur ce point

Merci encore de tes bons conseils :D
 

MRJG

Membre junior
12 Juillet 2020
29
2
46
Petit feedback:

  • reset Mac et réinstall ok
  • tests disques monter/démonter OK
  • réinstall soft de backup (comet) ok
  • tests back up vers disques + disques monter/démonter... retour du disque BROL 1

Visiblement le soft de backup a une incidence sur le point de montage, je ne sais pas laquelle, ça ne sera pas le sujet ici.

Merci beaucoup à toi macomaniac pour ton aide.

Bonne journée à tout le monde
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
74 412
22 653
Forêt de Fontainebleau
Je te conseille de télécharger la démo de Carbon Copy Cloner (gratuite un mois) > et de l'utiliser pour cloner à la place de ton cloner (à désinstaller) -->

- est-ce que les volumes sont montés par le kernel sans indexation en mode constant ?​
 

MRJG

Membre junior
12 Juillet 2020
29
2
46
Ça n'est pas un cloner, c'est un soft de backup qui permet de backuper les fichiers vers des cloud type S3 (amazon, wasabi) mais aussi vers des disques USB. Visiblement la gestion des disques/montages sous mac est mal gérée par le soft...

- est-ce que les volumes sont montés par le kernel sans indexation en mode constant ?
J'ai fait des tests avant d'installer le soft et le montage se faisait de manière régulière. Je me rend compte que par contre il y a une variable que je n'ai pas pris en compte c'est le montage de 2 disques USB. Avant d'installer mon soft de backup j'ai testé avec 1 disque et après avoir installé mon soft 2 disques USB...
Je vais le désinstaller et refaire des tests pour valider que le perturbateur est bien mon soft...
 

andr3

Membre émérite
15 Septembre 2011
567
27
Manage.Be
Comme logiciel de backup, il y’a aussi « ARQ » qui fonctionne très bien tant en USB qu’avec des clouds.