Problème affichage Firefox

igorbatchev

Membre actif
22 Novembre 2009
355
10
Bonsoir !

J'ai un MacBook Pro mi 2010, qui roule très bien avec son SSD et sa RAM doublée.

Je rencontre un problème avec Firefox depuis peu : les affichages sont incomplets. Pourtant je n'ai pas ajouté de module récemment, et quand je désactive mes divers bloqueurs, ça ne résout rien. J'ai fait le ménage dans mes caches avec Onyx, ça n'a rien changé. J'ai désinstallé puis réinstallé l'appli : rien non plus. Tout s'affiche bien sur Chrome.

Quelqu'un aurait une idée ?

Voilà par exemple comment s'affiche la page d'accueil de MacGeneration :

CAPTURE_ 2021-08-14 à 22.29.27.png
 
Dernière édition par un modérateur:

peyret

Membre expert
Club MacG
22 Octobre 2001
5 884
2 604
71
43110
Salut,

...quelle version de Firefox ?
 
Dernière édition par un modérateur:

cabadet

Membre enregistré
16 Août 2021
8
1
53
Bonjour à tous,

J'ai exactement le même souci sur mon iMac 27 pouces. J'ai supprimé les cookies et fait réparer Firefox mais rien de mieux : les pages n'ont plus le style et apparaissent en style texte.
Je ne vois pas comment résoudre le problème. Peut-être que cela vient de High Sierra qu'on ne peut plus mettre à jour et qui n'est pas adapté à la dernière version de Firefox ? Sur Safari ou Chrome, aucun souci.

La seule solution que je vois pour l'instant c'est de revenir sur la version précédente. Quelqu'un a-t-il une autre solution ?
 
Dernière édition par un modérateur:

peyret

Membre expert
Club MacG
22 Octobre 2001
5 884
2 604
71
43110
J'ai exactement le même souci sur mon iMac 27 pouces. J'ai supprimé les cookies et fait réparer Firefox mais rien de mieux : les pages n'ont plus le style et apparaissent en style texte.
Salut,
...ce menu est-il bien sélectionné ? --> Capture d’écran 2021-08-16 à 10.51.50.png
 
Dernière édition par un modérateur:

cabadet

Membre enregistré
16 Août 2021
8
1
53
...ce menu est-il bien sélectionné ? -->
Bonjour et merci de t'interesser à ce problème qui n'a pas l'air unique.

Oui j'ai vérifié, il l'est bien. Je l'ai même décoché puis recoché mais le problème est toujours là.
Bien sûr, si je décoche le style est bien plus primitif mais, en le cochant, je ne retrouve pas mon beau Firefox.
 
Dernière édition par un modérateur:

peyret

Membre expert
Club MacG
22 Octobre 2001
5 884
2 604
71
43110
...et en désactivant les extensions de Firefox ?
là je sèche....
(pour ma part firefox 91 imac de ma signature sur HS et pas de problème...)
 

cabadet

Membre enregistré
16 Août 2021
8
1
53
Je viens de regarder et toutes mes extensions sont déjà désactivées mais j'ai remarqué un message qui me parait faire mouche : "Tous les modules complémentaires ont été désactivés par le mode sans échec." Je serais donc en mode sans échec ? Je ne savais pas que Firefox avait ce type de mode ; je croyais que ce n'était que pour les OS.

D'où ma nouvelle question : comment revenir à un mode normal pour Firefox ? je vais un peu chercher de mon côté et je reviens vers le forum si je trouve quelque chose.
 
Dernière édition par un modérateur:

peyret

Membre expert
Club MacG
22 Octobre 2001
5 884
2 604
71
43110
Dernière édition par un modérateur:

cabadet

Membre enregistré
16 Août 2021
8
1
53
Faux espoir, ce mode sans échec vient effectivement du mode de dépannage que j'avais activé dans ma dernière tentative. Il suffit de quitter Firefox et et le relancer pour quitter le mode sans échec. Donc problème initial toujours présent !

Ce qui est fou, c'est que cela fait 20 ans que j'utilise Firefox et que je n'ai jamais eu de souci. Depuis la mise à jour de la semaine dernière, c'est le chantier !
 
Dernière édition par un modérateur:

peyret

Membre expert
Club MacG
22 Octobre 2001
5 884
2 604
71
43110

cabadet

Membre enregistré
16 Août 2021
8
1
53
OK merci ! J'ai fait la chose et c'est bon, tout est redevenu dans l'ordre. J'ai bien enlevé aussi la mise à jour automatique de Firefox. J'attendrai une future version pour réessayer mais pour l'instant je reste ainsi.

On peut mettre le souci comme résolu même si... cela reste une solution viable !!
 
Dernière édition par un modérateur:
  • J’aime
Réactions: peyret

radioman

Membre actif
23 Octobre 2007
590
123
Limoges
C'est la version 91 qui met le bazar, j'ai restauré la version 90 avec Time Machine mais il faut créer un autre utilisateur :
Firefox -> poubelle, retour à Safari
 
Dernière édition par un modérateur:

cabadet

Membre enregistré
16 Août 2021
8
1
53
J'utilise aussi Safari depuis toujours. Cela me permet de trier mes fenêtres et c'est vrai que j'ai pensé à revenir qu'à Safari et arrêter Firefox mais au final avec la version 90 tout roule. Il suffit de te reconnecter avec ton compte et tout roule mais faut se dépêcher de stopper la mise à jour car il va très vite à revenir à la 91.

J'utilise aussi parfois Chrome qui marche pas mal mais mon chouchou c'est Firefox. Ce n'est pas du snobisme, c'est juste qu'il lit des choses que Safari ne peut pas lire. Sinon d'accord avec toi pour la 91 ! C'est le foutoir !!
 
Dernière édition par un modérateur:

chafpa

Membre expert
Club MacG
12 Décembre 2009
2 823
216
Elsass, aux pieds des Vosges
Etant passé à la version 91 très brièvement avant un retour à la 90, c'est cette version qui fout le bazar.

J'ai questionné sur le forum Geckozone (Softs de Mozilla version française) et on me demande des copies écran sauf que je ne suis pas pressé de réinstaller la 91 pour les faire.

Il est peut-être possible que Thunderbird (= Mail) soit aussi impacté mais je n'ai pas du tout approfondi et fais aussi un retour à la version précédente dans la foulée. ;)

PS : Evidemment j'ai les mises à jour automatiques TOUJOURS désactivées !
 

ScapO

Membre actif
30 Septembre 2014
465
468
Slt,

avec cette V91, qu'est-ce qui peut mettre le bazar chez vous et pas chez d'autres ?
 

radioman

Membre actif
23 Octobre 2007
590
123
Limoges
Dernière édition par un modérateur:

cabadet

Membre enregistré
16 Août 2021
8
1
53
Je ne suis pas sûr de la raison du problème mais, comme je l'ai dit plus haut, je pense que le souci est la compatibilité avec High Sierra. C'est à vérifier. Ya-t-il un Big Sur qui aurait ce souci ?

Par contre, vu le nombre de gens qui ont ce souci, je pense que cela suffit à justifier la réalité du problème réel.
Idem pour moi ! Je n'ai pas envie de remettre la 91 pour des captures d'écran mais celui qui n'est pas encore repassé en 90 peut encore le faire.
 
Dernière édition par un modérateur: