Problème de chiffrement

ataraxie44

Nouveau membre
9 Avril 2010
9
0
Bonjour tous le monde,

J'ai un souci avec un macbook unibody certainement du à une mauvaise manip mais j'ai beau chercher je ne trouve pas laquelle.
Je m'aperçois lors d'une copie de fichiers vers mon serveur samba que certains sont incopiables car je n'ai pas les droits nécessaires...
je lance un ls -l qui me retourne :

capturedecran.jpg

Tous les fichiers me posant problème sont ceux avec le @.
Il me semble comprendre avec la doc de ls qu'il s'agirait d'une histoire de chiffrement.
Filevault est désactivé ; je ne l'ai d'ailleurs jamais lancé.

Mon problème aujourd'hui est que mes fichiers sont inexploitables par un autre ordinateur. Il n'y a que l'utilisateur actuel du macbook (celui de la création des fichiers) qui peut les modifier mais même pas les copier.
Autrement dit, si je réinstalle, je perd tous.

Quelqu'un aurait une idée de la cause du problème et d'une solution si possible :)

Merci d'avance

---------- Nouveau message ajouté à 17h56 ---------- Le message précédent a été envoyé à 17h51 ----------

Ce @ est valable avec tous les fichiers créés avec l'interface graphique.
Si je créé un fichier via le terminal, je n'ai pas de problème

chown et chmod inefficaces
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
597
Île-de-France
Bonsoir et bienvenue sur MacGé' :coucou:

Les fichiers apparaissant avec un @ sont, il me semble, ceux qui sont compressés de manière transparente par HFS+ (sous Snow Leopard uniquement).

Ça ne règle pas ton problème, mais c'est peut-être un début de piste pour comprendre ce qui se passe.

---------- Nouveau message ajouté à 21h41 ---------- Le message précédent a été envoyé à 21h32 ----------

Tu pourrais tenter de copier ces fichiers à l'aide de la commande « ditto --nohfsCompression » pour vérifier que le @ disparaît bien sur les fichiers de destination. On aurait ainsi la confirmation qu'il s'agit bien de fichiers compressés par Snow Leopard.
 

ataraxie44

Nouveau membre
9 Avril 2010
9
0
Merci pour la réponse mais ca ne semble pas fonctionner. Je duplique bien le fichier mais il reste le @
Je continu de chercher

---------- Nouveau message ajouté à 11h22 ---------- Le message précédent a été envoyé à 11h00 ----------

je n'ai encore jamais vu ça :
ls -@l retourne :
http://img685.imageshack.us/img685/3223/capls.jpg

---------- Nouveau message ajouté à 12h11 ---------- Le message précédent a été envoyé à 11h22 ----------

Un autre fil de discussion tournant autour du problème. Il sera peut-être utile pour certains :
http://forum.macbidouille.com/lofiversion/index.php/t241012-100.html

J'opte pour la méthode tar qui réédite complétement les droits d'un fichier à la création de l'archive. Je vais pouvoir récupérer mes données et réinstaller. Arrière goût amer de ne pas avoir trouvé de solution.
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
597
Île-de-France
Le @ indique d'une manière générale la présence d'un attribut étendu ou de méta-données (et pas nécessairement une compression transparente).

Pourrais-tu préciser avec quel outil tu tentes de faire la copie vers le serveur SAMBA ?
 

ataraxie44

Nouveau membre
9 Avril 2010
9
0
Bonjour,

Et bien le problème est à moitié règlé. J'ai pu récupérer mes fichiers grâce à TAR mais même après réinstallation + mises a jour, lorsque je créé un fichier avec textedit :


MacBook-de-Mac-Book:~ macbook$ ls -a@le Desktop/
total 96
drwx------+ 10 macbook staff 340 11 avr 10:17 .
0: group:everyone deny delete
drwxr-xr-x+ 18 macbook staff 612 11 avr 10:05 ..
0: group:everyone deny delete
-rw-------@ 1 macbook staff 6148 11 avr 10:17 .DS_Store
com.apple.FinderInfo 32
-rw-r--r-- 1 macbook staff 0 10 avr 19:04 .localized
-rw-r--r--@ 1 macbook staff 20479 11 avr 10:17 Capture d’écran 2010-04-11 à 10.16.59.png
com.apple.FinderInfo 32
com.apple.metadata:kMDItemIsScreenCapture 42
com.apple.metadata:kMDItemScreenCaptureType 51
-rw-r--r--@ 1 macbook staff 162 10 avr 19:10 test.rtf
com.apple.FinderInfo 32
-rw-r--r--@ 1 macbook staff 177 11 avr 10:07 test2.rtf
com.apple.FinderInfo 32
-rw-r--r--@ 1 macbook staff 177 11 avr 09:44 test3.rtf
com.apple.FinderInfo 32
-rw-r--r--@ 1 macbook staff 177 11 avr 09:44 test4.rtf
com.apple.FinderInfo 32
-rw-r--r--@ 1 macbook staff 177 11 avr 10:12 test5.rtf
com.apple.FinderInfo 32

L'ordi est juste réinstallé + formatage avec MAJ sans aucun autre soft, ni aucune configuration

Je pose la question car je commence vraiment à avoir des doutes : est-ce-normal ?


merci d'avance
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
597
Île-de-France
Chez moi, ces attributs étendus du Finder (com.apple.FinderInfo) n'apparaissent pas, à moins que je fasse une manipulation supplémentaire (changement de la couleur du texte de l'icône, création d'un lien, etc.).

Pour voir de quoi il retourne, il faudrait utiliser la commande en ligne « xattr -l » sur l'un de ces fichiers. Par exemple :
Bloc de code:
xattr -l ~/Desktop/test.rtf
Le dump des 32 octets permettrait de voir les informations qui ont été rajoutées (notamment les 9ème et 10ème octets).
 

ataraxie44

Nouveau membre
9 Avril 2010
9
0
MacBook-de-macbook:Desktop macbook$ xattr -l test.rtf
com.apple.FinderInfo:
00000000 00 00 00 00 00 00 00 00 00 10 00 00 00 00 00 00 |................|
00000010 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
00000020
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
597
Île-de-France
... :confused:

D'après ce qu'on lit, la valeur des flags Finder est 0x0010. Or, je ne trouve pas la signification du bit positionné (bit 4) dans la documentation d'Apple.

Bloc de code:
[SIZE="1"]enum {
  kIsOnDesk                     = 0x0001, /* Files and folders (System 6) */
  kColor                        = 0x000E, /* Files and folders */
                                        /* bit 0x0020 was kRequireSwitchLaunch, but is now reserved for future use*/
  kIsShared                     = 0x0040, /* Files only (Applications only) */
                                        /* If clear, the application needs to write to */
                                        /* its resource fork, and therefore cannot be */
                                        /* shared on a server */
  kHasNoINITs                   = 0x0080, /* Files only (Extensions/Control Panels only) */
                                        /* This file contains no INIT resource */
  kHasBeenInited                = 0x0100, /* Files only */
                                        /* Clear if the file contains desktop database */
                                        /* resources ('BNDL', 'FREF', 'open', 'kind'...) */
                                        /* that have not been added yet. Set only by the Finder */
                                        /* Reserved for folders - make sure this bit is cleared for folders */
                                        /* bit 0x0200 was the letter bit for AOCE, but is now reserved for future use */
  kHasCustomIcon                = 0x0400, /* Files and folders */
  kIsStationery                 = 0x0800, /* Files only */
  kNameLocked                   = 0x1000, /* Files and folders */
  kHasBundle                    = 0x2000, /* Files only */
  kIsInvisible                  = 0x4000, /* Files and folders */
  kIsAlias                      = 0x8000 /* Files only */
};[/SIZE]

Je vais approfondir la question.



NB: concernant le problème initial, j'ai testé le transfert de fichiers présentant différents attributs étendus avec un serveur SAMBA sous Windows XP, dans les deux sens. Les attributs étendus se retrouvent dans les data streams de NTFS, et sont bien conservés au retour sur le Mac.

---------- Nouveau message ajouté à 23h32 ---------- Le message précédent a été envoyé à 22h18 ----------

La valeur 0x0010 des flags Finder semble correspondre au positionnement du bit "never switch-launch" (d'après la documentation relative à l'enregistrement du format HFS sur CD ISO 9660). Mais cet usage semble obsolète. Je continue à chercher à quoi peut servir ce bit.
 

ataraxie44

Nouveau membre
9 Avril 2010
9
0
Bonjour,

Merci pour les recherches.
Je compte sur toi car là je suis complètement calé et ne sais plus quoi tester.
S'il te faut des infos, n'hésite pas.

Merci

---------- Nouveau message ajouté à 17h15 ---------- Le message précédent a été envoyé à 16h46 ----------

q1 : est-ce normal le @ ?
q2 : les droits unix ne sont pas respectés, pk ? acl ?
q3 : est-ce normal que les fichiers se créer par défaut avec un tel masque ? et avec un @ ?
lorsque je créer un fichier via le terminal je n'ai pas le @


merki :sleep:
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
597
Île-de-France
q1: le @ est normal parce qu'il y a des attributs étendus. Pour la présence des attributs étendus, c'est une autre paire de manche.

q2: je ne sais pas. Mais je n'arrive pas trop à comprendre ce qui se passe à ce niveau chez toi.

q3: chez moi, les fichiers créés avec TextEdit ne sont pas accompagnés des attributs de tes fichiers. J'essaye de trouver un moyen de reproduire le phénomène.

Aurais-tu installé un logiciel particulier sur ton Mac ?
 

ataraxie44

Nouveau membre
9 Avril 2010
9
0
logiciels installés :
Adobe PS 4 / ILL 4 / Dreamwaver
Logic
Office 2008
Filezilla
Smultron
Firefox
Vlc

Ce sont les seuls que j'ai installé
 

ataraxie44

Nouveau membre
9 Avril 2010
9
0
La solution ENFIN !!!!!
Après plusieurs réinstallations, c'est en fait la mise a jour 10.6.3 v 1.1 qui posait souci.
Samba a été mis à jour quasiment en même temps.
La solution ici :
http://splatdot.com/fixing-snow-leopard-10-6-3-samba-write-access/

Il suffit d'ajouter 'unix extensions = no' au smb.conf

Ceci est une solution mais n'explique pas du tout le problème.

J'espère que ça en aidera certain. Admin, peux-tu renommer mon sujet de discussion car je ne pense pas que se soit un problème de chiffrement.

Encore merci PA5CAL pour le temps passé