Problème de lecture à Quicktime Streaming Server

Abondance

Nouveau membre
15 Novembre 2008
4
0
www.mcm.asso.fr
Bonjour,

Je travaille pour une association et nous essayons de mettre en ligne des captations vidéo de nos spectacles et concerts en mp4 H264 hinted pour notre site web.

Nous avons un serveur distant équipé de XServe 10.5 et Quicktime Streaming Server.
QTSS semble paramétré normalement. La société qui héberge le serveur accède sans problème à nos vidéos avec sa propre connexion internet.

Dans mon cas et celui de mes collèges, impossible avec Quicktime 7.5.5. En revanche ça marche avec VLC, ce qui est un comble...

J'ai fait le test à partir de ma connexion wanadoo au bureau et free à la maison.

ex:rtsp://mcm.base-alexandrie.fr/kirghiz3.mp4

Quelqu'un a-t-il rencontré un problème analogue en installant son propre QTSS*?

Merci
 

samalaplaya

Membre d’élite
Club MacG
16 Mars 2005
3 164
120
Non, non, évidemment ma réponse était courte, mais dans QT > cmd + u > ledit lien collé, tout fonctionne correctement, c'est bien ça que ça voulait dire.

À part Pref système > QT > Avancées > config. transport: automatique, ce qui de toutes façons doit être le cas par défaut, je ne comprends pas bien ce qui pourrait se passer (p-e Pref système > sécurité > coupe-feu > autoriser les connections entrantes de QT, mais je pense que ça doit aussi être le cas par défaut).
Je ne vois pas, sinon.
 

Abondance

Nouveau membre
15 Novembre 2008
4
0
www.mcm.asso.fr
Non, non, évidemment ma réponse était courte, mais dans QT > cmd + u > ledit lien collé, tout fonctionne correctement, c'est bien ça que ça voulait dire.

À part Pref système > QT > Avancées > config. transport: automatique, ce qui de toutes façons doit être le cas par défaut, je ne comprends pas bien ce qui pourrait se passer (p-e Pref système > sécurité > coupe-feu > autoriser les connections entrantes de QT, mais je pense que ça doit aussi être le cas par défaut).
Je ne vois pas, sinon.
Merci beaucoup pour ces précisions.
Effectivement, je n'ai pas vérifié l'état du coupe-feu.
Cela dit, avec le même ordinateur à mon bureau à Paris et ceux de mes collègues (FAI Orange Business ex-Oléane) ça fonctionne impeccablement. Connexion immédiate, fluide, parfaite.
Peut-être devrions-nous activer le port 80 sur QTSS ? Nous ne l'avons pas fait.
Sincèrement
 

Abondance

Nouveau membre
15 Novembre 2008
4
0
www.mcm.asso.fr
Problème résolu.
Il ne faut surtout pas suivre les instructions du manuel qui veut que l'on se connecte en rtsp:// mais au contraire le faire en http:// après avoir activé le port 80 sur Quicktime Streaming Server.
La connexion devient beaucoup plus stable, universelle et fluide. Le fichier s'ouvre à l'intérieur d'une page html (si l'on a le plug-in Quicktime Player), sinon il déclenche le lancement d'un lecteur (Quicktime ou RealPlayer 11 ou VLC selon l'installation de chacun).
 

enka

Membre confirmé
8 Octobre 2003
137
27
95
fr.linkedin.com
.
Il ne faut surtout pas suivre les instructions du manuel qui veut que l'on se connecte en rtsp:// mais au contraire le faire en http://
Pas forcément ;)

Le fait de passer par le port 80 permet de traverser la plupart des firewall qui ne bloquent pas le port 80 (accès web) et donc dans ce cas là l'adresse est bien htpp://

Mais on peut aussi imaginer des application qui n'accèdent pas au port 80 et qui ne fonctionnent qu'en rstp par exemple.

Donc tout dépend de l'utilisation et de l'utilisateur final...

Mais en tout cas, bravo pour votre serveur, ça marche du tonnerre (en rstp chez moi)