• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

probleme de path (enfin je pense)

marsu_381

Membre junior
21 Octobre 2003
34
0
J'ai installé the gimp depuis fink. Mais lorsque je lance X11 sepuis sont icone, puis que je veux lancer gimp depuis le terminal il ne me le trouve pas. Mais lorsque je fais un startx puis que je le lance depuis le terminal qui apparait la c bon. J'ai le meme problème avec fink.

Je pense que le path doit pas etre le meme pour les 2 terminal.

Comment je fais pour avoir le meme sur les 2 terminal ?
 

molgow

Vétéran
Club MacG
4 Janvier 2002
5 493
612
36
Suisse
www.monts-chevreuils.ch
Si tu tapes "echo $SHELL" dans ton terminal normal et ton terminal X11 est-ce que ça retourne pareil ? (par défaut, ça devrait).
Tu peux aussi faire "echo $PATH" pour voir quels sont les dossiers où le shell ira cherché les commandes tapées.
Si jamais, le PATH est probablement configuré dans les fichiers .tcshrc, .cshrc, ... Tu peux éventuellement rajouté les path nécessaires dans le fichier qu'il faut.
 

Eymerich

Membre junior
5 Avril 2003
61
3
51
Paris
J'ai eu un problème équivalent avec mon mac de maison et X11: le chemin dans l'application Terminal n'était pas le même que sous xterm sous x11.

j'ai du jongler avec les fichiers de lancement,mais je ne sais plus bien comment.


le chemin dans le terminal apple est par exemple dans .cshrc (ou dans des endroits moins orthodoxes si on suit les indication d'apple)

sous x11, le processus de démarrage de X11 semblait ecraser chez moi les déclarations dans .cshrc! x11 semble imposer son propre chemin.

Ici on traite du même problème mais pour un shell sous bash
http://www.macosxhints.com/article.php?story=20030825001724805

les indications n'ont pas marché chez moi, mais en faisant je ne sais plus quoi, ça a fini par tourner...

Courage